Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: AverMedia MR800 USB Radio  (Прочитано 6643 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн hober

  • Автор темы
  • Новичок
  • *
  • Сообщений: 38
    • Просмотр профиля
AverMedia MR800 USB Radio
« : 01 Ноябрь 2007, 09:11:35 »
Небольшой faq по настройке
Ставим chmod 777 на /dev/usb/hiddev0
Качаем amusbradio-0.01.tar.bz2, распаковываем.
Делаем make

Запускаем,где 106.00 - частота радиостанции, звук регулирется в самой системе
./amusbradio -S 106.00
Должно высветиться:
found 'AVerMedia Technologies AVerMedia USB Radio' at '/dev/usb/hiddev0'




[вложение удалено Администратором]

Оффлайн Блуждающая девственница

  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: AverMedia MR800 USB Radio
« Ответ #1 : 23 Октябрь 2008, 14:10:15 »
Спасибо большое. Долго искал фак. Как написано, так и работает. Только у меня с параметром -S не заработало. а без него, когда просто частоту указал -- всё отлично заиграло.

Оффлайн CityAceE

  • Активист
  • *
  • Сообщений: 475
  • Ubuntu 16.04 amd64
    • Просмотр профиля
    • Speccy - наш выбор!
Re: AverMedia MR800 USB Radio
« Ответ #2 : 08 Ноябрь 2008, 12:24:40 »
Большое спасибо! А то я уже думал, то остался без радио под Линуксом. Правда методика использования оставляет желать лучшего. Очень плохо, что всё происходит исключительно через командную строку. А как же GUI? Может быть существует какое-то универсальное решение под такие цели? Или всё, что остаётся разместить на рабочем столе кучу скрипотов?
С уважением, Станислав.

Оффлайн CityAceE

  • Активист
  • *
  • Сообщений: 475
  • Ubuntu 16.04 amd64
    • Просмотр профиля
    • Speccy - наш выбор!
Re: AverMedia MR800 USB Radio
« Ответ #3 : 26 Апрель 2009, 04:50:30 »
М-да... Переставил на бело Ubuntu 9.04 и теперь не могу снова настроить радио. У меня теперь просто отсутствует /dev/usb/hiddev0

Вот, что выдаёт lsusb:
stanislav@ZX-Spectrum:~/1/amusbradio-0.01$ lsusb
Bus 001 Device 007: ID 0457:0151 Silicon Integrated Systems Corp. Super Flash 1GB / GXT  64MB Flash Drive
Bus 001 Device 004: ID 05e3:070e Genesys Logic, Inc. X-PRO CR20xA USB 2.0 Internal Card Reader
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 005: ID 07ca:b800 AVerMedia Technologies, Inc.
Bus 002 Device 004: ID 046d:c219 Logitech, Inc. Cordless RumblePad 2
Bus 002 Device 003: ID 045e:0095 Microsoft Corp. IntelliMouse Explorer 4.0 (IntelliPoint)
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

В ReadMe  к amusbradio написано:
Цитировать
1.1 Prereq

A Kernel with the possibility for raw hiddev access should be
installed (all 2.6.x are equipped with it, maybe even the 2.4.x, but I don't
know).

USB support has to be enabled and the usbhid module has to be loaded (or
included within the kernel). On recent distributions there is the hotplug
daemon which does the loading for you when you plug in the usbradio.

Пока мест не удаётся решить проблему. Прошу помощи!
С уважением, Станислав.

Оффлайн DebianBoy

  • Активист
  • *
  • Сообщений: 304
    • Просмотр профиля
Re: AverMedia MR800 USB Radio
« Ответ #4 : 31 Май 2009, 14:56:36 »
Решение проблемы для ядер 2.6.28 и выше:

Вставляем свое AverMedia USB Radio. Запускаем машину. В dmesg убеждаемся, что девайс распознан и загружен для него соответствующий драйвер radio-mr800. А также, в /dev появился файлик -radio0. Если да, то радуемся :)

Дальше я делал так:

sudo chmod 777 /dev/radio0
Все. Запускаем Gnomeradio и слушаем любимые частоты эфира ;)

P.S. Дело в том, что в ядрах .28 и выше убран теперь /dev/usb/hiddev. После долгого гугления я наткнулся на Алексея Климова, который и написал собственно этот патч для ядра. Сделано это в пользу правильной работы v4l, то бишь для тв- и фм- тюнеров. Теперь Ваш AverMedia USB-Stick Radio является виртуально-полноценным фм-тюнером, как будто это реальная FM Tuner Card, как я понял :)

P.P.S. Чтобы были права постоянно и каждый раз не вводить sudo chmod 777 /dev/radio0 вероятно надо добавить себя в группу, возможно в audio. Еще не разбирался. Кто в курсе - тот в курсе ;)
« Последнее редактирование: 02 Июнь 2009, 15:47:45 от UbuntuBoy »
Debian и только Debian :)

Оффлайн TEX_SP

  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: AverMedia MR800 USB Radio
« Ответ #5 : 26 Февраль 2010, 23:00:37 »
Хм, что то у меня не получается....
Ставлю на ubuntu 9.04 (более новую версию для установки не предлагать), установил «Gnomeradio» (был скачен на репозитарии через виндовс (потому что модем диолап не работает под Ubuntu) и установлен),  запускаю, он выдаёт что /dev/radio0 нет доступа (изменил группу не помогло, «sudo chmod 777» также не помогло) или /dev/radio0 используется другим приложением.
Файл  radio0, весит 0 байтов (это и должно быть так, по моему мнению там должно быть конфигурация).
> В dmesg убеждаемся, что девайс распознан и загружен для него соответствующий драйвер radio-mr800.
Dmesg, выдал большой список (в нём так и не разбирался), но файл  radio0 присутствует.
Radio-mr800, присутствует в установленных пакетах (был уставлен после установки «Gnomeradio» вернее был им установлен).
Так, куда копать дальше что бы AverMedia MR800 USB Radio, заработало??

 

Страница сгенерирована за 0.058 секунд. Запросов: 24.