Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: PPP poff/pon делает два соединения ppp0 и ppp1 вместо одного (2 сетевухи)  (Прочитано 1441 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн silenceod

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Такая проблема. В компе 2 сетевые карты. Одна подключена вторая просто болтается.

Сеть настроена через /etc/network/interfaces
/etc/init.d/networking stop/start поднимает все соединения нормально.

Но если сделать poff -a ; pon mypprovider запускаются два pppd сервера и в списке интерфейсов указывается ppp0 и ppp1. Разумеется, интернет не работает.

Если перезагрузить сеть опять то опять все ок.
Проверил опытным путем (добавил echo ... >> /tmp/test) - команда pon у меня запускает 2 раза скрипт /usr/bin/pon с одними и теми же параметрами. Какого такого фига это происходит и как указать что второе (ppp1) подключение создавать не надо?


ps:
как правильно вместо /etc/init.d/networking перезагружать сеть, а то пишет что этот способ в Ubuntu устарел?
« Последнее редактирование: 08 Май 2011, 17:33:02 от silenceod »

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Сеть настроена через /etc/network/interfaces
/etc/init.d/networking stop/start поднимает все соединения нормально.
Ну хоть покажите этот самый interfaces и проясните, что Вы подразумеваете под "все соединения" и подтвердите это выхлопом
ifconfig -a
как правильно вместо /etc/init.d/networking перезагружать сеть, а то пишет что этот способ в Ubuntu устарел?
Версия убунты-то какая? Догадаться должны?
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн jiceman

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Автор сабжа куда-то пропал и не отписался.

Была аналогичная проблема: т.е. когда делаю
root@linx-ice:~# pon dsl-providerподнимаются ppp0 и ppp1, затем через 5 сек падают и инета нет.


Проблему решил так. В файле /etc/network/interfaces вместо
'iface ppp0 inet ppp' прописал 'iface dsl-provider inet ppp'
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.3.165
netmask 255.255.0.0
gateway 192.168.0.8
dns-nameservers 192.168.0.8

auto dsl-provider
iface dsl-provider inet ppp
pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
provider dsl-provider

#auto ppp0
#iface ppp0 inet ppp
#pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
#provider dsl-provider

auto eth1
iface eth1 inet static
address 20.10.10.1
netmask 255.255.255.0
gateway 192.168.0.8
dns-nameservers 192.168.0.8
pre-up iptables-restore < /etc/network/miptables.save
#pre-down iptables-save -c > /etc/network/miptables.save

Собственно вопрос:
Хотелось бы понять почему конфиг с iface ppp0 не работает (ведь сам интерфейс называется именно ppp0, а не dsl-provider)?

Всем кто растолкует заранее спасибо.

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Если почитать man к interfaces, то можно вычитать следующее:
Цитировать
Lines  beginning with the word "auto" are used to identify the physical interfaces to be brought up when ifup is run with the -a option.
То есть это касается только ФИЗИЧЕСКИХ интерфейсов.
ppp-же является виртуальным интерфейсом. Читаем что написано про ppp в том же мане
Цитировать
The ppp Method
       This method uses pon/poff to configure a PPP interface. See those  commands for details.
       Options
              provider name
                     Use name as the provider (from /etc/ppp/peers).
переводить?
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн jiceman

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Спасибо за ответ, проясните уж тогда и вот что.
Почему если в interfaces имеем
auto ppp0
iface ppp0 inet ppp
и запускаем через ifup -a   , то всё работает превосходно? несмотря на то, что через pon dsl-provider поднимаются два интерфейса и сразу падают?

и второе, если auto касается только физических ифейсов, почему auto ppp0 срабатывает?

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Не совсем только физических интерфейсов. Если Вам инересно, то изучите man. Будет непонятно - спрашивайтею
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн shushpanchik

  • Активист
  • *
  • Сообщений: 296
    • Просмотр профиля
    • SKSS - "Современные компьютерные сети и системы"
Есть вот такое решение.

1. Из /etc/network/interfaces убираем интерфейс, который смотрит на провайдера.
2. Например в rc.local добавляем
/sbin/ifconfig eth0 up
/etc/ppp/pppoe_on_boot
3. Радуемся результату.

В коде описан мой вариант. Работает.
(Нажмите, чтобы показать/скрыть)

 

Страница сгенерирована за 0.11 секунд. Запросов: 24.