Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Проблемы с новым сервером LAMP Ubuntu 10.04  (Прочитано 745 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн rovnik

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Я начинающий линуксоид, у нас в инфраструктуре были одни Windows сервера, я решил начать сокращать их количество, и решил начать с веб сервера на котором крутится внутренний портал.Я установил Ubuntu Server 10.04 LTS сделал даунгрейд php до версии 5.2.17 настроил виртуальные сайты, прикрутил полноценную gd библиотеку, перенёс все сайты со старого сервера, перенёс mysql бд. Всё заработало, хоть и отняло у меня приличное количество времени. Встал вопрос бэкапа, т.к. я всё бэкаплю symantec backup exec, я решил и этот сервер бэкапить им, но выяснилось что BE не поддерживает ubuntu, но с помощью гугла я смог установить необходимые библиотеки и запустить бекап агента на своём LAMP сервере, после перезагрузки он заработал. Я уже ликовал, решил сделать финальную перезагрузку и тут случилось страшное сервер перестал грузится вообще,как я понял он даже не может замаунтить ни одного раздела, всё что я вижу это многочисленные надписи scsi: killing requests for dead queue. И всё труп. Подскажите какие варианты решения есть? Сейчас я думаю что надо как-то проверить файловую систему в первую очередь, но как это сделать? И я на самом деле не понимаю причины сбоя, железо проверенное  (сервер работает уже 4 года - 1U серв, с двумя скази винтами по 140 гб.).  Я всегда думал что линукс системы надёжнее Windows, но теперь начинаю сомневаться. В общем прошу помощи, ибо заново всё это конфигурировать мне уж очень не хочется. Заранее Спасибо!  :)

Оффлайн RustemNur

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 2933
  • умрешь с вами
    • Просмотр профиля
Re: Проблемы с новым сервером LAMP Ubuntu 10.04
« Ответ #1 : 15 Январь 2012, 00:41:35 »
Ну попробуйте для начала с LiveCD загрузиться, посмотрите, что с винтами и т.д.

Оффлайн rovnik

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Проблемы с новым сервером LAMP Ubuntu 10.04
« Ответ #2 : 15 Январь 2012, 02:07:01 »
Я загрузился с дектопной убунты но в гпарт увидел только её разделы  :(

Оффлайн rovnik

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Проблемы с новым сервером LAMP Ubuntu 10.04
« Ответ #3 : 16 Январь 2012, 15:53:42 »
Удалось увидеть разделы fsck пишет:

Attempt to read block from filesystem resulteed in short read while trying to open /dev/sda2
Could this be a zeo-length partition
не знаю что делать

Оффлайн rovnik

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Проблемы с новым сервером LAMP Ubuntu 10.04
« Ответ #4 : 19 Январь 2012, 11:38:52 »
Мне удалось оживить север следующим образом:

1. Загрузился c Live CD
2.Установил lvm sudo apt-get install lvm23.Просканировал lvm разделы:
sudo pvscan
sudo vgscan
4.Увидел группу интересующих меня разделов и активировал их sudo vgchange -a y LAMP5.Вызвал листинг логических томов sudo lvscan6.И над одним из них сделал проверку файловой системы (в моём случае был том root)sudo fsck /dev/LAMP/root7.Начал загружать систему она вывела кучу "квадратов" и судя по тому, что я понял она сообщала, что найдено множество ошибок, кроме "квадратов" были видны только буквы F,I и ещё какие-т.Я так понял что это вопрос и нажал F (как я понял  fix)
8.После этого система перегрузилась и запустилась в обычном режиме.

P.S. Единственное, теперь меня мучает вопрос из-за чего и стоит ли вообще использовать данную систему....  :-[ И судя по всему некоторые файлы просто перестали существовать  >:(
« Последнее редактирование: 19 Январь 2012, 11:48:43 от rovnik »

 

Страница сгенерирована за 0.056 секунд. Запросов: 24.