Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Значки папок на NTFS разделах  (Прочитано 826 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Internet

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Значки папок на NTFS разделах
« : 07 Февраль 2012, 13:34:47 »
Имеется kubuntu 11.10 с дефолтными иконками oxygen и следующая проблема - на разделах с NTFS все папки отображаются со стандартным значком, хотя в свойствах выставлены другие иконки. На корневом ext4 всё работает как надо - можо повесить на папку значёк музыки или сделать её жёлтой и он будет отображаться. НА свежепримонтированных флешках fat32 тоже иконки нормально работают. раньше всё было нормально, так что сказать после чего началась проблема не могу - незаметно как-то произошло. Если загрузиться с LiveCD или из-под чистой системы то все папки отображаются с назначенными им значками, но возвращаюсь в нормальную систему и они опять отображаются стандартным значком папки. Файлы .desktop впорядке, пробовал начисто удалять папку home - не помогает, из чего сделал вывод что дело не в пользовательских настройках - в чём может быть проблема?

Оффлайн oddworld

  • Активист
  • *
  • Сообщений: 404
    • Просмотр профиля
Re: Значки папок на NTFS разделах
« Ответ #1 : 07 Февраль 2012, 14:49:24 »
в параметрах монтирования может?
нет ничего совершенного, и не будет...

Оффлайн Internet

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Значки папок на NTFS разделах
« Ответ #2 : 07 Февраль 2012, 18:38:27 »
в параметрах монтирования может?
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc /proc proc nodev,noexec,nosuid 0 0
#Entry for /dev/sda1 :
UUID=82f1ab67-9921-43d0-b8fb-9020923aa157 / ext4 errors=remount-ro 0 1
#Entry for /dev/sdb1 :
UUID=144AF91D4AF8FBF4 /media/Data ntfs-3g nodev,noexec,nosuid,locale=ru_RU.UTF-8 0 0
#Entry for /dev/sdb2 :
UUID=DE135B8C3A00B297 /media/Video ntfs-3g nodev,noexec,nosuid,locale=ru_RU.UTF-8 0 0

вроде бы ничего ненормального, но на всякий откатил на стандартный кубунтовский вариант и безрезультатно :(
« Последнее редактирование: 07 Февраль 2012, 18:40:40 от Internet »

Оффлайн oddworld

  • Активист
  • *
  • Сообщений: 404
    • Просмотр профиля
Re: Значки папок на NTFS разделах
« Ответ #3 : 07 Февраль 2012, 19:49:12 »
noexec попробуй убрать из параметров монтирования
нет ничего совершенного, и не будет...

Оффлайн Internet

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Значки папок на NTFS разделах
« Ответ #4 : 07 Февраль 2012, 20:02:24 »
попробовал - безрезультатно...
да вроде бы fstab давно не правился, так что вряд ли в нём дело

Пользователь решил продолжить мысль 07 Февраль 2012, 23:04:00:
и ещё интересное наблюдение - у тех папок, которым иконки были заданы раньше, в свойствах папки показываются правильные иконки, их можно поменять на стандартую или на любую другую. Но если создать новую папку и задать ей значёк - то он даже не сохраняется, и если заного открыть свойства, то там будет дефолтный значёк.

Пользователь решил продолжить мысль 07 Февраль 2012, 23:23:17:
и ещё наблюдение - на папки созданные из-под винды значёк в свойствах вешается ,но всё равно не отображается. Может дело где-то в реализации ntfs под линуксом - что-то удалилось или полетело?

Пользователь решил продолжить мысль 07 Февраль 2012, 23:40:52:
если снести ntfs-3g то иконки появляются, но с диском нормально работать само-собой уже не получится
« Последнее редактирование: 07 Февраль 2012, 23:40:52 от Internet »

 

Страница сгенерирована за 0.077 секунд. Запросов: 25.