Форум русскоязычного сообщества Ubuntu


Автор Тема: Ошибка при конвертации .rpm в .deb  (Прочитано 2726 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ognedar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Ошибка при конвертации .rpm в .deb
« : 17 Июль 2012, 21:06:47 »
При конвертации .rpm в .deb
sudo alien jdk-7u5-linux-x64.rpmполучается
error: open of vspace=3></td> failed: No such file or directory
error: open of <td><a failed: No such file or directory
error: open of href=http://www.oracle.com/us/sitemaps/index.html </tr> <tr valign=middle> <td align=right valign=top><img src=/errors/us/assets/004894.gif height=7 vspace=3></td> <td><a href=http://www.oracle.com/technetwork/index.html>OTN Homepage</a></td> </tr> </table> <br> <div id=footer> <table width=100%  border=0 cellspacing=0 cellpadding=0> <tr> <td width=50% class=legalese align=right valign=top>&nbsp;</td> <td width=50% class=legalese align=left valign=top >&nbsp;</td> </tr> <tr> <td width=50% class=legalese align=left valign=top>&nbsp;</td> <td width=50% class=legalese align=right valign=top><a class=legalese href=http://www.oracle.com/rss/index.html target=_top>RSS <img src=/errors/us/assets/feed-icon-14x14.png width=14 height=14 border=0></A><span class=navlink> | </span> <a class=legalese href=http://www.oracle.com/html/copyright.html target=_top>Legal Notices and Terms for Use</a><span class=navlink> | </span> <a class=legalese href=http://www.oracle.com/html/privacy.html target=_top>Privacy Statement</a><br /> </td> </tr> <tr> <td width=50% class=legalese align=right valign=top>&nbsp;</td> <td width=50% class=legalese align=left valign=top ></td> </tr> </table> </div> </td> <TD WIDTH=10><IMG SRC=/errors/us/assets/spacer.gif BORDER=0 ALT= WIDTH=10></TD> </tr> </table> </body> </html> failed: No such file or directory
Error executing "LANG=C rpm -qp --queryformat %{NAME} 'jdk-7u5-linux-x64.rpm'":  at /usr/share/perl5/Alien/Package.pm line 489.
Как это победить?
ubuntu-server 12.04 x64
Ubuntu 12.04 i386

Оффлайн svetz

  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Ошибка при конвертации .rpm в .deb
« Ответ #1 : 17 Июль 2012, 21:26:03 »
Попробуйте так.

Оффлайн Ognedar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Ошибка при конвертации .rpm в .deb
« Ответ #2 : 18 Июль 2012, 14:25:16 »
Спасибо, помогло.
add-apt-repository не работало, вылечил этим
sudo apt-get install --reinstall python-software-properties && sudo dpkg-reconfigure python-software-properties
Все же хотелось бы узнать что не так с Alien и как с этим бороться.
« Последнее редактирование: 18 Июль 2012, 15:44:39 от Ognedar »
Ubuntu 12.04 i386

Оффлайн svetz

  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Ошибка при конвертации .rpm в .deb
« Ответ #3 : 18 Июль 2012, 21:51:33 »
встречал такую же точно ошибку на 10.04. Короче, подозреваю, что проблема именно в оракловских пакетах.

Что до add-apt-repository, то и через синаптик это делается просто.

Оффлайн medprofy

  • Любитель
  • *
  • Сообщений: 57
    • Просмотр профиля
Re: Ошибка при конвертации .rpm в .deb
« Ответ #4 : 25 Декабрь 2012, 17:31:54 »
Вот такая ошибка еще
jre-7u10-linux-i586.rpm is for architecture i386 ; the package cannot be built on this system
   find jre-1.7.0_10 -type d -exec chmod 755 {} ;
   rm -rf jre-1.7.0_10

Что делать? Очень нужно установить на 64-разрядный (Ubuntu 11.10) Java SE Runtime Environment (JRE) версии не ниже 1.6_14

И еще пишет:
in_oji.so
   chown 0:0 jre-1.7.0_10//usr/java/jre1.7.0_10/release
   chmod 644 jre-1.7.0_10//usr/java/jre1.7.0_10/release
   mkdir jre-1.7.0_10/debian
   hostname
   date -R
   hostname
   date -R
   chmod 755 jre-1.7.0_10/debian/rules
jre-7u10-linux-i586.rpm is for architecture i386 ; the package cannot be built on this system
   find jre-1.7.0_10 -type d -exec chmod 755 {} ;
   rm -rf jre-1.7.0_10

Оффлайн dj--alex

  • Старожил
  • *
  • Сообщений: 3209
  • Понимаешь, я какбы беру в руки лопату и говорю...
    • Просмотр профиля
    • все мои творения и занятия
Re: Ошибка при конвертации .rpm в .deb
« Ответ #5 : 24 Октябрь 2014, 03:28:01 »

 ~/Закачки $ sudo  alien iscan-2.10.0-1.c2.i386.rpm deb
Warning: Skipping conversion of scripts in package iscan: postinst postrm preinst prerm
Warning: Use the --scripts parameter to include the scripts.
iscan-2.10.0-1.c2.i386.rpm is for architecture i386 ; the package cannot be built on this system

инструкцию смотрел тут http://forum.relaxdom.net/showthread.php?t=55206
ой внезапно выяснилось что компьютер то 64-битный
всё человеку говорить сканер выкидывать?

мне нужно этот файл отконвертить в деб
Ubuntu 16.04.1 MATE x64, 18.1 x64 Mate, MX-Linux 16 Mate Mate Mate Mate. PC:?\FX4100@4ghz\8Gb\2TB HDD\1060gtx\90GB Ocz
https://forum.ubuntu.ru/index.php?topic=199897.0

Оффлайн victor00000

  • Старожил
  • *
  • Сообщений: 14855
  • Я не слышу.
    • Просмотр профиля
~.o

 

Страница сгенерирована за 0.055 секунд. Запросов: 24.