Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: IDE Netbeans руби проект. не подсвечивает синтаксис javascript  (Прочитано 1541 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн only_dimon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Добрый вечер!

Не могу понять в чем, дело. Поставил Netbeans 7.0.1. Пакеты для Java и Ruby.
А javascript не подсвечивает. Вообще как про него забыло. И файл новый js создать нельзя и в списке MIME-типов его нет (Tools-Options-Miscellanious-Files)

В плагин файндере для js только JSLint находит. Искал ручками, Javascript editor и тому подобное - ничего не нашел. Везде написано, что Netbeans подсвечивает html, css и js по умолчанию.

Подскажите, пожалуйста, что делать.

Оффлайн Crush

  • Любитель
  • *
  • Сообщений: 83
    • Просмотр профиля
может Вы автокомплит имеете ввиду, так как синтаксис javascript netbeans вроде как подсвечивает?!

Оффлайн only_dimon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Нет, вовсе не автокомплит. В том то и дело, что везде написано, что подсвечивает. А у меня нет. Открываю файл admin.js, к примеру, и весь код одного цвета.
HTML подсвечивает исправно, javascript нет. HTML и CSS файлы создать в рамках проекта можно, javascript - нельзя. Как будто он про существование JS забыл.:o Может есть какой-то пакет JS который вручную доставить можно?

P.S. У меня руби проект, может быть в этом дело?

Оффлайн Crush

  • Любитель
  • *
  • Сообщений: 83
    • Просмотр профиля
ну вот пример подсветки, не очень конечно, но есть


все из коробки, правда версия netbeans под винду, но думаю там не сильно отличается....
а какую сборку netbeans Вы устанавливали? странно что нельзя создавать js файлы из коробки

Оффлайн only_dimon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Да, очень странно.

Установил из центра приложений Ubuntu IDE 7.0.1. Вначале поставился пакет Java, потом доставил пакет Ruby.

Скрины по ссылкам ниже:

http://screenshot.su/show.php?img=6ce39ec3ce0823257ee20db340c4377a.jpg
http://screenshot.su/show.php?img=2b26479785991bc384f2b8e96b1f48ef.jpg

Оффлайн Crush

  • Любитель
  • *
  • Сообщений: 83
    • Просмотр профиля
в репе старая версия, попробуйте переустановить с офф сайта тыц (хотя дело скорее всего не в этом), можете доставить плагины для PHP, там по любому будет поддержка js (правда еще дополнительно доставит поддержку html и css но думаю это наврятли будет сильно мешать) 

Оффлайн only_dimon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Да, спасибо за совет. И, правда, в репе странная версия была. Устанавливал к ней PHP, все равно js поддержка не появилась.

Помог снос и установка такой же версии с офф. сайта.

Оффлайн Haron Prime

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 11313
  • Нетолерантный социопат
    • Просмотр профиля
Решено. Закрыто.

 

Страница сгенерирована за 0.101 секунд. Запросов: 25.