Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Не работают новые драйвера Ubuntu 12.04 GeForce 9600GT  (Прочитано 7694 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн k790

  • Автор темы
  • Участник
  • *
  • Сообщений: 218
    • Просмотр профиля
    • Компьютерная - Лаборатория
Re: Не работают новые драйвера Ubuntu 12.04 GeForce 9600GT
« Ответ #30 : 18 Февраль 2013, 14:20:25 »
k790,
Поставьте вот так. Только не обновляйтесь в промежутках. У меня сейчас так стоит.
sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-310
sudo add-apt-repository -r ppa:xorg-edgers/ppa
Выполните подряд обязательно все команды. Иначе могут быть большие проблемы. Получите самый последний стабильный 310 драйвер. Но не факт, что он будет хорошо работать с вашей старенькой видюхой.

Как и раньше - чёрный экран консоли
Цитировать
Но если поставить новый xorg c новым ядром, то работать будет гораздо шустрее.

Поставил, гуи заработало, но видно драйвер слетел, запустил стим и в терминал предложил удалить новое ядро.

Диагноз: поскольку старая видюха и дрова под неё плохие, то ничего не получится?

Pilot6

  • Гость
Re: Не работают новые драйвера Ubuntu 12.04 GeForce 9600GT
« Ответ #31 : 18 Февраль 2013, 14:43:29 »
k790,
Видимо да. 9000 серия видимо все-таки не поддерживается драйвером 310. Возвращайтесь на 304.64 и живите без стима. Ну или купите новую видеокарту.

Оффлайн DDA-E398

  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Re: Не работают новые драйвера Ubuntu 12.04 GeForce 9600GT
« Ответ #32 : 18 Февраль 2013, 23:06:03 »
Попробуй так:

sudo apt-get remove --purge nvidia-*
sudo rm /etc/X11/xorg.conf

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

sudo apt-get uddate
sudo apt-get upgrage

sudo apt-get install nvidia-common ubuntu-desktop
sudo apt-get install --reinstall xserver-xorg-video-nouveau
sudo dpkg-reconfigure xserver-xorg
sudo apt-get install --reinstall linux-headers-generic
sudo apt-get install --reisntall linux-source dkms
sudo reboot

sudo apt-get install nvidia-current nvidia-settings (либо sudo apt-get install nvidia-310 nvidia-310, либо sudo apt-get install nvidia-313 nvidia-313)
sudo nvidia-xconfig
sudo reboot

Мне пару раз уже помогало после неудачных экспериментов с дровами :)
Если что пиши в асю, помогу чем смогу 47968О21О

Tritus

  • Гость
Re: Не работают новые драйвера Ubuntu 12.04 GeForce 9600GT
« Ответ #33 : 19 Февраль 2013, 02:34:56 »
k790,
Видимо да. 9000 серия видимо все-таки не поддерживается драйвером 310. Возвращайтесь на 304.64 и живите без стима. Ну или купите новую видеокарту.
Сайт nVidia говорит об обратном -драйверы 310.32 для Linux поддерживают и 8-ю, и 9-ю серии.

Оффлайн k790

  • Автор темы
  • Участник
  • *
  • Сообщений: 218
    • Просмотр профиля
    • Компьютерная - Лаборатория
Re: Не работают новые драйвера Ubuntu 12.04 GeForce 9600GT
« Ответ #34 : 26 Февраль 2013, 20:02:59 »
Извините за долгое отсутствие.
Как всегда проблемы:
sudo apt-get install --reinstall xserver-xorg-video-nouveau
Цитировать
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 xserver-xorg-video-nouveau : Зависит: xorg-video-abi-12
                              Зависит: xserver-xorg-core (>= 2:1.11.99.901)
                              Рекомендует: libgl1-mesa-dri (>= 7.11.1)
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Я пока удалю драйвер:
sudo apt-get remove --purge nvidia-*
P.S.
у вас опечатки в командах:
Цитировать
sudo apt-get uddate
sudo apt-get upgrage

А должно быть:
sudo apt-get update
sudo apt-get upgrade

Оффлайн k790

  • Автор темы
  • Участник
  • *
  • Сообщений: 218
    • Просмотр профиля
    • Компьютерная - Лаборатория
Поставил новые драйвера на видео, но Ubuntu теперь ругается на amd ucode:
microcode: failed to load file amd-ucode/microcode_amd.bin
Как поставить его?

chemtech

  • Гость
k790,
sudo aptitude install apt-file
sudo apt-file update
apt-file search microcode_amd.bin

Цитировать
amd64-microcode: /lib/firmware/amd-ucode/microcode_amd.bin

Pilot6

  • Гость
k790,
Это не "теперь ругается", а просто сплеш теперь не графический. Поэтому эту ругань видно.
Можно сделать вот что:
1. Вернуть графический сплеш.
2. Ну и поставить пакет с микрокодом. sudo apt-get install amd64-microcode

Графический сплеш возвращается так. В папке /usr/share/nvidia-current или nvidiaXXXXX в зависимости от того, какой пакет ставили нужно в файле XXXXXX.grub-gfxpayload закомментировать последнюю строку.

Потом сделать в терминале

sudo update-grub-gfxpayload
sudo update-grub
« Последнее редактирование: 09 Март 2013, 11:25:00 от Pilot6 »

Оффлайн k790

  • Автор темы
  • Участник
  • *
  • Сообщений: 218
    • Просмотр профиля
    • Компьютерная - Лаборатория
Pilot6,
Тогда вопрос, почему сплеш не графический? У меня рабочий стол не загружается и консоль не работает.

Pilot6

  • Гость
k790,
Сплеш не графический потому, что framebufer убрали в новых драйверах. Можно вернуть, но тогда в консоли будут шрифты не графические. А стол не загружается потому, что видимо новые драйверы плохо поддерживают старые карты.

Оффлайн k790

  • Автор темы
  • Участник
  • *
  • Сообщений: 218
    • Просмотр профиля
    • Компьютерная - Лаборатория
Pilot6,
Спасибо, а в Ubuntu 13.04 драйвер так же будет работать или есть варианты, что там эту "проблему" решили?

Pilot6

  • Гость
Лучше ставьте более низкую версию драйвера на эти карты. Вряд ли с новыми решат.

Оффлайн k790

  • Автор темы
  • Участник
  • *
  • Сообщений: 218
    • Просмотр профиля
    • Компьютерная - Лаборатория
Поставил ubuntu 13.04 - шустрая, но проблема с драйвером на видюху, второй монитор не работает, после попытки включение второго монитора Ubuntu жутко тупила и выкидывала на авторизацию (ввод имени и пароля пользователя), но после перезагрузки Ubuntu снова стала шустро работать, но без второго монитора - это на родных драйверах убунты.

Решил попробовать новые драйвера 313 - не работает/не корректно, 304 - работает, но тормозит и выкидывает переодически (второй монитор заработал), после таких экспериментов решил удалить все установленные драйвера и вернуться к стандартным от убунты.

После удаления, пропала панель юнити (нет кнопок закрытия, файла и правки, да и самой левой меню нет). Уже пару часов пытаюсь вернуть панель - никак не получается, подскажите как восстановить юнити?

Оффлайн Sevka

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Поставил ubuntu 13.04 - шустрая, но проблема с драйвером на видюху, второй монитор не работает, после попытки включение второго монитора Ubuntu жутко тупила и выкидывала на авторизацию (ввод имени и пароля пользователя), но после перезагрузки Ubuntu снова стала шустро работать, но без второго монитора - это на родных драйверах убунты.
Подскажи, поставил всё таки дрова на видеокарту? У меня такая же проблема со стандартным vesa драйвером.

После удаления, пропала панель юнити (нет кнопок закрытия, файла и правки, да и самой левой меню нет). Уже пару часов пытаюсь вернуть панель - никак не получается, подскажите как восстановить юнити?
Мне помогла эта статья: http://askubuntu.com/questions/204428/unity-missing-cant-see-top-or-side-panels
Чтобы открыть консоль надо воспользоваться Alt+Ctrl+T для вызова терминала. Либо задать свою комбинацию (если нет) ПКМ на рабочем столе => Изменить фон раб. стола => Все параметры => Клавиатура => Комбинации клавиш
В терминале ввести:

    dconf reset -f /org/compiz/
    setsid unity

Оффлайн k790

  • Автор темы
  • Участник
  • *
  • Сообщений: 218
    • Просмотр профиля
    • Компьютерная - Лаборатория
Подскажи, поставил всё таки дрова на видеокарту? У меня такая же проблема со стандартным vesa драйвером.
Вроде поставил - два минитора заработали, но нет панелей
Сейчас наверное драйвер снёс, нужно будет посмотреть твои команды.

Можно попробовать гном поставит

 

Страница сгенерирована за 5.124 секунд. Запросов: 24.