Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: При установке библиотеки удалились очень важные файлы.  (Прочитано 851 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 4Juice

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Народ,тупанул я конкретно....Установил библиотеку и случайно удалились ВСЕ важные файлы....Начиная от центра приложений,заканчивая файловым менеджером...даже в меню не могу зайти,по-сути осталась только мозила,виртуал бокс и все)
Помогите,что делать в таком случае?Где взять основные файлы?

Пользователь решил продолжить мысль 31 Май 2013, 00:18:26:
Если что,загрузоный диск убунты есть)

Пользователь решил продолжить мысль 31 Май 2013, 00:25:00:
Помогите,чем сможете :'(
« Последнее редактирование: 31 Май 2013, 00:25:00 от 4Juice »

Оффлайн san-alex

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 7727
  • Ex-CNC programmer
    • Просмотр профиля
Может, ты все-таки подробно опишешь свои действия? Или нам угадать?
Какую библиотеку, как устанавливал, каким образом установка библиотеки удалила ВСЕ важные файлы (неважные остались), где эти важные файлы находились, с чего ты решил, что они удалились и т.д.?
Чем больше нужной информации ты дашь - тем больше шанс получить полезный совет.

Оффлайн 4Juice

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Может, ты все-таки подробно опишешь свои действия? Или нам угадать?
Какую библиотеку, как устанавливал, каким образом установка библиотеки удалила ВСЕ важные файлы (неважные остались), где эти важные файлы находились, с чего ты решил, что они удалились и т.д.?
Чем больше нужной информации ты дашь - тем больше шанс получить полезный совет.
Да бы не прав,но решил проблему сам,т.к. после перезагрузки Ubuntu не загружалась(
Просто переустановил ОС,благо на три раздела разбил)

Punko

  • Гость
АААААААА!!!!!!!! опять не юникс-вэй:(
Можно было попробовать установить ubuntu-desktop, подтянуло б и наутилус, и даш и всё остальное..

Оффлайн 4Juice

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
У меня теперь такая проблема.
Никак не могу избавиться от зависимостей(
sudo apt-get -f install вот что выводит

artem@artem-Inspiron-N5110:~/Загрузки/TZ$ sudo apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующий пакет устанавливался автоматически и больше не требуется:
  x11-apps xserver-xorg-video-mach64-lts-quantal xserver-xorg-video-trident-lts-quantal libgmp10:i386 libmpfr4:i386 xfonts-scalable
  xserver-xorg-video-sis-lts-quantal libdrm-nouveau2 x11-xserver-utils-lts-quantal libxcb-dri2-0 screen-resolution-extra
  xserver-common-lts-quantal xserver-xorg-video-modesetting-lts-quantal xserver-xorg-input-synaptics-lts-quantal
  xserver-xorg-input-evdev-lts-quantal xserver-xorg-video-ati-lts-quantal xserver-common gcc-4.4-base:i386
  xserver-xorg-input-vmmouse-lts-quantal xserver-xorg-video-s3-lts-quantal x11-session-utils xserver-xorg-video-vesa-lts-quantal libquadmath0
  xserver-xorg-video-tdfx-lts-quantal libmtdev1 xserver-xorg-video-fbdev-lts-quantal xserver-xorg-video-nouveau-lts-quantal xfonts-base
  x11-xfs-utils libxrandr-ltsq2 xserver-xorg-video-mga-lts-quantal xinit xserver-xorg-video-sisusb-lts-quantal
  xserver-xorg-video-neomagic-lts-quantal xserver-xorg-video-radeon-lts-quantal xserver-xorg-video-openchrome-lts-quantal libfs6
  xserver-xorg-video-cirrus-lts-quantal libxvmc1 libc6-dev:i386 nvidia-settings-experimental-310 xserver-xorg-input-wacom-lts-quantal
  linux-libc-dev:i386 xserver-xorg-input-mouse-lts-quantal xserver-xorg-input-all-lts-quantal xserver-xorg-video-intel-lts-quantal
  xserver-xorg-video-savage-lts-quantal xserver-xorg-video-siliconmotion-lts-quantal xserver-xorg-core-lts-quantal libllvm3.1
  xserver-xorg-video-r128-lts-quantal
Для их удаления используйте «apt-get autoremove».
Будут установлены следующие дополнительные пакеты:
  gcc-4.4-base
НОВЫЕ пакеты, которые будут установлены:
  gcc-4.4-base
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 156 пакетов не обновлено.
не установлено до конца или удалено 6 пакетов.
Необходимо скачать 0 B/12,0 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 175 kB.
Хотите продолжить [Д/н]? y
(Чтение базы данных ... на данный момент установлено 178596 файлов и каталогов.)
Распаковывается пакет gcc-4.4-base (из файла .../gcc-4.4-base_4.4.7-1ubuntu2_amd64.deb)...
dpkg: не удалось обработать параметр /var/cache/apt/archives/gcc-4.4-base_4.4.7-1ubuntu2_amd64.deb (--unpack):
 './usr/share/doc/gcc-4.4-base/README.Debian.gz' is different from the same file on the system
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/gcc-4.4-base_4.4.7-1ubuntu2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

а мне нужно запустить вот это файл:
artem@artem-Inspiron-N5110:~/Загрузки/TZ$ ./zeron
./zeron: error while loading shared libraries: libboost_regex.so.1.46.1: wrong ELF class: ELFCLASS64

Вот,а команда ldd zeron выводит это
artem@artem-Inspiron-N5110:~/Загрузки/TZ$ ldd zeron
./zeron: /usr/lib/i386-linux-gnu/libmysqlclient.so.18: no version information available (required by ./zeron)
linux-gate.so.1 =>  (0xf775e000)
libboost_system.so.1.46.1 => /usr/lib/libboost_system.so.1.46.1 (0xf7740000)
libboost_regex.so.1.46.1 => not found
libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf7724000)
libmysqlclient.so.18 => /usr/lib/i386-linux-gnu/libmysqlclient.so.18 (0xf740a000)
libstdc++.so.6 => /usr/lib/i386-linux-gnu/libstdc++.so.6 (0xf7325000)
libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf7307000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf715e000)
/lib/ld-linux.so.2 (0xf775f000)
libz.so.1 => /lib/i386-linux-gnu/libz.so.1 (0xf7147000)
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf7142000)
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf7116000)

а когда пытаешься установить libboost_regex.so.1.46.1 выводит вот что
artem@artem-Inspiron-N5110:~/Загрузки/TZ$ sudo apt-get install libboost-regex1.46.1:i386
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 cpp-4.4 : Зависит: gcc-4.4-base (= 4.4.7-1ubuntu2) но он не будет установлен
 g++-4.4 : Зависит: gcc-4.4-base (= 4.4.7-1ubuntu2) но он не будет установлен
 gcc-4.4 : Зависит: gcc-4.4-base (= 4.4.7-1ubuntu2) но он не будет установлен
 libboost-regex1.46.1 : Конфликтует: libboost-regex1.46.1:i386 но 1.46.1-7ubuntu3 будет установлен
 libboost-regex1.46.1:i386 : Зависит: libicu48:i386 (>= 4.8-1) но он не будет установлен
                             Конфликтует: libboost-regex1.46.1 но 1.46.1-7ubuntu3 будет установлен
 libstdc++6-4.4-dev : Зависит: gcc-4.4-base (= 4.4.7-1ubuntu2) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).

Так что этомкнутый круг,господа.
И я не знаю,как из него выбраться.


Предупреждение:
Нарушение правил форума. На форуме запрещено:
2.8. Задавать в одной теме несвязанные вопросы.

Для нового вопроса создайте новую тему. Закрыто.

--Сперанский

« Последнее редактирование: 31 Май 2013, 07:55:07 от Сперанский »

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net

 

Страница сгенерирована за 0.171 секунд. Запросов: 24.