Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Проблема при установке emacs.  (Прочитано 770 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gondzo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Проблема при установке emacs.
« : 03 Октябрь 2013, 18:11:20 »
koss@koss-HP:~$ sudo dpkg --configure -a
Настраивается пакет emacs24 (24.2+1-2ubuntu2) …
Install auto-install-el for emacs24
install/auto-install: Handling install for emacsen flavor emacs24
/usr/lib/emacsen-common/packages/install/auto-install-el: 27: cd: can't cd to /usr/share/emacs/site-lisp/auto-install
ERROR: install script from auto-install-el package failed
dpkg: ошибка при обработке параметра emacs24 (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Настраивается пакет emacs23 (23.4+1-4ubuntu1) …
Install auto-install-el for emacs23
install/auto-install: Handling install for emacsen flavor emacs23
/usr/lib/emacsen-common/packages/install/auto-install-el: 27: cd: can't cd to /usr/share/emacs/site-lisp/auto-install
ERROR: install script from auto-install-el package failed
dpkg: ошибка при обработке параметра emacs23 (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 emacs24
 emacs23
Подскажите ,кто не занят в чем может быть проблема.

Оффлайн JmAbuDabi

  • Старожил
  • *
  • Сообщений: 2468
  • 나는 빅터 해요. 나는 프로그래머입니다
    • Просмотр профиля
Re: Проблема при установке emacs.
« Ответ #1 : 03 Октябрь 2013, 19:14:19 »
sudo apt-get install -f
Покой – это не место, где тихо и мирно, где нет шума и беспокойства.
Покой – это когда при всем этом, вы сохраняете мир и спокойствие в своем сердце.

Оффлайн gondzo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: Проблема при установке emacs.
« Ответ #2 : 04 Октябрь 2013, 13:37:33 »
При обработке следующих пакетов произошли ошибки:
 emacs23
E: Sub-process /usr/bin/dpkg returned an error code (1)
koss@koss-HP:~$
всеравно одна и та же ошибка.
Как решить проблему с зависимостями, или как получить отчет по ошибке но более подробный.

Вот еще
ERROR: install script from auto-install-el package failed
dpkg: ошибка при обработке параметра emacs23-lucid (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 emacs23-lucid
E: Sub-process /usr/bin/dpkg returned an error code (1)
koss@koss-HP:~$
« Последнее редактирование: 04 Октябрь 2013, 13:50:43 от gondzo »

Оффлайн JmAbuDabi

  • Старожил
  • *
  • Сообщений: 2468
  • 나는 빅터 해요. 나는 프로그래머입니다
    • Просмотр профиля
Re: Проблема при установке emacs.
« Ответ #3 : 04 Октябрь 2013, 14:42:30 »
Можно было полный листинг ???

sudo apt-get update
sudo apt-get purge emacs23-lucid
sudo apt-get install emacs23-lucid

Пользователь решил продолжить мысль 04 Октябрь 2013, 14:47:26:
sudo apt-get install

покажет, что нужно менеджеру пакетов.

То что нужно доставте руками

заходим на сайт

http://packages.ubuntu.com/ИМЯ_ПАКЕТА_КОТОРЫЙ_НУЖЕН

выбираем версию Оси. качаем нужной разрядности или all.

Ставим

sudo dpkg -i ИМЯ_ПАКЕТА_КОТОРЫЙ_СКАЧАЛИ
Пробуем

apt-get install -f

если не пытается ничего удалить, то согалашаемся.

Иначе повторяем по новой.

Если пишет,

Пакет бла: зависит от блакен (Версия 1.2) но установлена версия 1.4.

Обновите пакет Бла.
« Последнее редактирование: 04 Октябрь 2013, 14:47:26 от JmAbuDabi »
Покой – это не место, где тихо и мирно, где нет шума и беспокойства.
Покой – это когда при всем этом, вы сохраняете мир и спокойствие в своем сердце.

 

Страница сгенерирована за 0.075 секунд. Запросов: 25.