Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Metasploit Framework проблема с rubygems.rb  (Прочитано 2199 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Omengh

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Metasploit Framework проблема с rubygems.rb
« : 20 Октябрь 2013, 08:35:32 »
Установил metasploit в ubuntu 13.04, но он не хочет запускаться, и обновляться тоже.
Вот вывод консоли:

omengh@main-pc:~$ sudo msfconsole
/opt/metasploit/ruby/lib/ruby/1.9.1/rubygems.rb:31:in `require': cannot load such file -- rbconfig (LoadError)
from /opt/metasploit/ruby/lib/ruby/1.9.1/rubygems.rb:31:in `<top (required)>'
from <internal:gem_prelude>:1:in `require'
from <internal:gem_prelude>:1:in `<compiled>'

Помогите разобраться в чем тут дело?  :'(
« Последнее редактирование: 21 Октябрь 2013, 19:43:07 от Omengh »

Оффлайн soarin

  • Старожил
  • *
  • Сообщений: 1850
  • ubuntu 20.04
    • Просмотр профиля
Re: Metasploit Framework проблема с rubygems.rb
« Ответ #1 : 20 Октябрь 2013, 12:19:42 »
а зачем sudo?
ruby 1.9.1 - старую версию ставишь?
« Последнее редактирование: 20 Октябрь 2013, 12:23:46 от soarin »

Оффлайн Omengh

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Re: Metasploit Framework проблема с rubygems.rb
« Ответ #2 : 21 Октябрь 2013, 19:32:43 »
а зачем sudo?
ruby 1.9.1 - старую версию ставишь?
Ну без sudo никакого вывода в терминале нет, просто мерцающий курсор.

А насчет ruby то я не очень там разбираюсь, т.е. вы говорите, что нужно поставить версию новее 1.9.1?

Установил ruby1.9.3, не помогло. Может еще какие пакеты нужны?
« Последнее редактирование: 21 Октябрь 2013, 19:39:45 от Omengh »

Оффлайн soarin

  • Старожил
  • *
  • Сообщений: 1850
  • ubuntu 20.04
    • Просмотр профиля
Re: Metasploit Framework проблема с rubygems.rb
« Ответ #3 : 21 Октябрь 2013, 20:12:08 »
Ну build-essential ещё нужен.

Оффлайн Omengh

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Re: Metasploit Framework проблема с rubygems.rb
« Ответ #4 : 22 Октябрь 2013, 17:00:41 »
Ну build-essential ещё нужен.

как оказалось

"Уже установлена самая новая версия build-essential.
build-essential установлен вручную."

Metasploit Framework ставил по инструкции: https://help.ubuntu.ru/wiki/metasploit_framework_%D0%B2_ubuntu

Ошибка остается прежней.

Оффлайн Omengh

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Re: Metasploit Framework проблема с rubygems.rb
« Ответ #5 : 28 Октябрь 2013, 09:53:55 »
Решить проблему у меня так и не получилось, но требуемого результата я достиг другим путем. Установил virtualbox и там же backtrack 5. Metasploit Framework на ubuntu не становится, такие дела. :-\

Оффлайн soarin

  • Старожил
  • *
  • Сообщений: 1850
  • ubuntu 20.04
    • Просмотр профиля
Re: Metasploit Framework проблема с rubygems.rb
« Ответ #6 : 28 Октябрь 2013, 16:10:40 »
там же backtrack 5
Ну зачем же некромантией заниматься? ставил бы kali linux
Поддержка backtrack 5 была дропнута в начале 2013 года.
« Последнее редактирование: 28 Октябрь 2013, 16:16:46 от soarin »

Оффлайн Omengh

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Re: Metasploit Framework проблема с rubygems.rb
« Ответ #7 : 30 Октябрь 2013, 19:33:24 »
Цитировать
Ну зачем же некромантией заниматься? ставил бы kali linux
Поддержка backtrack 5 была дропнута в начале 2013 года.
Спасибо, завтра поставлю kali linux  8)

 

Страница сгенерирована за 0.086 секунд. Запросов: 25.