Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Как установить Мультифон (multifon) от Мегафона на Ubuntu x64  (Прочитано 3922 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн EvgIq

  • Автор темы
  • Любитель
  • *
  • Сообщений: 96
    • Просмотр профиля
У них на сайте доступна версия для Ubuntu. Но она для х32 версии (в ней этот клиент работает нормально, проверял). Для Ubuntu x64 доблестный Мегафон, клиентом Мультифона, не озадачился.
На данный момент пользуюсь виртуалкой с ВинХР только лишь для этой проги.
Подскажите - как поставить на х64 версию системы?
(темы здесь про Мультифон видел, но так и не смог установить)
PS у меня Ubuntu 13.10 x64
« Последнее редактирование: 12 Февраль 2014, 20:13:07 от EvgIq »

Оффлайн Haron Prime

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 11311
  • Arch Linux & XMonad
    • Просмотр профиля
sudo dpkg -i --force-architecture /.../.../file.deb
/.../.../file.deb  -  путь к Вашему мегахонному файлу
« Последнее редактирование: 12 Февраль 2014, 18:20:28 от Haron Prime »
sudo ls -a | grep brain > /dev/head

Оффлайн EvgIq

  • Автор темы
  • Любитель
  • *
  • Сообщений: 96
    • Просмотр профиля
Haron Prime
ставил уже так
Если запускать в терминале, выдает:
MultiFon: error while loading shared libraries: libjpeg.so.62: wrong ELF class: ELFCLASS64

Оффлайн Haron Prime

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 11311
  • Arch Linux & XMonad
    • Просмотр профиля
sudo apt-get install libjpeg62
sudo ls -a | grep brain > /dev/head

Оффлайн EvgIq

  • Автор темы
  • Любитель
  • *
  • Сообщений: 96
    • Просмотр профиля
#sudo apt-get install libjpeg62
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлена самая новая версия libjpeg62.
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Не помогает это.
Нашел, что надо х32 репозиторий подключить, снести Мультифон, и заново поставить.
Но как это сделать - не нашел (х32 репы установить)
« Последнее редактирование: 12 Февраль 2014, 18:32:56 от EvgIq »

Оффлайн Haron Prime

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 11311
  • Arch Linux & XMonad
    • Просмотр профиля
тогда не судьба  :(
исходников, само собой, нет? собрать самому не получится?
у меня других вариантов нет
sudo ls -a | grep brain > /dev/head

Оффлайн Haron Prime

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 11311
  • Arch Linux & XMonad
    • Просмотр профиля
Цитировать
Нашел, что надо х32 репозиторий подключить, снести Мультифон, и заново поставить.
нет отдельных репов для 32-битных пакетов

sudo ls -a | grep brain > /dev/head

Оффлайн EvgIq

  • Автор темы
  • Любитель
  • *
  • Сообщений: 96
    • Просмотр профиля
там есть еще rpm Линукс клиент
MultiFon-1.27.503-Linux.rpm

Больше ничего не предлагают...

Оффлайн Haron Prime

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 11311
  • Arch Linux & XMonad
    • Просмотр профиля
попробуйте
sudo apt-get install  ia32-libsа потом установить прогу

*правда в последних версиях убунты этой либы больше нет ((((
sudo ls -a | grep brain > /dev/head

Оффлайн peregrine

  • FSM
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 7080
  • Gentoo x64 Ubuntu 16.04.1 x64
    • Просмотр профиля
EvgIq,
sudo apt-get install libjpeg62:i386Возможно поможет, но это на свой страх и риск, смотрите, что удалять предложит (если предложит)

Оффлайн Haron Prime

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 11311
  • Arch Linux & XMonad
    • Просмотр профиля
peregrine,
я что-то такой либы не нашёл  :idiot2:

*кстати, сейчас проверил в терминале - не предлагает удалять ничего, установилась без проблем

** снёс от греха подальше )))
« Последнее редактирование: 12 Февраль 2014, 18:54:55 от Haron Prime »
sudo ls -a | grep brain > /dev/head

Оффлайн EvgIq

  • Автор темы
  • Любитель
  • *
  • Сообщений: 96
    • Просмотр профиля
Haron Prime,
$ sudo apt-get install  ia32-libs
[sudo] password for evg:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет ia32-libs недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list
Однако следующие пакеты могут его заменить:
  lib32z1 lib32ncurses5 lib32bz2-1.0

E: Для пакета «ia32-libs» не найден кандидат на установку

peregrine,
Пакет встал, ничего удалять не предлагал. Но теперь пишет:
$MultiFon
MultiFon: error while loading shared libraries: libqjson.so.0: cannot open shared object file: No such file or directory


Оффлайн peregrine

  • FSM
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 7080
  • Gentoo x64 Ubuntu 16.04.1 x64
    • Просмотр профиля
EvgIq, сейчас всё установим, правда может долго.
sudo apt-get install libqjson0:i386

Оффлайн EvgIq

  • Автор темы
  • Любитель
  • *
  • Сообщений: 96
    • Просмотр профиля
peregrine,
~$ MultiFon
MultiFon: error while loading shared libraries: libQtWebKit-movial.so.4: cannot open shared object file: No such file or directory
Угу, вроде продвигаемся :)
(написал им в форму обратной связи просьбу собрать под х64, ответили "обращайтесь в банк идей" :) )

Оффлайн Haron Prime

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 11311
  • Arch Linux & XMonad
    • Просмотр профиля
(Нажмите, чтобы показать/скрыть)
sudo ls -a | grep brain > /dev/head

 

Страница сгенерирована за 0.057 секунд. Запросов: 24.