Форум русскоязычного сообщества Ubuntu


Автор Тема: Не работают браузеры через vpn на Ubuntu.  (Прочитано 877 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ymnikvlz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Уважаемые форумчане простите меня за тупость но столкнулся с такой проблемой:

Есть у меня дома роутер асус на нем настроен vpn сервер . Создал vpn подключение на ubuntu все вроде хорошо коннектится
но проблема в том что ни мазила ни хромиум браузеры не открывают странички. По терминалу все ок трассировки идут через роутер , ip vpnа комп получает , даже консольный браузер lynx и тот открывает странички, а вот браузеры никак не хотят как не пытался и в центр приложений Ubuntu тоже не пускает. Не работает все графические приложения , даже скайп.
Пробовал менять настройки , типы шифрования оставлял разные ничего не помогло , а вот на windows xp,7 проверял как назло все работает через этот vpn Подскажите куда лезть и что можно поправить. Мучаюсь уже около 2х месяцев.

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13744
    • Просмотр профиля
Re: Не работают браузеры через vpn на Ubuntu.
« Ответ #1 : 20 Февраль 2014, 19:20:55 »
Аххалай-махалай.
Нет, не телепатится.
Хотя нет... красный крокодил на косячное mtu намекает.
Давайте хотя бы tracepath ya.ru что-ли посмотрим, раз конфиги засекречены.
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн Ymnikvlz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Re: Не работают браузеры через vpn на Ubuntu.
« Ответ #2 : 25 Февраль 2014, 17:29:13 »
pathping , tracepath все впорядке трафик идет через vpn асуса ,а потом к провайдеру. Купил на днях Mikrotik RB750 настроил на нем vpn сервер таких проблем не наблюдаю на убунте все работает прекрасно и на винде тоже, жаль что не смог понять почему веб на убунте через асус не ок а на винде все ок.
« Последнее редактирование: 25 Февраль 2014, 17:31:35 от Ymnikvlz »

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13744
    • Просмотр профиля
Re: Не работают браузеры через vpn на Ubuntu.
« Ответ #3 : 25 Февраль 2014, 18:03:39 »
жаль что не смог понять почему веб на убунте через асус не ок а на винде все ок.
А Вы правда пытались?
В указанных командах не только путь интересен... Ну и ладно. Сраслось, значит сраслось.
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн Ymnikvlz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Re: Не работают браузеры через vpn на Ubuntu.
« Ответ #4 : 26 Февраль 2014, 14:43:51 »
все-таки интерес меня мучает хочется понять что не так

 tracepath ya.ru
 1:  192.168.10.2                                          0.155ms pmtu 1400
 1:  router.asus.com                                       1.778ms
 1:  router.asus.com                                       1.753ms

тут дальше провайдера хопы их копировать не стал

 Resume: pmtu 1400 hops 8 back 51

192.168.10.2 -это ip который дает асус через vpn.

проверил параллельно от микротика через его впн pmtu тоже 1400

может какой конфиг на убунте посмотреть, я еще только учусь , простите за кривые руки, но может подскажете какой конфиг посмотреть что не пускает веб интерфейс просто долгое время мучился, а понять хочется , да и конечно большой плюс таких мучений то что много нового начинаю узнавать развиваться...

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13744
    • Просмотр профиля
Re: Не работают браузеры через vpn на Ubuntu.
« Ответ #5 : 26 Февраль 2014, 15:13:37 »
Вектор Вы всё-таки приняли и последовали ему. )))
То есть я, скорее всего, попал в точку, что косяки из-за mtu
Вообще, выравниванием mtu должен был заниматься Ваш роутер. Хотя вполне вероятно, что в параметрах vpn Вы этот самый mtu указали неверно.
Кстати а акой тип VPN-то используется?
Опять аххалай-махалай надо делать, а у меня дежурный бубен на реставрации.
Будет диагностика и/или конфиги?
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн Ymnikvlz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Re: Не работают браузеры через vpn на Ubuntu.
« Ответ #6 : 26 Февраль 2014, 17:21:26 »
ubuntu 13.10
настраивал vpn  pptp 

командой ifconfig -a определил что ,
eth0 - соединение по кабелю у него mtu 1500
ppp0 - впн у него mtu 1400
пробовал менять в терминале mtu
sudo ifconfig eth0 mtu 1300
sudo ifconfig ppp0 mtu 1300

затем проверил ifconfig -a он мне показал что mtu стали по 1300 , не помогло.
потом подключился на асус , в настройке vpn сервера стоит mtu 1450 пробовал менять на 1300, 1000, 14000 не помогло

но

C:\Documents and Settings\a1>PING -f -l 1472 ya.ru

Обмен пакетами с ya.ru [93.158.134.3] по 1472 байт:

Ответ от 93.158.134.3: число байт=1472 время=33мс TTL=54
Ответ от 93.158.134.3: число байт=1472 время=34мс TTL=52
Ответ от 93.158.134.3: число байт=1472 время=33мс TTL=54
Ответ от 93.158.134.3: число байт=1472 время=32мс TTL=52

Статистика Ping для 93.158.134.3:
    Пакетов: отправлено = 4, получено = 4, потеряно = 0 (0% потерь),
Приблизительное время приема-передачи в мс:
    Минимальное = 32мсек, Максимальное = 34 мсек, Среднее = 33 мсек

C:\Documents and Settings\a1>PING -f -l 1500 ya.ru

Обмен пакетами с ya.ru [93.158.134.3] по 1500 байт:

Требуется фрагментация пакета, но установлен запрещающий флаг.
Требуется фрагментация пакета, но установлен запрещающий флаг.
Требуется фрагментация пакета, но установлен запрещающий флаг.
Требуется фрагментация пакета, но установлен запрещающий флаг.

это проверка с виндовс xp на mtu

Затем включил wireshark и etherape на убунте 

etherape показал туннель до роутера и все .
а wireshark весь трафик HTTP красным сразу выделяет.
Я так думаю на роутере все застревает .

пробовал искать конфиг на vpn но может не там искал /etc/ppp/ ничего про mtu не нашел.
 Подскажите пожалуйста где дальше копать и если какие конфиги надо то по какому пути они лежат...
 

Оффлайн Ymnikvlz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Re: Не работают браузеры через vpn на Ubuntu.
« Ответ #7 : 21 Июль 2014, 16:35:12 »
Итак прошло много времени и я уверен что я нашел ответ на 99% по данному вопросу . Прописать вручную днсы провайдера. Не знаю почему так в убунте у меня получилось , но столкнулся с этой проблемой потом и на других роутерах , когда проблема повторилась подставил днсы принудительно и все заработало.

Думаю что проблему можно закрыть :)

 

Страница сгенерирована за 0.062 секунд. Запросов: 24.