Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Ошибка пакета PostgreSQL 8.4  (Прочитано 734 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн agar-agar

  • Автор темы
  • Любитель
  • *
  • Сообщений: 61
    • Просмотр профиля
Ошибка пакета PostgreSQL 8.4
« : 23 Март 2014, 07:06:29 »
Система стала регулярно сообщать об ошибке в пакете. Попробовал его удалить - не получается. Вот, что выдает:

(Чтение базы данных ... на данный момент установлено 642352 файла и каталога.)
Удаляется пакет postgresql-8.4 ...
 * Stopping PostgreSQL 8.4 database server                                       * Use of uninitialized value $info{"pgdata"} in -d at /usr/bin/pg_ctlcluster line 331.
Use of uninitialized value $info{"pgdata"} in concatenation (.) or string at /usr/bin/pg_ctlcluster line 332.
Error:  is not accessible or does not exist
                                                                         [fail]
invoke-rc.d: initscript postgresql, action "stop" failed.
dpkg: не удалось обработать параметр postgresql-8.4 (--purge):
 подпроцесс установлен сценарий pre-removal возвратил код ошибки 1
Отчёты apport не записаны, так достигнут MaxReports
                                                   При обработке следующих пакетов произошли ошибки:
 postgresql-8.4
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ошибка при установке пакета. Попытка восстановления:
Настраивается пакет postgresql-common (129ubuntu1) ...
 * Starting PostgreSQL 8.4 database server                                       * Use of uninitialized value $info{"pgdata"} in -d at /usr/bin/pg_ctlcluster line 331.
Use of uninitialized value $info{"pgdata"} in concatenation (.) or string at /usr/bin/pg_ctlcluster line 332.
Error:  is not accessible or does not exist
                                                                         [fail]
invoke-rc.d: initscript postgresql, action "start" failed.
dpkg: не удалось обработать параметр postgresql-common (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 postgresql-common


Пользователь решил продолжить мысль 23 Март 2014, 08:51:31:
Та же ошибка выскакивает при попытке установки каких-либо новых пакетов. Вот например сейчас попробовал установить драйвер для видеокарты и получил следующий вывод в терминале:
sudo apt-get install xserver-xorg-video-intel

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  libboost-python1.46.1 libepc-1.0-3 libgoocanvas-2.0-9 libgdamm-5.0-13 libgtksourceviewmm-3.0-0 libgoocanvasmm-2.0-6
  gir1.2-gda-5.0 libgoocanvas-2.0-9-common libjs-underscore glom-doc libglom-1.20-0 libepc-common libxml++2.6-2 libxcb-dri2-0
Для их удаления используйте «apt-get autoremove».
Пакеты, которые будут обновлены:
  xserver-xorg-video-intel
обновлено 1, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 10 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 634 kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 566 kB.
Получено:1 http://ppa.launchpad.net/glasen/intel-driver/ubuntu/ precise/main xserver-xorg-video-intel i386 2:2.21.15~precise~ppa1.1 [634 kB]
Получено 634 kБ за 1с (437 kБ/c)                 
(Чтение базы данных ... на данный момент установлено 642568 файлов и каталогов.)
Подготовка к замене пакета xserver-xorg-video-intel 2:2.17.0-1ubuntu4.4 (используется файл .../xserver-xorg-video-intel_2%3a2.21.15~precise~ppa1.1_i386.deb) ...
Распаковывается замена для пакета xserver-xorg-video-intel ...
Обрабатываются триггеры для man-db ...
Настраивается пакет postgresql-common (129ubuntu1) ...
Use of uninitialized value $_[0] in open at /usr/share/postgresql-common/PgCommon.pm line 947.
/bin/df: «»: Нет такого файла или каталога
/bin/df: не обработано ни одной файловой системы
 * Starting PostgreSQL 8.4 database server                                                                                           * Use of uninitialized value $info{"pgdata"} in -d at /usr/bin/pg_ctlcluster line 331.
Use of uninitialized value $info{"pgdata"} in concatenation (.) or string at /usr/bin/pg_ctlcluster line 332.
Error:  is not accessible or does not exist
                                                                                                                             [fail]
invoke-rc.d: initscript postgresql, action "start" failed.
dpkg: не удалось обработать параметр postgresql-common (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Настраивается пакет xserver-xorg-video-intel (2:2.21.15~precise~ppa1.1) ...
При обработке следующих пакетов произошли ошибки:
 postgresql-common
E: Sub-process /usr/bin/dpkg returned an error code (1)

« Последнее редактирование: 23 Март 2014, 12:56:54 от Haron Prime »

Оффлайн Haron Prime

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 11313
  • Arch Linux & XMonad
    • Просмотр профиля
Re: Ошибка пакета PostgreSQL 8.4
« Ответ #1 : 23 Март 2014, 12:59:56 »
agar-agar,
Листинги и текстовые файлы следует добавлять в сообщения с помощью тегов [spоiler][/spоiler] или [cоde][/cоde] либо прикреплять к сообщению в виде файла!
sudo ls -a | grep brain > /dev/head

Оффлайн JmAbuDabi

  • Старожил
  • *
  • Сообщений: 2468
  • 나는 빅터 해요. 나는 프로그래머입니다
    • Просмотр профиля
Re: Ошибка пакета PostgreSQL 8.4
« Ответ #2 : 23 Март 2014, 13:01:36 »
sudo apt-get update
sudo apt-get install -f
Покой – это не место, где тихо и мирно, где нет шума и беспокойства.
Покой – это когда при всем этом, вы сохраняете мир и спокойствие в своем сердце.

Оффлайн agar-agar

  • Автор темы
  • Любитель
  • *
  • Сообщений: 61
    • Просмотр профиля
Re: Ошибка пакета PostgreSQL 8.4
« Ответ #3 : 23 Март 2014, 13:22:57 »
sudo apt-get update
sudo apt-get install -f

После sudo apt-get install -f
выдает следующее (т.е. то же самое)

(Нажмите, чтобы показать/скрыть)

Пользователь решил продолжить мысль 23 Март 2014, 13:23:48:
agar-agar,
Листинги и текстовые файлы следует добавлять в сообщения с помощью тегов [spоiler][/spоiler] или [cоde][/cоde] либо прикреплять к сообщению в виде файла!

Не нашел сразу нужную кнопку... Прошу извинить.
« Последнее редактирование: 23 Март 2014, 13:24:47 от agar-agar »

 

Страница сгенерирована за 0.063 секунд. Запросов: 24.