Форум русскоязычного сообщества Ubuntu


Автор Тема: Плагин/индикатор для индикации статуса синхронизации с Yandex-disk  (Прочитано 211014 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн User Kubuntu

  • Новичок
  • *
  • Сообщений: 42
    • Просмотр профиля
OS: Debian 10 64 Bit

При добавлении репозитория получаю следующую проблему, как ее решить?

(Нажмите, чтобы показать/скрыть)

Оффлайн Sly_tom_cat

  • Автор темы
  • Don't worry, be happy!
  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 12025
  • Xubuntu 18.04 (64bit)
    • Просмотр профиля
Так ключ добавился. Пакет должен ставится.
Индикатор для Yandex-Disk: https://forum.ubuntu.ru/index.php?topic=241992
UEFI-Boot - грузимся без загрузчика: http://help.ubuntu.ru/wiki/uefiboot

Оффлайн User Kubuntu

  • Новичок
  • *
  • Сообщений: 42
    • Просмотр профиля
В данный момент вы занимаетесь разработкой yd-qgo или проект заброшен? Есть ли PPA или deb пакет для данной утилиты?

Оффлайн Sly_tom_cat

  • Автор темы
  • Don't worry, be happy!
  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 12025
  • Xubuntu 18.04 (64bit)
    • Просмотр профиля
yd-qgo - вполне рабочий индикатор (golang + QT). Коммитов давно не было потому что и вопросов ни у кого не возникает (либо не используется ни кем, либо у всех работает и кушать не просит - мне трудно понять).

Но он значительно упрощен по сравнению с yd-tools: конфигурация - руками в файле, только английский интерфейс.

PPA или deb я не делал. Там собирается все довольно просто.
Индикатор для Yandex-Disk: https://forum.ubuntu.ru/index.php?topic=241992
UEFI-Boot - грузимся без загрузчика: http://help.ubuntu.ru/wiki/uefiboot

Оффлайн HellMaus

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля

Python-gi и Python3-gi обе установлены. Версия 3.34.0.3   Пробовал переустановить - результат тот же.
Что еще можно попробовать?

Я столкнулся с такой же проблемой и разобрался. У меня два Питона (3.8 обычный и 3.7 в Conda), при этом модуль gi был виден только в 3.8, а симлинк /usr/bin/python3 вел на 3.7. Пытался поставить gi в Conda по инструкциям https://stackoverflow.com/questions/37526026/how-to-install-gi-module-for-anaconda-python3, не получилось.
Сделал проще: в первой строке yandex-disk-indicator.py поставил принудительное указание на интерпретатор python3.8 (#!/usr/bin/env python3.8) и все заработало.

Оффлайн Sly_tom_cat

  • Автор темы
  • Don't worry, be happy!
  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 12025
  • Xubuntu 18.04 (64bit)
    • Просмотр профиля
К сожалению с версиями питона и библиотек - всегда возможны накладки и несоответствия.

Причем вариантов всяких возможно много и какого-то универсального решения нет - с каждой ситуацией надо разбираться индивидуально...
Индикатор для Yandex-Disk: https://forum.ubuntu.ru/index.php?topic=241992
UEFI-Boot - грузимся без загрузчика: http://help.ubuntu.ru/wiki/uefiboot

 

Страница сгенерирована за 0.233 секунд. Запросов: 24.