Форум русскоязычного сообщества Ubuntu


Автор Тема: Apple обязала разработчиков создавать 64-битные приложения  (Прочитано 849 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Tamir

  • Автор темы
  • Активист
  • *
  • Сообщений: 782
    • Просмотр профиля
    • PDF формы
"Вслед за публичным релизом iOS 8.1 в понедельник, 20 октября, Apple представила ряд других новшеств, среди которых есть и то, что напрямую касается разработчиков мобильных приложений под iOS.
В частности, компания изменила требования к выпускаемым приложениям, о чем вчера оповестила разработчиков через уведомления от Developer Center.
Основных новых требования два: с 1 февраля 2015 года все новые приложения и обновления уже опубликованных должны быть разработаны с использованием SDK iOS 8, включённого в интегрированную среду разработки ПО Xcode 6, и быть совместимыми с 64-битной архитектурой. В противном случае они будут отклонены...
Стоит отметить, что требования касаются только впервые публикуемых в App Store приложений или обновленных версий. Старые программы по-прежнему могут оставаться 32-битными. Вероятно, что в перспективе на 64-битную архитектуру будут переведены все приложения, но решение этого вопроса займет, скорее всего, не один год."

Подробнее http://habrahabr.ru/post/241219/
 

Оффлайн victor00000

  • Старожил
  • *
  • Сообщений: 14862
  • Я не слышу.
    • Просмотр профиля
Tamir,
зачем? скоро news windows?
~.o

Оффлайн Tamir

  • Автор темы
  • Активист
  • *
  • Сообщений: 782
    • Просмотр профиля
    • PDF формы
Считаешь не стоило  :-[? Вроде *nix..
(Нажмите, чтобы показать/скрыть)

Оффлайн victor00000

  • Старожил
  • *
  • Сообщений: 14862
  • Я не слышу.
    • Просмотр профиля
Tamir,
ты был аппле? я не было, буду папробувать?
~.o

Оффлайн Tamir

  • Автор темы
  • Активист
  • *
  • Сообщений: 782
    • Просмотр профиля
    • PDF формы
Новость отражает всего лишь тенденцию, которую не так просто осуществить, вот и всё. Никаких тайных намёков или поощрений на переход на IOS или Mac OS здесь нет. У меня тоже нет устройств от apple...думаю, учитывая цену этих гаджетов пробовать не будем :).

Оффлайн alsoijw

  • Старожил
  • *
  • Сообщений: 4073
  • Fedora 25 GNOME 3 amd64
    • Просмотр профиля
Tamir, и? Владельцы старых устройств срочно должны купить новые. как всегда.
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?

Оффлайн Tamir

  • Автор темы
  • Активист
  • *
  • Сообщений: 782
    • Просмотр профиля
    • PDF формы
alsoijw,
ты не понял, сейчас многие говорят о разработке приложений только под 64 битные процессоры, но на практике это автоматически не означает, что 32 битным разработкам конец. Ведь существует много устройств которые владельцы не собираются абгрейдить, и даже такая мощная корпорация как Apple (у которой имеются соответствующие рычаги давления) не может добиться этого мгновенно...

Оффлайн .ubuntufan

  • Активист
  • *
  • Сообщений: 638
    • Просмотр профиля
32-битные то никто не дропает. Просто теперь, помимо 32-битной версии, авторы обязаны публиковать и 64-битные. На процессорах с поддержкой 64 бит будут работать 64-битные, а на старых соответственно 32-битные (iPhone 4S, 5, 5S, iPad 2).

 

Страница сгенерирована за 0.06 секунд. Запросов: 24.