Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: проблема с автомонтированием  (Прочитано 1317 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн CrimsonMoon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
проблема с автомонтированием
« : 23 Апрель 2008, 14:21:02 »
вроде бы ничего не делал.. вобщем внезапно перестали автоматически монтироваться диски. Т.е. при загрузке все нормально - fstab (или как он там) работает нормально. но вот допустим если я извлекаю диск (кстати раньше я мог это сделать нажатием на соответствующую кнопку на приводе, а теперь только отмонтированием через наутилус) и вставляю другой, то чтобы он заработал надо опять таки его сначала примонтировать (раньше это само происходило) и метка диска показываетя та, что была на предыдущем диске.
с флэшкой немного сложнее, ее можно смонтировать только в консоли mount, что не очень удобно
gnome-volume-manager вроде включен (если конечно он вообще за это отвечает), на всякий случай поставил autofs, правда при установке он написал  что нету mapping'а или чтото похожее
надеюсь на вашу помощь, подскажите куда лезть и что править.. ато так не хочется переустанавливать все это дело

PS. ах да.. установлена ubuntu 7.10
« Последнее редактирование: 23 Апрель 2008, 14:33:43 от CrimsonMoon »

Оффлайн kiev

  • Активист
  • *
  • Сообщений: 412
    • Просмотр профиля
    • Соционическое типирование и консультирование
Re: проблема с автомонтированием
« Ответ #1 : 27 Апрель 2008, 12:31:21 »
а у меня вообще не работает автомонтирование - что теперь делать?

Оффлайн Пингвус

  • Любитель
  • *
  • Сообщений: 65
    • Просмотр профиля
Re: проблема с автомонтированием
« Ответ #2 : 27 Апрель 2008, 19:08:42 »
а у меня вообще не работает автомонтирование - что теперь делать?
Править /etc/fstab
Люблю жизнь!

Оффлайн fwhr

  • Старожил
  • *
  • Сообщений: 2104
    • Просмотр профиля
Re: проблема с автомонтированием
« Ответ #3 : 27 Апрель 2008, 23:45:16 »
CrimsonMoon, а я уже привык вынимать компакты путём нажатия кнопки F12 - получаю отмонтирование и открытие лотка на автомате (настраивается в Комбинации Клавиш Клавиатуры в Ubuntu)
Обычно люди получают не то, что заслуживают, а то, что получилось... © Доктор Хауз

Оффлайн kiev

  • Активист
  • *
  • Сообщений: 412
    • Просмотр профиля
    • Соционическое типирование и консультирование
Re: проблема с автомонтированием
« Ответ #4 : 29 Апрель 2008, 14:11:06 »
Править /etc/fstab
так в том то и дело что флешки в убунте монтируются какой-то службой которая следит за их подключением и монтирует согласно метке диска, а метка заранее не известна.

Оффлайн Anton Bobov

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: проблема с автомонтированием
« Ответ #5 : 29 Апрель 2008, 15:48:52 »
Тоже после обновления перестали автоматически монтироваться флешки.

Помогло следующее:
открываем gconf-editor, далее в /system/storage/default_options/vfat/mount_options убрать usefree

Bug #151025 in gnome-mount
« Последнее редактирование: 29 Апрель 2008, 15:53:34 от Anton Bobov »
Ubuntu Feisty Fawn

Оффлайн Sirx

  • Участник
  • *
  • Сообщений: 189
    • Просмотр профиля
Re: проблема с автомонтированием
« Ответ #6 : 29 Апрель 2008, 15:53:23 »
Править /etc/fstab
так в том то и дело что флешки в убунте монтируются какой-то службой которая следит за их подключением и монтирует согласно метке диска, а метка заранее не известна.
Эта хитрая служба не только в убунте. Это связка hal и dbus.
_________________
Я живу не для того, чтобы соответствовать вашим ожиданиям.

Оффлайн kiev

  • Активист
  • *
  • Сообщений: 412
    • Просмотр профиля
    • Соционическое типирование и консультирование
Re: проблема с автомонтированием
« Ответ #7 : 30 Апрель 2008, 18:39:49 »
у меня вообще нет файла /system/storage/default_options/vfat/mount_options
может потому что кде?

Оффлайн Sirx

  • Участник
  • *
  • Сообщений: 189
    • Просмотр профиля
Re: проблема с автомонтированием
« Ответ #8 : 30 Апрель 2008, 20:53:04 »
у меня вообще нет файла /system/storage/default_options/vfat/mount_options
может потому что кде?
Не может, а точно потому что кде.
_________________
Я живу не для того, чтобы соответствовать вашим ожиданиям.

 

Страница сгенерирована за 0.09 секунд. Запросов: 22.