Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Ubuntu 15.04(проблема с Grub) + UEFI  (Прочитано 2650 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн veax

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Ubuntu 15.04(проблема с Grub) + UEFI
« : 30 Октябрь 2015, 23:13:18 »
  Доброго времени суток! Возникла проблема с установкой ubuntu рядом с windows 8 на мой ноутбук lenovo z500,
который имеет стандарт UEFI.
Проблема возникает практически в самом конце установки, появляется ошибка об инсталляции grub:
Распишу подробно по шагам, как я производил установку:
1. Сделал загрузочную флешку с ubuntu 15.04
2. В настройках UEFI отключил secure Boot control(disabled) и в boot menu выбрал зайти с флешки,
далее выбрал try ubuntu и собственно вошел в систему.
3. Открыл программу GParted отделил 50Гб от своего диска с виндой(на нем было свободно 110Гб)
и поделил это пространство на 3 раздела: swap(8192 мб), root(7192мб) и home все оставшееся. Делал по инструкции с
оф.сайта, sda с ESP у меня уже был, так как винда под uefi:

4. После этого на рабочем столе открыл ярлык install ubuntu, в типе установки выбрал "другой вариант" и далее
выбрал точки монтирования для root(/) и home(/home) + для sda типа efi выбрал "системный раздел efi", вообщем все
как на сайте:


5. Дальше началась установка, уже в самом ее конце возникла ошибка:"не удалось установить пакет "grub-efi-amd64-signed'
в /target/. Без системного загрузчика GRUB установленная система не будет загружаться:

Собственно после этого пробовал переустановить несколько раз, пробовал установить grub вручную через терминал,
ничего не помогло, в чем может быть проблема?

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
Re: Ubuntu 15.04(проблема с Grub) + UEFI
« Ответ #1 : 30 Октябрь 2015, 23:31:51 »
veax,
ну вообще все правильно, тебе руководства можно писать))
1) Gparted закрыл перед продолжением установки?
2) Фаст бут выключил в настройках?
3) на скрине два фат32 раздела, не ошибся правильный для Ефи выбрал?

Оффлайн veax

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 15.04(проблема с Grub) + UEFI
« Ответ #2 : 30 Октябрь 2015, 23:36:27 »
1) Да, GParted я закрывал
2) Fast Boot я не нашел в настройках своего UEFI, да и проблема не в нем, даже если я его отключу, в любом случае grub как таковой не установлен
3) Там все верно

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
Re: Ubuntu 15.04(проблема с Grub) + UEFI
« Ответ #3 : 30 Октябрь 2015, 23:38:42 »
veax,
в настройках Винды Фаст бут. Выключи её полностью, по-умолчанию она в гибернацию уходит даже если нажимать выключить

Оффлайн veax

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 15.04(проблема с Grub) + UEFI
« Ответ #4 : 31 Октябрь 2015, 00:00:24 »
wajnon,
отключил фаст бут и переустановил Ubuntu, ошибка та же осталась

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
Re: Ubuntu 15.04(проблема с Grub) + UEFI
« Ответ #5 : 31 Октябрь 2015, 00:20:43 »
veax,
а что за образ? не битый? чем записывал?
когда устанавливаешь то Ефи разделу должна точка монтирования прописатся /boot/efi или /boot/EFI не помню точно. у тебя как?

Оффлайн veax

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 15.04(проблема с Grub) + UEFI
« Ответ #6 : 31 Октябрь 2015, 00:45:28 »
wajnon,
скачивал с этого сайта образ, я устанавливал и с точкой монтирования /boot/efi для efi раздела и без нее, ошибка одинаковая все время

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
Re: Ubuntu 15.04(проблема с Grub) + UEFI
« Ответ #7 : 31 Октябрь 2015, 01:05:20 »
veax,
а чем записывал, какой прогой?

Оффлайн veax

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 15.04(проблема с Grub) + UEFI
« Ответ #8 : 31 Октябрь 2015, 13:53:29 »
wajnon,
Universal usb installer

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
Re: Ubuntu 15.04(проблема с Grub) + UEFI
« Ответ #9 : 31 Октябрь 2015, 14:18:09 »
veax,
кроме попробовать другой образ (например 14.04) и записать другой прогой (под виндой Rufus рекомендуют) желательно на другую флешку, идей у меня нет.

Оффлайн rolik

  • Активист
  • *
  • Сообщений: 458
    • Просмотр профиля
Re: Ubuntu 15.04(проблема с Grub) + UEFI
« Ответ #10 : 31 Октябрь 2015, 14:22:31 »
Если Windows 8 был установлен с UEFI, то кто ж это надоумил отключать UEFI при установке Ubu

Оффлайн zaskock

  • Активист
  • *
  • Сообщений: 541
  • Manjaro 15.12-dev Capella
    • Просмотр профиля
Re: Ubuntu 15.04(проблема с Grub) + UEFI
« Ответ #11 : 31 Октябрь 2015, 14:22:41 »
veax,
Згрузчик (GRUB) сами руками выбираете куда поставить, а по умолчанию куда он хочет стать не смотрели?
Правильные ответы начинаются с правильных вопросов.

Оффлайн veax

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 15.04(проблема с Grub) + UEFI
« Ответ #12 : 31 Октябрь 2015, 14:39:58 »
zaskock,
по умолчанию это /dev/sda ATA ST1000LM024 HN-M(1.0TB)

Пользователь решил продолжить мысль [time]31 Октябрь 2015, 15:43:46[/time]:
Вообщем попробовал создать новый раздел с типом EFI, без удаления старого(на котором Windows Boot Manager, может были проблемы с совместимостью) и указал этот новый раздел, как устройство для установки загрузчика, но проблема опять таки осталась та же самая


Пользователь решил продолжить мысль [time]31 Октябрь 2015, 15:52:26[/time]:
Вспомнил, что раньше попробовал поменять в настройках uefi на legacy, и потом выбрать windows boot manager как резервную загрузочную область bios, в итоге все установилось без ошибок и при перезагрузке появился загрузчик grub, но когда пытался войти и в винду и в Ubuntu, ни одна из систем не захотела грузиться, в итоге вернул legacy обратно в uefi

Пользователь решил продолжить мысль 31 Октябрь 2015, 18:47:13:
Проблема решена) в настройках биоса сменил все таки uefi на legacy, через try ubuntu поставил себе boot repair, сделал проверку и перезагрузил комп, grub заработал, винда и ubuntu стоят рядом)
« Последнее редактирование: 31 Октябрь 2015, 18:47:13 от veax »

 

Страница сгенерирована за 0.096 секунд. Запросов: 24.