Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: И опять LTE модем и pppd!  (Прочитано 1644 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн DiSyA

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
И опять LTE модем и pppd!
« : 22 Февраль 2016, 14:24:16 »
Доброго времени суток!
Други, сил больше нет бороться, посему прошу помощи.
Есть lte модем Huawei E392u-12 (мегафоновская симка). Прекрасно себя зарекомендовал и работал в Ubuntu 12.х-14.х.
Чего-то произошло и в 15.10 работать отказывается с теми же самыми конфигами.
Симптомы следующие (набираем pon Megafon или ручками вызываем pppd call Megafon), соединение устанавливается, назначается ip адрес, прописываются dns сервера, всё вроде бы хорошо, но сети нет.
ping 8.8.8.8 выдаёт
connect: Network is unreachable

ifconfig кажет, что интерфейс есть

ppp0      Link encap:Протокол PPP (Point-to-Point Protocol) 
          inet addr:100.64.46.37  P-t-P:10.64.64.64  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:7 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:70 (70.0 B)  TX bytes:142 (142.0 B)

В логах тоже нет явной ругани:

Feb 21 18:32:03 Aspire-V3-551G chat[4256]: AT+CGDCONT=1,"IP","internet","",0,0^M^M
Feb 21 18:32:03 Aspire-V3-551G chat[4256]: OK
Feb 21 18:32:03 Aspire-V3-551G chat[4256]:  -- got it
Feb 21 18:32:03 Aspire-V3-551G chat[4256]: send (ATD*99#^M)
Feb 21 18:32:03 Aspire-V3-551G chat[4256]: timeout set to 22 seconds
Feb 21 18:32:03 Aspire-V3-551G chat[4256]: expect (CONNECT)
Feb 21 18:32:03 Aspire-V3-551G chat[4256]: ^M
Feb 21 18:32:03 Aspire-V3-551G chat[4256]: ATD*99#^M^M
Feb 21 18:32:03 Aspire-V3-551G chat[4256]: CONNECT
Feb 21 18:32:03 Aspire-V3-551G chat[4256]:  -- got it
Feb 21 18:32:03 Aspire-V3-551G chat[4256]: send (^M)
Feb 21 18:32:03 Aspire-V3-551G pppd[4254]: Serial connection established.
Feb 21 18:32:03 Aspire-V3-551G pppd[4254]: Using interface ppp0
Feb 21 18:32:03 Aspire-V3-551G pppd[4254]: Connect: ppp0 <--> /dev/ttyUSB0
Feb 21 18:32:03 Aspire-V3-551G NetworkManager[685]: nm_device_get_device_type: assertion 'NM_IS_DEVICE (self)' failed
Feb 21 18:32:03 Aspire-V3-551G NetworkManager[685]: <info>  (ppp0): new Generic device (carrier: UNKNOWN, driver: 'unknown', ifindex: 9)
Feb 21 18:32:03 Aspire-V3-551G NetworkManager[685]: <info>  devices added (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
Feb 21 18:32:03 Aspire-V3-551G NetworkManager[685]: <info>  device added (path: /sys/devices/virtual/net/ppp0, iface: ppp0): no ifupdown configuration found.
Feb 21 18:32:04 Aspire-V3-551G pppd[4254]: PAP authentication succeeded
Feb 21 18:32:07 Aspire-V3-551G pppd[4254]: Could not determine remote IP address: defaulting to 10.64.64.64
Feb 21 18:32:07 Aspire-V3-551G pppd[4254]: local  IP address 100.64.46.37
Feb 21 18:32:07 Aspire-V3-551G pppd[4254]: remote IP address 10.64.64.64
Feb 21 18:32:07 Aspire-V3-551G pppd[4254]: primary   DNS address 10.154.44.154
Feb 21 18:32:07 Aspire-V3-551G whoopsie[645]: [18:32:07] Cannot reach: https://daisy.ubuntu.com
Feb 21 18:32:07 Aspire-V3-551G NetworkManager[685]: <info>  keyfile: add connection in-memory (95622919-58a0-471f-8b38-cefadbde8810,"ppp0")
Feb 21 18:32:07 Aspire-V3-551G pppd[4254]: secondary DNS address 85.26.231.188
Feb 21 18:32:07 Aspire-V3-551G NetworkManager[685]: <info>  (ppp0): device state change: unmanaged -> unavailable (reason 'connection-assumed') [10 20 41]
Feb 21 18:32:07 Aspire-V3-551G NetworkManager[685]: <info>  (ppp0): device state change: unavailable -> disconnected (reason 'connection-assumed') [20 30 41]
Feb 21 18:32:07 Aspire-V3-551G NetworkManager[685]: <info>  Device 'ppp0' has no connection; scheduling activate_check in 0 seconds.
Feb 21 18:32:07 Aspire-V3-551G NetworkManager[685]: <info>  (ppp0): Activation: starting connection 'ppp0' (95622919-58a0-471f-8b38-cefadbde8810)
Feb 21 18:32:07 Aspire-V3-551G NetworkManager[685]: <info>  (ppp0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Feb 21 18:32:07 Aspire-V3-551G NetworkManager[685]: <info>  (ppp0): device state change: prepare -> config (reason 'none') [40 50 0]
Feb 21 18:32:07 Aspire-V3-551G NetworkManager[685]: <info>  (ppp0): device state change: config -> ip-config (reason 'none') [50 70 0]
Feb 21 18:32:07 Aspire-V3-551G NetworkManager[685]: <info>  (ppp0): device state change: ip-config -> ip-check (reason 'none') [70 80 0]
Feb 21 18:32:07 Aspire-V3-551G NetworkManager[685]: <info>  (ppp0): device state change: ip-check -> secondaries (reason 'none') [80 90 0]
Feb 21 18:32:07 Aspire-V3-551G NetworkManager[685]: <info>  (ppp0): device state change: secondaries -> activated (reason 'none') [90 100 0]
Feb 21 18:32:07 Aspire-V3-551G NetworkManager[685]: <info>  NetworkManager state is now CONNECTED_LOCAL
Feb 21 18:32:07 Aspire-V3-551G NetworkManager[685]: <info>  (ppp0): Activation: successful, device activated.
Feb 21 18:32:07 Aspire-V3-551G dbus[662]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service'
Feb 21 18:32:07 Aspire-V3-551G systemd[1]: Starting Network Manager Script Dispatcher Service...
Feb 21 18:32:07 Aspire-V3-551G dbus[662]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Feb 21 18:32:07 Aspire-V3-551G systemd[1]: Started Network Manager Script Dispatcher Service.
Feb 21 18:32:07 Aspire-V3-551G nm-dispatcher: Dispatching action 'up' for ppp0

Пробовал использовать wvdial - результат тот же.
Помогите, пожалуйста побороть проблему, сам что-то никак не осиляю!

Оффлайн vip.lohmatiy

  • Забанен
  • Активист
  • *
  • Сообщений: 555
  • RealScanFoto
    • Просмотр профиля
Re: И опять LTE модем и pppd!
« Ответ #1 : 22 Февраль 2016, 14:45:10 »
pppd или ppp0 ?
CPU-1.1G , RAM-640M , VGA-16M , рядом Матэ белка.

Оффлайн DiSyA

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: И опять LTE модем и pppd!
« Ответ #2 : 22 Февраль 2016, 14:59:42 »
pppd или ppp0 ?
Не понял вопроса...
pppd - утилита
ppp0 - интерфейс.

Оффлайн vip.lohmatiy

  • Забанен
  • Активист
  • *
  • Сообщений: 555
  • RealScanFoto
    • Просмотр профиля
Re: И опять LTE модем и pppd!
« Ответ #3 : 22 Февраль 2016, 15:12:35 »
 inet addr:100.64.46.37  P-t-P:10.64.64.64   <--- 3 октет правильно?
CPU-1.1G , RAM-640M , VGA-16M , рядом Матэ белка.

Оффлайн DiSyA

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: И опять LTE модем и pppd!
« Ответ #4 : 22 Февраль 2016, 15:22:53 »
Вредитель найден :) Им оказался network-manager!
Стопим его:
service network-manager stop И вуа ля
root@Aspire-V3-551G:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=50 time=123 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=50 time=188 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=50 time=123 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=50 time=103 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=50 time=99.9 ms
64 bytes from 8.8.8.8: icmp_seq=6 ttl=50 time=98.7 ms
^C
--- 8.8.8.8 ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 5007ms
rtt min/avg/max/mdev = 98.775/123.111/188.860/31.180 ms

root@Aspire-V3-551G:~# ping google.ru
PING google.ru (37.29.1.212) 56(84) bytes of data.
64 bytes from 37.29.1.212: icmp_seq=1 ttl=54 time=83.5 ms
64 bytes from 37.29.1.212: icmp_seq=2 ttl=54 time=39.5 ms
^C
--- google.ru ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 39.503/61.523/83.544/22.021 ms

Как обычно netwok-manager подтвердил свою кривизну :)
Всем спасибо за попытки помочь!

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13347
  • Xubuntu 18.04
    • Просмотр профиля
Re: И опять LTE модем и pppd!
« Ответ #5 : 22 Февраль 2016, 15:29:23 »
DiSyA,
Никакой кривизны тут нет. Вы либо с помощью NM настраиваете, либо без. А так ни рыба, ни мясо было.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн DiSyA

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: И опять LTE модем и pppd!
« Ответ #6 : 28 Февраль 2016, 07:58:33 »
Кривизна есть, т.к. nm не может подключиться, пишет "подключение невозможно", а старый добрый pppd работает.

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 2112
    • Просмотр профиля
Re: И опять LTE модем и pppd!
« Ответ #7 : 28 Февраль 2016, 12:51:21 »
Когда я в начале 2000-х попробовал подключиться по GPRS через телефон,
я пользовался chat, а не wwdial, запускал pppd каким-то скриптом,
требовалось только настроить конфигурационные файлы в /etc/ppp/. NM не требовлся.

Недавно я подключился через смартфон же, сначала подключил его командами
mmcli -L
mmcli -e -m <N>
N- что вернул 1-я команда, а затем с помощью Network Manager подключился к сети:
nmcli connection add type gsm ifname ppp0 apn internet user mts password mts
nmcli device connect ppp0
nmcli connection up ifname ppp0
т.к. у меня МТС, выключался в обратном порядке:
nmcli connection down ppp0
nmcli device disconnect ppp0
nmcli connection delete ppp0
Пётр.

Оффлайн DiSyA

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: И опять LTE модем и pppd!
« Ответ #8 : 28 Февраль 2016, 16:22:41 »
denis@Aspire-V3-551G:~$ mmcli -e -m /org/freedesktop/ModemManager1/Modem/0 [QUALCOMM INCORPORATED] 0
successfully enabled the modem

denis@Aspire-V3-551G:~$ nmcli connection add type gsm ifname ppp0 apn internet
Connection 'gsm-ppp0' (714d57d0-ae42-4877-b96d-331d890d4a7f) successfully added.

denis@Aspire-V3-551G:~$ nmcli device connect ppp0
Ошибка: не найдено устройство «ppp0».

А если тыкать через GUI, то получаем такие сообщения (см. вложение)


Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 2112
    • Просмотр профиля
Re: И опять LTE модем и pppd!
« Ответ #9 : 28 Февраль 2016, 23:55:35 »
В команде "mmcli -e -m <N>" надо указать только номер, т.е. в данном случае 0,
а почему не выполнилаь команда "nmcli device connect ppp0", не знаю.
Попробуйте в случае ошибки ввести
nmcli device statusили
nmcli device show ppp0
Пользователь решил продолжить мысль 29 Февраль 2016, 20:58:13:
Если 1-ю команду с nmcli ввели действительно так, как показано,
то попробуйте полностью, с user и password.
« Последнее редактирование: 29 Февраль 2016, 20:58:13 от Peter_I »
Пётр.

Оффлайн DiSyA

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: И опять LTE модем и pppd!
« Ответ #10 : 01 Март 2016, 13:54:00 »

Found 1 modems:
        /org/freedesktop/ModemManager1/Modem/0 [QUALCOMM INCORPORATED] 0

denis@Aspire-V3-551G:~$ mmcli -e -m 0
successfully enabled the modem
denis@Aspire-V3-551G:~$ nmcli connection add type gsm ifname ppp0 apn internet user gdata password gdata
Connection 'gsm-ppp0-3' (b5c5daa9-5f98-41ff-a3df-af77dd695667) successfully added.
denis@Aspire-V3-551G:~$ nmcli device status
УСТРОЙСТВО         ТИП       СОСТОЯНИЕ       СОЕДИНЕНИЕ
wlp3s0             wifi      подключено      air-5     
0C:00:11:E7:D6:6B  bt        отключено       --         
enp2s0             ethernet  недоступен      --         
cdc-wdm1           gsm       недоступен      --         
lo                 loopback  без управления  --         
denis@Aspire-V3-551G:~$ nmcli device show ppp0
Ошибка: не найдено устройство «ppp0».
denis@Aspire-V3-551G:~$


Пользователь решил продолжить мысль 01 Март 2016, 14:23:13:
и ещё интересный момент.

denis@Aspire-V3-551G:~$ nmcli device show cdc-wdm1
GENERAL.УСТРОЙСТВО:                     cdc-wdm1
GENERAL.ТИП:                            gsm                                                                                                                                                     
GENERAL.АППАРАТНЫЙ АДРЕС:               (неизвестно)                                                                                                                                           
GENERAL.MTU:                            0                                                                                                                                                       
GENERAL.СОСТОЯНИЕ:                      20 (недоступен)                                                                                                                                         
GENERAL.СОЕДИНЕНИЕ:                     --                                                                                                                                                     
GENERAL.CON-PATH:                       --                                                                                                                                                     
denis@Aspire-V3-551G:~$ nmcli device show ppp0
Ошибка: не найдено устройство «ppp0».                                                                                                                                                           
denis@Aspire-V3-551G:~$

denis@Aspire-V3-551G:~$ nmcli device connect cdc-wdm1
Error: Failed to add/activate new connection: gsm: GSM mobile broadband connection requires a 'gsm' setting

Похоже поэтому и ГУЙ не может запустить соединение.
« Последнее редактирование: 01 Март 2016, 14:23:13 от DiSyA »

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 2112
    • Просмотр профиля
Re: И опять LTE модем и pppd!
« Ответ #11 : 03 Март 2016, 17:25:11 »
Я поозреваю, что я неправильно привёл команду для подключeния, а именно аргумент опции "apn".
В моём случае должно было быть "internet.mts.ru". Уточните точное название у провайдера или
в его салоне.
Пётр.

Оффлайн badbob

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: И опять LTE модем и pppd!
« Ответ #12 : 06 Август 2018, 09:00:51 »
Столкнулся со схожей проблемой. После обновления Ubuntu 17.10 -> 18.04 перестал работать модем Huawei E1550.

$ nmcli device
DEVICE TYPE STATE CONNECTION
enp4s0 ethernet disconnected --
wlp3s0 wifi disconnected --
ttyUSB2 gsm unavailable --
lo loopback unmanaged --

$ nmcli device show ttyUSB2
GENERAL.DEVICE: ttyUSB2
GENERAL.TYPE: gsm
GENERAL.HWADDR: (unknown)
GENERAL.MTU: 0
GENERAL.STATE: 20 (unavailable)
GENERAL.CONNECTION: --
GENERAL.CON-PATH: --

$ nmcli device connect ttyUSB2
Error: Failed to add/activate new connection: gsm: GSM mobile broadband connection requires a 'gsm' setting

Удалось найти решение?

 

Страница сгенерирована за 0.118 секунд. Запросов: 22.