Форум русскоязычного сообщества Ubuntu


Автор Тема: Помогите собрать fb2edit из исходников (Решено! Спасибо alang)  (Прочитано 2464 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн march

  • Автор темы
  • Участник
  • *
  • Сообщений: 114
  • Долой демократию! Да здравствует свобода!
    • Просмотр профиля
На рабочем компе установлен Ubuntu 10.04. Комп слабенький, и хозяин категорически против обновления системы. Возникла необходимость установки fb2edit, но на сайте есть только версии, начиная с 10.10, установить из деб-пакета не получается. Скачал с офсайта http://fb2edit.lintest.ru/ fb2edit-0.0.8.tar.bz2, прочитал статью https://forum.ubuntu.ru/index.php?topic=11609.0, но ничего не получилось, так как файла configure в пакете нет.

Помогите, пожалуйста!
« Последнее редактирование: 25 Февраль 2016, 15:56:03 от march »
Долой демократию!
Да здравствует свобода!

Оффлайн Haron Prime

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 11315
  • Arch Linux & XMonad
    • Просмотр профиля
Re: Помогите собрать fb2edit из исходников
« Ответ #1 : 25 Февраль 2016, 14:06:08 »
там может и не быть configure - в некоторых случая сразу делается make, это во-первых
во-вторых, файл README (или что-то похожее, типа READ.ME) там есть? теоретически должен быть - в нём инструкция по установке. возможно, что там присутствует текстовой файл под другим названием, типа install.txt - распаковывайте и смотрите содержимое каталога
в-третьих, Вы уверены, что это именно исходники, а не бинарная сборка, не требующая компиляции?
« Последнее редактирование: 25 Февраль 2016, 14:08:40 от Haron Prime »
sudo ls -a | grep brain > /dev/head

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2508
    • Просмотр профиля
Re: Помогите собрать fb2edit из исходников
« Ответ #2 : 25 Февраль 2016, 15:10:59 »
march, все просто. Нужно:
1) установить cmake
2) распаковать скачанный архив в какую-нибудь папку
3) далее в терминале, последовательно:
cd /путь/до/папки/с/распакованным/архивом
mkdir build
cd ./build
cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make
sudo make install
Все.
Но наверняка будут подводные камни в виде неудовлетворенных зависимостей. Тогда потребуется доустановить необходимые пакеты и повторить сборку, предварительно очистив директорию build.
Я никого не сторожил!

Оффлайн march

  • Автор темы
  • Участник
  • *
  • Сообщений: 114
  • Долой демократию! Да здравствует свобода!
    • Просмотр профиля
Re: Помогите собрать fb2edit из исходников
« Ответ #3 : 25 Февраль 2016, 15:18:15 »
2. readme действительно есть, в нем только данные об авторе.
Есть файл  CMakeLists.txt, только я не знаю, как ним пользоваться.
3. Архив действительно с исходниками
Долой демократию!
Да здравствует свобода!

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2508
    • Просмотр профиля
Re: Помогите собрать fb2edit из исходников
« Ответ #4 : 25 Февраль 2016, 15:31:06 »
Есть файл  CMakeLists.txt, только я не знаю, как ним пользоваться.

Этот файл не для тебя, а для cmake. Вероятно, ту "абракадабру", что я написал, ты читать не стал.
Ну, успехов.
Я никого не сторожил!

Оффлайн march

  • Автор темы
  • Участник
  • *
  • Сообщений: 114
  • Долой демократию! Да здравствует свобода!
    • Просмотр профиля
Re: Помогите собрать fb2edit из исходников
« Ответ #5 : 25 Февраль 2016, 15:32:11 »
alang

-- PACKAGE_NAME = fb2edit 0.0.8
CMake Error at /usr/share/cmake-2.8/Modules/FindQt4.cmake:1726 (MESSAGE):
  Qt qmake not found!
Call Stack (most recent call first):
  CMakeLists.txt:24 (find_package)


-- Configuring incomplete, errors occurred!

Я так понял, что еще какой-то пакет не установлен?


Пользователь решил продолжить мысль [time]25 Февраль 2016, 16:35:29[/time]:
alang

Этот ответ был не для вас, а для Haron Prime, просто так наложилось. Я пробую именно ваш вариант

Пользователь решил продолжить мысль 25 Февраль 2016, 15:54:44:
Ура! Сработало!

Спасибо alang
« Последнее редактирование: 25 Февраль 2016, 15:54:44 от march »
Долой демократию!
Да здравствует свобода!

Оффлайн voskrese

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Помогите собрать fb2edit из исходников
« Ответ #6 : 29 Март 2016, 19:20:45 »
sudo make install
давно уже не рекомендуют, поломает пакеты...
лучше создать deb и попробывать установить, а дальше видно будет

 

Страница сгенерирована за 0.062 секунд. Запросов: 24.