Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Форсирование 3G-соединения в NetworkManager  (Прочитано 1363 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Mutafakaz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Добрый день
Исполосовал весь интернет и этот форум в драбадан, но ответа так и нет ((
Есть специфическое устройство, Cinterion PHS8
Есть Ubuntu 16.04, версия ядра 4.4.1
Есть Network Manager версии 1.1.93

Есть проблема - самопроизвольное соединение с 3G/EGDE при автоподключении. То есть все отлично подключается и даже без иксов в консольном режиме "nmcli c" выдает что все подключено.., НО - зачастую в типе стоит "gsm", изредка "umts". В иксах та же беда - то UMTS, то GSM, причем зачастую GSM, когда ему хочется. В настройках аплета NM есть вкладка "тип сети", выбираю там "Только 3G" - нажимаю ОК, и.. нифига не меняется - если опять открыть настройки подключения - в типе опять стоит "любой" ((

К сожалению, в настройках устройства не нашел АТ-команды, чтобы форсировать 3G подключение
Но и в настройках NM, получается этого не получается сделать

Как быть? Нужен 3G ))

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26096
    • Просмотр профиля
Re: Форсирование 3G-соединения в NetworkManager
« Ответ #1 : 14 Июнь 2016, 19:45:31 »
Без знания команд ничего так и не получится.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Mutafakaz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Форсирование 3G-соединения в NetworkManager
« Ответ #2 : 14 Июнь 2016, 20:00:54 »
Отсутствует специальная АТ команда (( есть только команда проверки статуса подключения
То есть правильно ли я понимаю, что настраивать пытаться NM бесполезно?

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26096
    • Просмотр профиля
Re: Форсирование 3G-соединения в NetworkManager
« Ответ #3 : 14 Июнь 2016, 20:04:16 »
NM не святым духом настройки делает, а теми же AT командами.
Пинайте саппорт вашего устройства, пусть колятся.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 1801
    • Просмотр профиля
Re: Форсирование 3G-соединения в NetworkManager
« Ответ #4 : 15 Июнь 2016, 00:22:25 »
Попробуйте перед nmcli подключить модем вручную с помощью mmcli.
Например, если "mmcli -L" вернёт 0, то
mmcli -e -m 0Ubuntu после этого сама подключит модем или телефон к Интернету.
Если же не подключит и надо будет самому вводить команды nmcli,
то перед этим можно ввести команду, в случае МТС,
mmcli -m 0 --simple-connect="apn=internet,user=mts,password=mts"хотя user и password вроде бы не обязательно. man mmcli.
Пётр.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26096
    • Просмотр профиля
Re: Форсирование 3G-соединения в NetworkManager
« Ответ #5 : 15 Июнь 2016, 00:39:30 »
Peter_I, ты топик прочёл?… А понял?…
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 1801
    • Просмотр профиля
Re: Форсирование 3G-соединения в NetworkManager
« Ответ #6 : 15 Июнь 2016, 08:50:09 »
AnrDaemon,
Так если самому подключиться с помощью mmcli, то он и подключит как надо?
Можно и вообще отключить NM, чтобы не было автоматического подключения и подключаться только вручную.
« Последнее редактирование: 15 Июнь 2016, 08:52:05 от Peter_I »
Пётр.

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13751
    • Просмотр профиля
Re: Форсирование 3G-соединения в NetworkManager
« Ответ #7 : 15 Июнь 2016, 09:29:31 »
видимо не понял
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 1801
    • Просмотр профиля
Re: Форсирование 3G-соединения в NetworkManager
« Ответ #8 : 15 Июнь 2016, 13:48:40 »
Хорошо, у mmcli есть ещё команды  --set-allowed-modes и --set-preferred-mode.
Пётр.

Оффлайн Mutafakaz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Форсирование 3G-соединения в NetworkManager
« Ответ #9 : 15 Июнь 2016, 16:15:50 »
Саппорт ответил так:
Цитировать
Поменять приоритет вручную АТ командой к сожалению нельзя. Но можно жестко ограничить технологию доступа и частотные диапазоны модуля
К сожалению, ограничение GSM диапазона 1800/1900 Мегагерцами не помогло - все равно подключает GPRS

В общем, я так понимаю, обломтус полный ))
« Последнее редактирование: 15 Июнь 2016, 16:30:46 от Mutafakaz »

Оффлайн maksvlad

  • Активист
  • *
  • Сообщений: 663
    • Просмотр профиля
Re: Форсирование 3G-соединения в NetworkManager
« Ответ #10 : 15 Июнь 2016, 17:12:59 »

Есть проблема - самопроизвольное соединение с 3G/EGDE при автоподключении. То есть все отлично подключается и даже без иксов в консольном режиме "nmcli c" выдает что все подключено.., НО - зачастую в типе стоит "gsm", изредка "umts". В иксах та же беда - то UMTS, то GSM, причем зачастую GSM, когда ему хочется. В настройках аплета NM есть вкладка "тип сети", выбираю там "Только 3G" - нажимаю ОК, и.. нифига не меняется - если опять открыть настройки подключения - в типе опять стоит "любой" ((

К сожалению, в настройках устройства не нашел АТ-команды, чтобы форсировать 3G подключение
Но и в настройках NM, получается этого не получается сделать

Как быть? Нужен 3G ))
проблему в качестве связи вижу я.
Местоположение свистка поменять попробуй.
Да пребудет с тобой космонавт!
А если серьёзно,  то возможно,  что в месте, где подключаешь провайдер не может обеспечить передачу выше жпрс. Попробуй поменять оператора, место расположения
« Последнее редактирование: 15 Июнь 2016, 17:14:49 от maksvlad »
openSUSE 12.3 > openSUSE 13.1 > Ubuntu-minimal 14.04 x64 + KDE 4.14.2 > Gentoo + Plasma 5.8 @ Acer ASPIRE V3-571G-736b8G75BDCa
LinuxMint Mate @ Asus EEEPC 1000H

Оффлайн Mutafakaz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Форсирование 3G-соединения в NetworkManager
« Ответ #11 : 15 Июнь 2016, 17:13:42 »
--set-preferred-mode=3g
пишет "error: setting preferred mode requires list of allowed modes"
если делать
--set-allowed-modes=3g, то и вовсе ерунда какая-то:
Цитировать
error: couldn't set allowed modes:
'GDBus.Error:org.freedesktop.ModemManager1.Error.Core.Unsupported:
Setting allowed modes is not supported by this device'
причем если сделать --set-allowed-modes=2g, то все работает - и потом при выполнении mmcli -m 0 видно "allowed: 2g, preferred: none", бред какой-то. Обратно возвращается командой --set-allowed-modes=any, если же выполнить обе команды одновременно:
--set-allowed-modes=any --set-preferred-mode=3g, то получается тоже облом: "given combination of allowed and preferred modes is not supported"

Ну и чо делать? :(


Пользователь добавил сообщение 15 Июнь 2016, 17:15:48:
maksvlad, оператор МТС, рядом лежит USB-модем с такой же точно симкой МТС, уровень 3G на отлично, все настраивается и работает
да и этот девайс иногда "падает" на 3G (в KDE появляется значок U), но редко
« Последнее редактирование: 15 Июнь 2016, 17:15:48 от Mutafakaz »

Оффлайн maksvlad

  • Активист
  • *
  • Сообщений: 663
    • Просмотр профиля
Re: Форсирование 3G-соединения в NetworkManager
« Ответ #12 : 15 Июнь 2016, 17:23:40 »
К почему отвергнут вариант, что проблема в железе? от смены ОС поведение не меняется?
openSUSE 12.3 > openSUSE 13.1 > Ubuntu-minimal 14.04 x64 + KDE 4.14.2 > Gentoo + Plasma 5.8 @ Acer ASPIRE V3-571G-736b8G75BDCa
LinuxMint Mate @ Asus EEEPC 1000H

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 1801
    • Просмотр профиля
Re: Форсирование 3G-соединения в NetworkManager
« Ответ #13 : 15 Июнь 2016, 17:29:18 »
Если другой модем с такой SIM-картой подключается как надо, то ясно, что причина в устройстве.
Пётр.

Оффлайн Mutafakaz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Форсирование 3G-соединения в NetworkManager
« Ответ #14 : 15 Июнь 2016, 18:33:43 »
Заработало
после танцев с бубном с подбором диапазонов на железке внезапно и переключение --set-allowed-modes=3g сработало, и подключаться стал к 3G стабильно

Спасибо всем.

НО ))

Тут возникла новая херня
Железка поддерживает GPS. И он работает. И его можно включить modemmanager'ом (mmcli -m 0 --location-enable-gps-nmea), но вот какая загвоздка - это нужно сделать сразу после старта системы (программа стартует, которая работает с GPS), однако сразу модем-менеджер не поднимает устройство - это происходит через некоторое время после загрузки. Если эту строчку прописать в bashrc, то при старте сразу же видим "error: couldn't find modem at '/org/freedesktop/ModemManager1/Modem/0". Если подождать немного и повторить команду - все работает. Если в bashrc вставить sleep 10, например, а после команду включения - тоже запускается и работает.
Внимание вопрос ))
Как написать скрипт-проверку на наличие модема и запускать его когда он "поднят"?
пока мозги дошли до проверки на сам модем менеджер:

Цитировать
if ps uax | grep -q 'ModemManager'; then mmcli -m 0 --location-enable-gps-nmea else sleep 10 fi

но как я понимаю сам-то сервис уже запущен - не запущен модем, т.к. при старте условие выполняется
в этом я что-то совершенно не силен

подскажите решение плз

 

Страница сгенерирована за 0.063 секунд. Запросов: 24.