Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Откат обновлений внутри версии 2  (Прочитано 430 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн madox

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
  • madox
    • Просмотр профиля
Откат обновлений внутри версии 2
« : 04 Сентябрь 2016, 06:23:55 »
Форум предложил создать новую тему...
Есть нетбук Acer Aspire One 722 C68kk с Ubuntu 14.04 LTS 64 на нем. Всё прекрасно работало до вчера. 03.09.2016 Update Manager предложил поставить важные обновления безопасности для железа. Установка прошла успешно, процесс не прерывался.

После перезагрузки разрешение экрана сбилось (при этом размер рабочего стола остался старым! -- некоторые ярлыки видны под срезом экрана), зверские тормоза в системе, экран не включается после сна, хотя по индикаторам бук проснулся.

В сторонних драйверах видно, что используются драйвера X.Org, на проприетарные ATI не переключается -- что-то делает, но результата нет и радиокнопка остаётся на открытых драйверах.

Есть возможность откатить это обновление?

Оффлайн τοΖεη

  • Заслуженный пользователь
  • Администратор
  • Старожил
  • *
  • Сообщений: 8615
    • Просмотр профиля
Re: Откат обновлений внутри версии 2
« Ответ #1 : 04 Сентябрь 2016, 07:20:45 »
madox, посмотреть историю последних установок в /var/log/apt/hystory.log и откатить видеодрайвер вручную.
# find / -iname '*τοΖεη*'
# /God's_Universe/Book_Of_Life_aka_LordJC_protected/τοΖεη
Subject description -->> Not an ideal but s@ved 4eVer. Final destination -->> Kingdom Of Heaven

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2515
    • Просмотр профиля
Re: Откат обновлений внутри версии 2
« Ответ #2 : 04 Сентябрь 2016, 08:02:20 »
Дело, скорей всего, не в видеодрайвере, а в том самом HWE, от которого порою больше вреда, чем пользы. Именно его ТС перепутал с "важными обновлениями безопасности для железа". Таким образом, откатывать нужно не видеодрайвер, а ядро и xserver.
Я никого не сторожил!

Оффлайн τοΖεη

  • Заслуженный пользователь
  • Администратор
  • Старожил
  • *
  • Сообщений: 8615
    • Просмотр профиля
Re: Откат обновлений внутри версии 2
« Ответ #3 : 04 Сентябрь 2016, 09:38:52 »
alang, возможно, ты больше прав чем я.
В любом случае, ТС нужно смотреть отчёт в логе.
# find / -iname '*τοΖεη*'
# /God's_Universe/Book_Of_Life_aka_LordJC_protected/τοΖεη
Subject description -->> Not an ideal but s@ved 4eVer. Final destination -->> Kingdom Of Heaven

Оффлайн madox

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
  • madox
    • Просмотр профиля
Re: Откат обновлений внутри версии 2
« Ответ #4 : 14 Сентябрь 2016, 07:00:44 »
Большое спасибо за помощь, но проверить на практике не удалось -- видео и скорость работы исправились сами (!?). Без обновлений, без моих вмешательств... Просто мне несколько раз пришлось воспользоваться буком -- вкл/выкл, и внешние признаки неисправности прошли. Однако видео продолжает упорно работать на драйверах X.org и переключаться на Atiшные отказывается.

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2515
    • Просмотр профиля
Re: Откат обновлений внутри версии 2
« Ответ #5 : 14 Сентябрь 2016, 08:16:43 »
Однако видео продолжает упорно работать на драйверах X.org и переключаться на Atiшные отказывается.

И не переключится. С этим стэком проприетарные драйвера не подерживаются.
Я никого не сторожил!

Оффлайн www777

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2596
    • Просмотр профиля
Re: Откат обновлений внутри версии 2
« Ответ #6 : 14 Сентябрь 2016, 10:06:51 »
Цитировать
Дело, скорей всего, не в видеодрайвере, а в том самом HWE, от которого порою больше вреда, чем пользы. Именно его ТС перепутал с "важными обновлениями безопасности для железа". Таким образом, откатывать нужно не видеодрайвер, а ядро и xserver.
Я так понимаю, пользователь, был на сестеме Ubuntu 14.04.2 либо 14.04.3 либо 14.04.4, и в связи с завершение поддержки указанных веток, система предложила обновиться до 14.04.5 - порты из 16.04, и отсутствие поддержки проприетарного драйвера? В таком случае, если так хочется остатья на 14.04 и сохранить проприетарный драйвер, то откатываться желательно до 14.04.1, так сохраниться поддержка ядра и иксы ещё на три года. При условии, что эта ветка совместима с вашим оборудованием. На 14.04.2 либо 14.04.3 либо 14.04.4 у вас не будет поддержки ядра и иксов.
« Последнее редактирование: 14 Сентябрь 2016, 10:08:45 от www777 »

 

Страница сгенерирована за 0.061 секунд. Запросов: 24.