Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: SqStat  (Прочитано 555 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ShadowNik

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
SqStat
« : 02 Февраль 2017, 16:01:46 »
Добрый день, поднят сервер на Debian, на нем стоит squid 3.1.20 Apach2 и SqStat, но почему то когда я обращаюсь к серверу в броузере  по http://ip/sqstat.php мне броузер показывает текст скрипта, вместо того чтобы его отрабатывать. В чем может быть дело подскажите пожалуйста.

Оффлайн Heider

  • Старожил
  • *
  • Сообщений: 1250
    • Просмотр профиля
Re: SqStat
« Ответ #1 : 02 Февраль 2017, 18:51:59 »
А php-модуль установлен\запущен?

Оффлайн bezbo

  • Старожил
  • *
  • Сообщений: 1441
    • Просмотр профиля
Re: SqStat
« Ответ #2 : 02 Февраль 2017, 21:21:27 »
sudo apachectl -M | grep php
и .conf сайта где указан путь до SqStat

Оффлайн ShadowNik

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: SqStat
« Ответ #3 : 03 Февраль 2017, 07:55:32 »
sudo apachectl -M | grep php
на данную команду отвечает что Syntax OK, а в конце файла Apache2.conf указанно:

# Include generic snippets of statements
Include conf.d/

# Include the virtual host configurations:
Include sites-enabled/

<Directory "/var/www/sqstat">
        AllowOverride All
</Directory>


Оффлайн bezbo

  • Старожил
  • *
  • Сообщений: 1441
    • Просмотр профиля
Re: SqStat
« Ответ #4 : 03 Февраль 2017, 09:37:17 »
осталось установить PHP

sudo apt-get install php7.0 libapache2-mod-php7.0

Оффлайн ShadowNik

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: SqStat
« Ответ #5 : 03 Февраль 2017, 11:48:54 »
осталось установить PHP

sudo apt-get install php7.0 libapache2-mod-php7.0

Но php стоит правда 5 версия а не 7


Пользователь добавил сообщение 03 Февраль 2017, 13:07:10:
При попытке установить данные пакеты вот что пишет:

Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 libapache2-mod-php7.0 : Зависит: php7.0-cli но он не будет установлен
                         Зависит: php7.0-common (= 7.0.15-1~dotdeb+8.1) но он не будет установлен
                         Зависит: php7.0-json но он не будет установлен
                         Зависит: php7.0-opcache но он не будет установлен
                         Зависит: apache2-api-20120211 но он не может быть установлен
                         Зависит: libc6 (>= 2.15) но 2.13-38+deb7u11 будет установлен
 php7.0 : Зависит: php7.0-common но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
« Последнее редактирование: 03 Февраль 2017, 13:07:10 от ShadowNik »

 

Страница сгенерирована за 0.165 секунд. Запросов: 24.