Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: не работает D-Link DWA-131  (Прочитано 2968 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн User DWA-131

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
не работает D-Link DWA-131
« : 24 Сентябрь 2017, 12:25:18 »
Всем, здрасте.

Умер у меня на старом ноутбуке Wi Fi.
Ноутбуку лет 10, сдавать в починку - не решение.

Взял у приятеля адаптер D-Link DWA-131, воткнул, и ничего, не заработал.

В поисках решения почитал https://forum.ubuntu.ru/index.php?topic=280988.0
Повторил все там предложенное, но результат нулевой.

lsb_release -dc ; uname -sri
Description: Ubuntu 16.04.3 LTS
Codename: xenial
Linux 4.4.0-96-generic x86_64

lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 2001:3319 D-Link Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13508
  • Xubuntu 18.04
    • Просмотр профиля
Re: не работает D-Link DWA-131
« Ответ #1 : 24 Сентябрь 2017, 20:05:13 »
Должно работать. Ядро у вас подходящее. Во всяком случае, раньше работало с таким ядром.
У меня этой железки нет, не могу проверить. А в к интернету были подключены, когда команды выполняли?
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн User DWA-131

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: не работает D-Link DWA-131
« Ответ #2 : 24 Сентябрь 2017, 21:05:40 »
Вот и приятель, который дал мне адаптер, говорил что ставил драйвер таким же способом и все работало, правда у него Минт, но не думаю что причина в этом.

И что теперь делать? Wi Fi то нужен. Может какой другой способ подскажете?


Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13508
  • Xubuntu 18.04
    • Просмотр профиля
Re: не работает D-Link DWA-131
« Ответ #3 : 24 Сентябрь 2017, 21:26:49 »
И что теперь делать? Wi Fi то нужен. Может какой другой способ подскажете?
Вы на вопрос не ответили. Другой способ - это установка того же драйвера. Только это самый лучший способ.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн User DWA-131

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: не работает D-Link DWA-131
« Ответ #4 : 24 Сентябрь 2017, 21:40:41 »
К интернету подключение было по проводу.


Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13508
  • Xubuntu 18.04
    • Просмотр профиля
Re: не работает D-Link DWA-131
« Ответ #5 : 24 Сентябрь 2017, 21:41:33 »
Ну и как? Драйвер установился?
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн User DWA-131

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: не работает D-Link DWA-131
« Ответ #6 : 24 Сентябрь 2017, 22:50:00 »
Ну и как? Драйвер установился?
Полагаю, даsudo apt-get purge rtl8192eu-dkms
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакеты, которые будут УДАЛЕНЫ:
  rtl8192eu-dkms*
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 1 пакетов, и 0 пакетов не обновлено.
После данной операции, объём занятого дискового пространства уменьшится на 10,3 MB.
Хотите продолжить? [Д/н]

Похоже наконец то получилось подключиться к Wi Fi роутеру, но в чем был затык, я так и не понял.
Просто в очередной раз удалил драйвер, правда в этот раз вместе с репозиторием ( sudo ppa-purge ppa:hanipouspilot/rtlwifi ).
А потом установил заново. Но в этот раз устанавливал из кэша, без подключения к интернету
sudo dpkg -i /var/cache/apt/archives/rtl8192eu*.deb
Что еще делал?
Ну пощелкал на всякий случай хардварной клавишей "Wireless Вкл./Выкл." которая на корпусе ноутбука.
Специально внимания не обращал, но похоже она у меня была в положении "Выкл.", дулал это не важно коль используется USB адаптер, а оказывается важно.

В общем проблема решена. Все работает.

Pilot6, спасибо!
И за драйвер, и за потраченное время.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13508
  • Xubuntu 18.04
    • Просмотр профиля
Re: не работает D-Link DWA-131
« Ответ #7 : 25 Сентябрь 2017, 01:59:49 »
User DWA-131,
Цитировать
Хотите продолжить? [Д/н]
Ну так вы выбрали продолжить или на этом остановились? Видимо продолжить вы не сумели.

Но в этот раз устанавливал из кэша, без подключения к интернетуНу это установка того же самого драйвера. Значит просто не получилось воспользоваться apt.
Он именно это и делает: скачивает пакет и устанавливает. Ну заодно еще зависимости ставит.

А клавиша выключения разумеется выключает даже USB устройство.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн User DWA-131

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: не работает D-Link DWA-131
« Ответ #8 : 25 Сентябрь 2017, 09:38:52 »
Цитировать
Хотите продолжить? [Д/н]
... Видимо продолжить вы не сумели.
Я конечно не сильно продвинутый пользователь Ubuntu, но и не совсем новичек.
Разумеется сумел, а иначе как бы я сначала удалил ранее установленный драйвер и потом установил его заново  :o


С apt тоже вроде не только что познакомился.
Думаю и в первый раз все с apt получилось нормально.
Видимо проблема была в положении клавиши выключения, хотя, для меня это было абсолютно неожиданно.

Pilot6, еще раз, спасибо.
Тему можно считать исчерпанной и закрыть.

 

Страница сгенерирована за 0.286 секунд. Запросов: 24.