Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Ubuntu 14.04 - PHP 5.5.9 -> 5.3.29  (Прочитано 1915 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн katrin-a-a

  • Автор темы
  • Любитель
  • *
  • Сообщений: 74
    • Просмотр профиля
Ubuntu 14.04 - PHP 5.5.9 -> 5.3.29
« : 23 Октябрь 2017, 17:29:27 »
В Ubuntu 14.04 устанавливается версия PHP 5.5.9 мне необходимо переустановить его на версию не выше 5.3.29. Знаю, что она устарела.
Нашла вот такое решение:
wget http://in1.php.net/distributions/php-5.3.29.tar.bz2
tar -xvf php-5.3.29.tar.bz2
cd php-5.3.29
./configure
make
make install
Перезапустила Apache. Если в консоли набрать php -v, то выводит PHP 5.3.29 (cli), однако если посмотреть через phpinfo(), то показывает PHP Version 5.5.9-1ubuntu4.22. Скажите, пожалуйста, что нужно еще сделать?


ТС не появлялся на Форуме более полугода по состоянию на 21/11/2019 (последняя явка: 24/04/2019). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 21 Ноябрь 2019, 18:46:14 от zg_nico »

Оффлайн bezbo

  • Старожил
  • *
  • Сообщений: 1445
    • Просмотр профиля
Re: Ubuntu 14.04 - PHP 5.5.9 -> 5.3.29
« Ответ #1 : 23 Октябрь 2017, 20:14:03 »
libapache2-mod-php?

Оффлайн katrin-a-a

  • Автор темы
  • Любитель
  • *
  • Сообщений: 74
    • Просмотр профиля
Re: Ubuntu 14.04 - PHP 5.5.9 -> 5.3.29
« Ответ #2 : 23 Октябрь 2017, 21:48:43 »
libapache2-mod-php?
Не поняла ваш вопрос. Если вы про libapache2-mod-php5, то при попытке установить командой apt-get install libapache2-mod-php5 пишет, что уже установлена последняя версия.

Оффлайн bezbo

  • Старожил
  • *
  • Сообщений: 1445
    • Просмотр профиля
Re: Ubuntu 14.04 - PHP 5.5.9 -> 5.3.29
« Ответ #3 : 23 Октябрь 2017, 23:02:16 »
libapache2-mod-php=phpinfo()

ppa:ondrej/php в этом тебе поможет

Оффлайн katrin-a-a

  • Автор темы
  • Любитель
  • *
  • Сообщений: 74
    • Просмотр профиля
Re: Ubuntu 14.04 - PHP 5.5.9 -> 5.3.29
« Ответ #4 : 24 Октябрь 2017, 00:04:32 »
ppa:ondrej/php
libapache2-mod-php=phpinfo() по этой комбинации гугл ничего не находит, в консоли никакой информации не выводит. Быть может правильней тогда уже смотреть через dpkg -l|grep php? Если вы хотел, чтобы я увидела версию libapache2-mod-php

А чем поможет ppa:ondrej/php если там версия от 5.6?

Оффлайн bezbo

  • Старожил
  • *
  • Сообщений: 1445
    • Просмотр профиля
Re: Ubuntu 14.04 - PHP 5.5.9 -> 5.3.29
« Ответ #5 : 24 Октябрь 2017, 10:35:05 »

Оффлайн katrin-a-a

  • Автор темы
  • Любитель
  • *
  • Сообщений: 74
    • Просмотр профиля
Re: Ubuntu 14.04 - PHP 5.5.9 -> 5.3.29
« Ответ #6 : 25 Октябрь 2017, 11:42:43 »
5.3.29
Спасибо за ссылку. Я находила этот ppa и даже устанавливала. Но работает с ним не стабильно система. Например некоторые скрипты (из-за каких мне и нужна версия 5.3) вызывают 500 ошибку.

Оффлайн bezbo

  • Старожил
  • *
  • Сообщений: 1445
    • Просмотр профиля
Re: Ubuntu 14.04 - PHP 5.5.9 -> 5.3.29
« Ответ #7 : 25 Октябрь 2017, 12:17:53 »
dpkg -l | grep libapache2-mod-php*?

Оффлайн katrin-a-a

  • Автор темы
  • Любитель
  • *
  • Сообщений: 74
    • Просмотр профиля
Re: Ubuntu 14.04 - PHP 5.5.9 -> 5.3.29
« Ответ #8 : 29 Октябрь 2017, 01:50:38 »
dpkg -l | grep libapache2-mod-php*
ii  libapache2-mod-php5   - 5.5.9+dfsg-1ubuntu4.22      - amd64 - server-side, HTML-embedded scripting language (Apache 2 module)
ii  libapache2-mod-php53  - 5.3.29-1sergeyd14.4~trusty1 - amd64 - PHP-5.3, Apache2 module.
ii  libapache2-mod-php53p - 5.3.29-1sergeyd14.4~trusty1 - all   - PHP-5.3, Apache2 module.

В настройках указано, чтобы работать с php53, информация через phpinfo выдает - PHP Version 5.3.29-Ubuntu/14.04-SergeyD/14.4

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27434
    • Просмотр профиля
Re: Ubuntu 14.04 - PHP 5.5.9 -> 5.3.29
« Ответ #9 : 29 Октябрь 2017, 03:06:31 »
Вместо того, чтобы за 10 минут исправить кривой скрипт, вы тут чёрт знает чем занимаетесь…
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн katrin-a-a

  • Автор темы
  • Любитель
  • *
  • Сообщений: 74
    • Просмотр профиля
Re: Ubuntu 14.04 - PHP 5.5.9 -> 5.3.29
« Ответ #10 : 29 Октябрь 2017, 17:21:46 »
Вместо того, чтобы за 10 минут исправить кривой скрипт, вы тут чёрт знает чем занимаетесь…
Вместо того, чтобы вникнуть в суть вопроса вы ходите по топикам и изливаете свой негатив.
Скрипт это Reg.Panel, которая использует ionCube и официально работает только 5.3.7 - 5.3.29
Вы такой гений, что исправите его за 10 минут, чего не сделали до сих пор в рег.ру? Очень интересно на это посмотреть.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27434
    • Просмотр профиля
Re: Ubuntu 14.04 - PHP 5.5.9 -> 5.3.29
« Ответ #11 : 29 Октябрь 2017, 19:38:55 »
Ну тогда ещё проще - выбросить кривой скрипт. Полно нормальных, работающих под современными версиями PHP без известных критических уязвимостей.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн katrin-a-a

  • Автор темы
  • Любитель
  • *
  • Сообщений: 74
    • Просмотр профиля
Re: Ubuntu 14.04 - PHP 5.5.9 -> 5.3.29
« Ответ #12 : 29 Октябрь 2017, 22:04:10 »
Ну тогда ещё проще - выбросить кривой скрипт. Полно нормальных, работающих под современными версиями PHP без известных критических уязвимостей.
Вы хотя бы сперва посмотрели, что такое Reg.Panel и для чего она прежде чем давать глупые советы. Покажите мне, пожалуйста, хотя бы одну панель, которая работает с reg.ru, ведь как вы говорите их полно.

p.s. может хватит влетать в топики и флудить? Здесь обсуждается конкретный вопрос, а не зачем это нужно. Даже пояснив вам для чего мне нужна такая версия вы что-то придумываете свое.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27434
    • Просмотр профиля
Re: Ubuntu 14.04 - PHP 5.5.9 -> 5.3.29
« Ответ #13 : 29 Октябрь 2017, 23:14:14 »
То, что вам не нравится ответ, не делает его неправильным.
Поддержка 5.3 закончилась БОЛЬШЕ ТРЁХ ЛЕТ НАЗАД.
http://php.net/supported-versions.php

И не вижу смысла использовать какие-то "панели", у reg.ru есть свой собственный интерфейс.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн katrin-a-a

  • Автор темы
  • Любитель
  • *
  • Сообщений: 74
    • Просмотр профиля
Re: Ubuntu 14.04 - PHP 5.5.9 -> 5.3.29
« Ответ #14 : 29 Октябрь 2017, 23:35:51 »
То, что вам не нравится ответ, не делает его неправильным.
Поддержка 5.3 закончилась БОЛЬШЕ ТРЁХ ЛЕТ НАЗАД.
http://php.net/supported-versions.php
И не вижу смысла использовать какие-то "панели", у reg.ru есть свой собственный интерфейс.
В дальнейшем буду игнорировать весь ваш флуд.
1. если бы вы читали вопросы, а не флудили, то обратили бы внимание, на первое мое сообщение, где я говорю, что знаю о том, что версия устарела.
2. "у reg.ru есть свой собственный интерфейс" - наверное открытие для вас это и есть Reg.Panel.
« Последнее редактирование: 29 Октябрь 2017, 23:56:55 от katrin-a-a »

 

Страница сгенерирована за 0.318 секунд. Запросов: 22.