Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Ubuntu 16.04.2 проблема с доступом в интернет + парадокс!  (Прочитано 884 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн barmatuha

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Добрый день всем, имеется проблема с доступом в интернет.
Проблема в следующем, почти ни одна программа не может получить доступ в интернет, как следствие, невозможно получить обновления, почту, торренты и т.д. и т.п.
Давно не заходил в Ubuntu, решил проверить обновки и на тебе, на других системах этого компа и других устройствах, доступ свободный, проблема именно в убунте, имеется ядро 4.4.0-81-generic и 4.4.0-83-generic, сейчас сижу на 4.4.0-81, думал, может новое ядро заглючило.

Вывод команд route -n и ifconfig если помогут.
Смущает соединение virbr0, что-то не припомню такого, может какой-то виртуальный мост от WMware?

(Нажмите, чтобы показать/скрыть)

(Нажмите, чтобы показать/скрыть)

А теперь парадокс, пишу сейчас в этой самой убунте через оперу с включённым VPN, то есть через прокси доступ есть, а без него ничего не грузит.
Прошу помощи от сообщества, и извиняйте, если чего ляпнул смешного, в линухе пока ещё полный нуб. :)

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3276
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
barmatuha, не поделитесь тайной, как у вас получилась Ubuntu 16 и названия интерфейсов со времен 14.04 ? Ковыряли интерфейсы?
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн barmatuha

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Ubuntu у меня ещё со времён 14.04, несколько раз обновлялась, уж чего там могло остаться от этой старой убунты, я без понятия. :o

Оффлайн barmatuha

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Удалось вернуть доступ, получилось, что ДНС не работал нормально, добавил в файле resolv.conf свой днс и гугловский заодно, и всё завертелось.
Не понятно, почему вдруг перестал работать ДНС, и из за чего.

Оффлайн Сэм

  • Активист
  • *
  • Сообщений: 391
  • чиновник и народ
    • Просмотр профиля
у Вас MTU:1500, а мне как-то Пилот6 подсказывал поменять его на 1498 (или 1492, точно уже не помню ), после чего у меня проблема с подключением к интернету решилась.
Xubuntu 20.04.1 х64 LTS. Ноутбук Dell Inspiron 1501. ОЗУ 2GiB, ЦПУ AMD Athlon(tm) 64 X2 Dual-Core Processor TK-55; Материнская плата 0UW744; WiFi BCM4311 802.11b/g

Оффлайн barmatuha

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Благодарю, но не помогало, менять его пробовал ещё с самого начала, не работало всё равно, пока не прописал днс работала только опера, и то через впн, благо, что вообще что-то работало, а то думал, что чего-то похерил на корню, не знамо как.

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3276
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Сэм, 1497
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн barmatuha

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Всем здорова ещё раз.
В продолжение истории про ДНС.
В общем, моё решение оказалось временным, ибо после каждого нового запуска системы, NM снова перезаписывал файл, в итоге связи не было снова, приходилось по новой вписывать свои настройки.
Поэтому, полазав по этим всяким интернетам, решил проблему костылём, вписал все настройки в файл interfaces, и вроде бы всё работало, но подключение было не управляемым, и это не давало мне покоя.
Решил я полазать по этим всяким интернетам снова, и наткнулся на совет проверить настройки роутера DHCP, полазав по роутеру, наткнулся на настройку Use DNSMasq for DNS, убираю галку и перезагружаю роутер, делаю рестарт NM, и о чудо, связь работает как надо и даже виджет с погодой зафурыкал сразу же, хотя до этого ничего не показывал. :D
Роутер ASUS WL-520Gc с прошивкой DD-WRT v24-sp2 (12/22/14) micro, всем бобра и удачи в решении проблем! :)
« Последнее редактирование: 17 Ноябрь 2017, 18:29:14 от barmatuha »

Оффлайн Сэм

  • Активист
  • *
  • Сообщений: 391
  • чиновник и народ
    • Просмотр профиля
EvangelionDeath,
Сэм, 1497
1492 - вот тема, где мне об этом писали  https://forum.ubuntu.ru/index.php?topic=293610.msg2307872#msg2307872
Xubuntu 20.04.1 х64 LTS. Ноутбук Dell Inspiron 1501. ОЗУ 2GiB, ЦПУ AMD Athlon(tm) 64 X2 Dual-Core Processor TK-55; Материнская плата 0UW744; WiFi BCM4311 802.11b/g

 

Страница сгенерирована за 0.252 секунд. Запросов: 22.