Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: ошибка при установке libpq-dev  (Прочитано 1411 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vergilsm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 34
    • Просмотр профиля
ошибка при установке libpq-dev
« : 14 Декабрь 2017, 16:18:24 »
ubuntu 16.04

Установил postgresql

sudo apt-get install postgresql postgresql-contrib
а

sudo apt-get install libpg-dev

выдал ошибку:

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 libpq-dev : Зависит: krb5-multidev но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

как решить проблему?

Оффлайн kmk

  • Активист
  • *
  • Сообщений: 544
    • Просмотр профиля
Re: ошибка при установке libpq-dev
« Ответ #1 : 14 Декабрь 2017, 17:30:44 »
Пакеты, имеющие неудовлетворённые зависимости:
 libpq-dev : Зависит: krb5-multidev но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

как решить проблему?
Очистить от битых пакетов:

sudo apt-get clean && sudo apt-get update
Удовлетворить зависимости:

sudo apt-get install krb5-multidev libpq-dev

Оффлайн vergilsm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 34
    • Просмотр профиля
Re: ошибка при установке libpq-dev
« Ответ #2 : 14 Декабрь 2017, 17:43:36 »
После ввода второй команды с установкой, выдал:

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 krb5-multidev : Зависит: libkrb5-3 (= 1.13.2+dfsg-5) но 1.13.2+dfsg-5ubuntu2 будет установлен
                 Зависит: libk5crypto3 (= 1.13.2+dfsg-5) но 1.13.2+dfsg-5ubuntu2 будет установлен
                 Зависит: libgssapi-krb5-2 (= 1.13.2+dfsg-5) но 1.13.2+dfsg-5ubuntu2 будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Это мне теперь что-то такое надо сделать?

sudo apt-get install libkrb5-3 libk5crypto3 libgssapi-krb5-2
« Последнее редактирование: 14 Декабрь 2017, 18:00:00 от vergilsm »

Оффлайн kmk

  • Активист
  • *
  • Сообщений: 544
    • Просмотр профиля
Re: ошибка при установке libpq-dev
« Ответ #3 : 14 Декабрь 2017, 18:26:20 »
Покажите что у вас за битые пакеты:
dpkg --get-selections | grep hold
Покажите, что у вас с репозиториями (такое бывает при каше в репозиториях):
cat /etc/apt/sources.listи здесь:
ls -a /etc/apt/sources.list.d/
(Все выводы убирайте под спойлер: )

Оффлайн vergilsm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 34
    • Просмотр профиля
Re: ошибка при установке libpq-dev
« Ответ #4 : 14 Декабрь 2017, 18:38:58 »
dpkg --get-selections | grep hold
ничего

cat /etc/apt/sources.list
(Нажмите, чтобы показать/скрыть)

ls -a /etc/apt/sources.list.d/
(Нажмите, чтобы показать/скрыть)

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
Re: ошибка при установке libpq-dev
« Ответ #5 : 14 Декабрь 2017, 18:49:13 »
dpkg --get-selections | grep hold
здесь кажись ошибка
dpkg --get-selections | grep hеld
deb https://cli-assets.heroku.com/branches/stable/apt  ?
git-core-ppa-trusty.list                               <-- 14.04
nilarimogard-webupd8-trusty.list                       <-- 14.04
heroku.list                                            ?
nodesource.list                                        ?

Оффлайн vergilsm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 34
    • Просмотр профиля
Re: ошибка при установке libpq-dev
« Ответ #6 : 14 Декабрь 2017, 18:53:16 »
dpkg --get-selections | grep hеld
Так тоже ничего

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
Re: ошибка при установке libpq-dev
« Ответ #7 : 14 Декабрь 2017, 18:58:22 »
Тогда попробуй
sudo apt install -fесли будут ошибки , покажи здесь. И что там за репы , на которые я показал?

Оффлайн vergilsm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 34
    • Просмотр профиля
Re: ошибка при установке libpq-dev
« Ответ #8 : 14 Декабрь 2017, 19:08:52 »
sudo apt install -f
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

heroku
node js
git

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
Re: ошибка при установке libpq-dev
« Ответ #9 : 14 Декабрь 2017, 19:15:01 »
deb https://cli-assets.heroku.com/branches/stable/apt
у меня эта ссылка показывает 404 ( не найдена ) , может протухла? Если она не участвует в установке , отключи , или ищи рабочую.

Оффлайн vergilsm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 34
    • Просмотр профиля
Re: ошибка при установке libpq-dev
« Ответ #10 : 14 Декабрь 2017, 19:24:37 »
А как отключить?

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
Re: ошибка при установке libpq-dev
« Ответ #11 : 14 Декабрь 2017, 19:32:01 »
поставь перед строкой #

Оффлайн vergilsm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 34
    • Просмотр профиля
Re: ошибка при установке libpq-dev
« Ответ #12 : 14 Декабрь 2017, 20:00:19 »
Готово и что теперь?

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
Re: ошибка при установке libpq-dev
« Ответ #13 : 14 Декабрь 2017, 20:12:30 »
Попробуй опять поставить этот пакет, хотя сомневаюсь.
Цитировать
apt search libpq-dev
p   libghc-postgresql-libpq-dev                     - low-level binding to libpq                               
p   libghc-postgresql-libpq-dev:i386                - low-level binding to libpq                               
v   libghc-postgresql-libpq-dev-0.9.1.1-45b46:i386  -                                                           
v   libghc-postgresql-libpq-dev-0.9.1.1-e3c81       -                                                           
p   libpq-dev                                       - заголовочные  файлы для libpq5 (библиотеки PostgreSQL)   
p   libpq-dev:i386                                  - заголовочные  файлы для libpq5 (библиотеки PostgreSQL)
или отсюда дебку возьми   https://packages.ubuntu.com/xenial/amd64/libpq-dev/download

Оффлайн vergilsm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 34
    • Просмотр профиля
Re: ошибка при установке libpq-dev
« Ответ #14 : 14 Декабрь 2017, 20:26:41 »
Через ссылку получилось.

Спасибо большое за помощь!

 

Страница сгенерирована за 0.246 секунд. Запросов: 22.