Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: install odoo8 ubuntu 18  (Прочитано 1050 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн IRIP

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
install odoo8 ubuntu 18
« : 18 Май 2018, 08:53:43 »
пытаюсь установить odoo 8 (работает на python2) на ubuntu 18

пишет ошибку

sudo apt-get install odoo
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 odoo : Зависит: python-imaging но он не может быть установлен
        Зависит: python-pypdf но он не может быть установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5367
    • Просмотр профиля
Re: install odoo8 ubuntu 18
« Ответ #1 : 18 Май 2018, 09:39:03 »
в релизе 18.04 пакета odoo нет.

обновляли дистрибутив до 18.04 с предыдущей версии?

Оффлайн IRIP

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: install odoo8 ubuntu 18
« Ответ #2 : 18 Май 2018, 11:17:40 »
в релизе 18.04 пакета odoo нет.

да, я ставил так:

поставил postgresql. настроил...


# wget -O - https://nightly.odoo.com/odoo.key | apt-key add -
# echo "deb http://nightly.odoo.com/8.0/nightly/deb/ ./" >> /etc/apt/sources.list
# apt-get update && apt-get install odoo



но возникает ошибка

Зависит: python-imaging но он не может быть установлен
Зависит: python-pypdf но он не может быть установлен




Пользователь добавил сообщение 18 Май 2018, 11:32:46:
может это связано с тем, что ubuntu 18 по умолчанию использует python3?
« Последнее редактирование: 18 Май 2018, 11:32:46 от IRIP »

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5367
    • Просмотр профиля
Re: install odoo8 ubuntu 18
« Ответ #3 : 18 Май 2018, 11:55:42 »
Зависит: python-imaging но он не может быть установлен Зависит: python-pypdf но он не может быть установлен

попробуйте загрузить пакеты из предыдущего релиза Ubuntu и установить вручную.

Оффлайн IRIP

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: install odoo8 ubuntu 18
« Ответ #4 : 18 Май 2018, 12:53:12 »
попробуйте загрузить пакеты из предыдущего релиза Ubuntu и установить вручную.


а как это сделать, в сети пробовал инструкцию найти, не смог

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5367
    • Просмотр профиля
Re: install odoo8 ubuntu 18
« Ответ #5 : 18 Май 2018, 15:08:32 »
прочтите в разделе Документация статью "Установка пакетов вручную".

Оффлайн IRIP

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: install odoo8 ubuntu 18
« Ответ #6 : 18 Май 2018, 17:57:25 »
Да, спасибо, помогло


Пользователь добавил сообщение 18 Май 2018, 17:58:06:
удовлетворил я эти зависимости =)

нужно в source.list ubuntu 18 прописать source.list от ubuntu 16
потом удалить все, что до этого делалось (установка odoo)

потом:

sudo -su root

apt-get update

apt-get upgrade

apt-get remove odoo

deluser odoo (и все, что с ним связано)

reboot

apt-get purge odoo

apt-get purge postgresql (при условии, что прописана установка 10 версии)

reboot
руками удалить все файлы с диска начинающиеся odoo* я это делал через mc

reboot

sudo apt-get install nodejs nodejs-legacy node-less

sudo apt-get install npm

sudo npm install -g less

sudo npm install -g less-plugin-clean-css

sudo ln -s /usr/local/bin/lessc /usr/bin/lessc

sudo ln -s /usr/bin/nodejs /usr/bin/node

sudo npm install -g npm

sudo npm install -g less less-plugin-clean-css

sudo apt-get install lxc

reboot

sudo -su root

apt-get -y update && apt-get -y upgrade && apt-get -y install python python-egenix-mxdatetime python-dateutil python-pybabel python-openid python-feedparser python-lxml python-libxml2 python-libxslt1 python-psycopg2 python-libxml2 python-libxslt1 python-imaging python-gdata python-ldap python-reportlab python-pyparsing python-simplejson python-pydot python-webdav graphviz python-werkzeug python-matplotlib python-vatnumber python-numpy python-pychart python-vobject python-zsi python-xlwt python-hippocanvas python-profiler python-dev python-setuptools postgresql postgresql-client-common python-yaml python-mako gcc mc python-babel python-feedparser python-reportlab-accel python-zsi python-openssl python-jinja2 python-unittest2 python-mock python-docutils lptools make python-psutil python-paramiko poppler-utils python-pdftools antiword python-jinja2 python-requests git-core sudo python-decorator python-pypdf python-passlib xsltproc xmlstarlet python-soappy python-qrencode curl npm && curl -sL https://deb.nodesource.com/setup | bash - && apt-get -y install nodejs && npm install -g npm && npm install -g less less-plugin-clean-css

reboot

sudo -su root

aptitude install odoo
=)

вот как-то так...

http://www.cyberforum.ru/python/thread2247659.html#post12401663


Просьба при добавлении в сообщения длинных листингов следовать Правилам форума:
Цитировать
Правила форума
1.4. Листинги и содержимое текстовых файлов следует добавлять в сообщение с помощью тегов [spoiler]...[/spoiler] или [code]...[/code], либо прикреплять к сообщению в виде отдельного файла. Длинные гиперссылки следует оформлять при помощи тега [url=]...[/url].
Исправлено
--DoctorRover
« Последнее редактирование: 21 Май 2018, 02:24:03 от DoctorRover »

 

Страница сгенерирована за 0.17 секунд. Запросов: 24.