Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Система зависает при попытке сменить расположение мониторов  (Прочитано 618 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ListOFF

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Добрый вечер.

Поставил Ubuntu 18.04.1 LTS. Подключено два монитора. Зашел в настройки
Пуск (по аналогии с виндой, как правильно в убунте назвать, не знаю) => Параметры => Устройства => Настройка экранов.

Успешно сменил главный монитор. Но курсор мышки не переходит слева направо в правый монитор, а "застревает" в левом. Я понял, что нужно поменять там же в настройках местами расположение мониторов. После смены мониторов и клика на "Применить" оба монитора гаснут и ничего не происходит. В итоге приходилось перезагружать систему аварийно через reset.

Не знаю, в правильную ли я сторону начал думать, но решил, что нужно поставить драйвер на видеокарту. Нашел этот мануал. Но споткнулся уже на этом

sudo apt-get install nvidia-304 nvidia-settings
Написано, что 304 - это номер версии nvidea. Как узнать номер версии я не понял. Команда

lspci -knn | egrep 'VGA|3D' -A2дает
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] [10de:1380] (rev a2)
Subsystem: ASUSTeK Computer Inc. GM107 [GeForce GTX 750 Ti] [1043:84be]
Kernel driver in use: nouveau

Что из этого номер версии я не понял.

Просьба подсказать, как можно решить проблему с мониторами и стоит ли дальше копать в сторону драйвера. А если стоит, то что подразумевается под версией видеокарты в данном случае.

ТС не появлялся на Форуме более полугода по состоянию на 22/07/2019 (последняя явка: 07/08/2018). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 22 Июль 2019, 15:20:56 от zg_nico »

alang

  • Гость
sudo apt install nvidia-384 nvidia-settings

В твоем случае.

что подразумевается под версией видеокарты в данном случае.

Ничего. Имеется в виду не "версия видеокарты", а версия драйвера. Тебе нужна самая последняя из доступных, а не самая древняя. Интересно, в винде ты так же тупил, когда искал драйвера?

Оффлайн ListOFF

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
alang, спасибо.

Команды как в мануале отработали (см. https://help.ubuntu.ru/wiki/%D0%B4%D1%80%D0%B0%D0%B9%D0%B2%D0%B5%D1%80_%D0%B2%D0%B8%D0%B4%D0%B5%D0%BE%D0%BA%D0%B0%D1%80%D1%82_nvidia, Установка драйвера из официального репозитория Ubuntu (рекомендуется)).

Но ситуация не улучшилась. После перезагрузки сильно снизилось разрешение на неосновном мониторе, на основном все ОК. Зашел в настройки. Для неосновного монитора в списке доступных разрешений нет нормального, все низкие. Попробовал поменять местами мониторы - сработало. Но расположение было выставлено немного не то. Зашел подкорректировать и после сохранения настроек произошло все как раньше - оба монитора светятся одним черным цветом, только курсор от мыши виден при передвижении.

Еще смутило, что после установки драйверов и перезагрузки

lspci -k| grep -EA2 'VGA|3D'
выдает то же, что и до установки

01:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2)
Subsystem: ASUSTeK Computer Inc. GM107 [GeForce GTX 750 Ti]
Kernel driver in use: nouveau

Я ожидал, что в последней строчке будет указано "Kernel driver in use: nvidia"

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
Цитировать
nouveau
это не было установка драйвер,

так, покажет информация.
ubuntu-drivers devices
Нельзя друзья, дулу - AnrDaemon видите?
~.o

alang

  • Гость
Я ожидал, что в последней строчке будет указано "Kernel driver in use: nvidia"

Так и должно было быть. Видно, что-то пошло не так. Попробуй через "Программы и обновления" - > "Дополнительные драйверы".

Оффлайн ListOFF

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Попробуй через "Программы и обновления" - > "Дополнительные драйверы".


Зашел туда. Там было три варианта (см.скрин). При выборе nvidia driver 390 и перезагрузке ничего не изменилось.



При этом в верхнем правом углу панели с часами появилось предупреждение "Ошибка BrokenCount > 0", "Установленные пакеты имеют неразрешенные зависимости".

sudo apt-get install -fДает
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  lib32gcc1 libc6-i386
Для их удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  libnvidia-gl-390 libnvidia-gl-390:i386
НОВЫЕ пакеты, которые будут установлены:
  libnvidia-gl-390 libnvidia-gl-390:i386
Обновлено 0 пакетов, установлено 2 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Установлено или удалено не до конца 3 пакетов.
Необходимо скачать 0 B/29,1 MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 147 MB.
Хотите продолжить? [Д/н] Y
(Чтение базы данных … на данный момент установлено 168356 файлов и каталогов.)
Подготовка к распаковке …/libnvidia-gl-390_390.48-0ubuntu3_i386.deb …
отклонение /usr/lib/i386-linux-gnu/libGL.so.1 в /usr/lib/i386-linux-gnu/libGL.so.1.distrib из-за nvidia-340
dpkg-divert: ошибка: несовпадение с пакетом
  при удалении «отклонение /usr/lib/i386-linux-gnu/libGL.so.1 из-за libnvidia-gl-390»
  найдено «отклонение /usr/lib/i386-linux-gnu/libGL.so.1 в /usr/lib/i386-linux-gnu/libGL.so.1.distrib из-за nvidia-340»
dpkg: ошибка при обработке архива /var/cache/apt/archives/libnvidia-gl-390_390.48-0ubuntu3_i386.deb (--unpack):
 new libnvidia-gl-390:i386 package pre-installation script subprocess returned error exit status 2
Подготовка к распаковке …/libnvidia-gl-390_390.48-0ubuntu3_amd64.deb …
отклонение /usr/lib/x86_64-linux-gnu/libGL.so.1 в /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib из-за nvidia-340
dpkg-divert: ошибка: несовпадение с пакетом
  при удалении «отклонение /usr/lib/x86_64-linux-gnu/libGL.so.1 из-за libnvidia-gl-390»
  найдено «отклонение /usr/lib/x86_64-linux-gnu/libGL.so.1 в /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib из-за nvidia-340»
dpkg: ошибка при обработке архива /var/cache/apt/archives/libnvidia-gl-390_390.48-0ubuntu3_amd64.deb (--unpack):
 new libnvidia-gl-390:amd64 package pre-installation script subprocess returned error exit status 2
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libnvidia-gl-390_390.48-0ubuntu3_i386.deb
 /var/cache/apt/archives/libnvidia-gl-390_390.48-0ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

При попытке выбрать и применить изменения для варианта nvidia-340 чекбокс сбрасывается к первоначальному варианту, применить не получается. При этом в системе выскакивает ошибка "package nvidia-340 (not installed) failed to install/upgrade: trying to overwrite '/lib/udev/rules.d/71-nvidia.rules', which is also in package nvidia-kernel-common-390 390.48-0ubuntu3"

С вариантом nouveau тоже проблема с мониторами остается.

alang

  • Гость
ListOFF, nvidia-340 - это legacy-драйвер для совсем старых видеокарт.

Удали предыдущую установку

sudo apt purge nvidia-*

После этого устанавливай по-новой последний доступный драйвер, а не что попало по принципу "а вдруг получится". Почему ты не читаешь, что тебе пишут?

Оффлайн ListOFF

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
sudo apt purge nvidia-*

Выполнил. Результат:

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Заметьте, выбирается «nvidia-325-updates» для glob «nvidia-*»
[и т.д, много строк про другие множество других пакетов]
Пакет «nvidia-profiler» не установлен, поэтому не может быть удалён
Пакет «nvidia-visual-profiler» не установлен, поэтому не может быть удалён
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 libnvidia-ifr1-390 : Зависит: libnvidia-gl-390 но он не будет установлен
 libnvidia-ifr1-390:i386 : Зависит: libnvidia-gl-390:i386 но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение).

Как видно, проблемы в конце возникли с nvidia. Попробовал предложенное apt --fix-broken install:

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  lib32gcc1 libc6-i386
Для их удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  libnvidia-gl-390 libnvidia-gl-390:i386
НОВЫЕ пакеты, которые будут установлены:
  libnvidia-gl-390 libnvidia-gl-390:i386
Обновлено 0 пакетов, установлено 2 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Установлено или удалено не до конца 3 пакетов.
Необходимо скачать 0 B/29,1 MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 147 MB.
Хотите продолжить? [Д/н] Y
(Чтение базы данных … на данный момент установлено 168356 файлов и каталогов.)
Подготовка к распаковке …/libnvidia-gl-390_390.48-0ubuntu3_i386.deb …
отклонение /usr/lib/i386-linux-gnu/libGL.so.1 в /usr/lib/i386-linux-gnu/libGL.so.1.distrib из-за nvidia-340
dpkg-divert: ошибка: несовпадение с пакетом
  при удалении «отклонение /usr/lib/i386-linux-gnu/libGL.so.1 из-за libnvidia-gl-390»
  найдено «отклонение /usr/lib/i386-linux-gnu/libGL.so.1 в /usr/lib/i386-linux-gnu/libGL.so.1.distrib из-за nvidia-340»
dpkg: ошибка при обработке архива /var/cache/apt/archives/libnvidia-gl-390_390.48-0ubuntu3_i386.deb (--unpack):
 new libnvidia-gl-390:i386 package pre-installation script subprocess returned error exit status 2
Подготовка к распаковке …/libnvidia-gl-390_390.48-0ubuntu3_amd64.deb …
отклонение /usr/lib/x86_64-linux-gnu/libGL.so.1 в /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib из-за nvidia-340
dpkg-divert: ошибка: несовпадение с пакетом
  при удалении «отклонение /usr/lib/x86_64-linux-gnu/libGL.so.1 из-за libnvidia-gl-390»
  найдено «отклонение /usr/lib/x86_64-linux-gnu/libGL.so.1 в /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib из-за nvidia-340»
dpkg: ошибка при обработке архива /var/cache/apt/archives/libnvidia-gl-390_390.48-0ubuntu3_amd64.deb (--unpack):
 new libnvidia-gl-390:amd64 package pre-installation script subprocess returned error exit status 2
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libnvidia-gl-390_390.48-0ubuntu3_i386.deb
 /var/cache/apt/archives/libnvidia-gl-390_390.48-0ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Нагуглил, что в таких случаях можно сделать

sudo apt-get cleansudo apt-get autoremove
Результат:

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 libnvidia-ifr1-390 : Зависит: libnvidia-gl-390 но он не установлен
 libnvidia-ifr1-390:i386 : Зависит: libnvidia-gl-390:i386 но он не установлен
 nvidia-driver-390 : Зависит: libnvidia-gl-390 (= 390.48-0ubuntu3) но он не установлен
                     Рекомендует: libnvidia-gl-390:i386 (= 390.48-0ubuntu3)
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение

Затем попробовал

sudo apt-get update
Результат

Игн:1 http://ppa.launchpad.net/nm-l2tp/network-manager-l2tp/ubuntu bionic InRelease
Игн:2 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                                                                     
Пол:3 http://dl.google.com/linux/chrome/deb stable Release [1 189 B]                                                                                                                                       
Сущ:4 http://ru.archive.ubuntu.com/ubuntu bionic InRelease                                                                                                                                                 
Пол:5 http://ru.archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]                                                                                                                               
Пол:6 http://dl.google.com/linux/chrome/deb stable Release.gpg [819 B]                                                                                                                                     
Ошк:7 http://ppa.launchpad.net/nm-l2tp/network-manager-l2tp/ubuntu bionic Release                                                                                                                         
  404  Not Found [IP: 91.189.95.83 80]
Пол:8 http://ru.archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]                                                                                                                             
Пол:9 http://security.ubuntu.com/ubuntu bionic-security InRelease [83,2 kB]                                                                                         
Пол:10 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages [1 374 B]                                                 
Пол:11 http://ru.archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [138 kB]                                                               
Пол:12 http://ru.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 48x48 Icons [31,4 kB]                                                                     
Пол:13 http://ru.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 64x64 Icons [53,7 kB]                                                                 
Пол:14 http://ru.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [149 kB]                                                   
Пол:15 http://ru.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 48x48 Icons [152 kB]                                                       
Пол:16 http://ru.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 64x64 Icons [273 kB]                                                                           
Пол:17 http://ru.archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2 464 B]                                                                     
Пол:18 http://ru.archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [5 100 B]                                                       
Пол:19 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [204 B]                                                                 
Пол:20 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [5 796 B]
Пол:21 https://packagecloud.io/slacktechnologies/slack/debian jessie InRelease [23,5 kB]                 
Игн:22 https://packagecloud.io/slacktechnologies/slack/debian jessie/main i386 Packages
Пол:23 https://packagecloud.io/slacktechnologies/slack/debian jessie/main amd64 Packages [8 983 B]
Пол:22 https://packagecloud.io/slacktechnologies/slack/debian jessie/main i386 Packages [4 991 B]                                                                                                         
Чтение списков пакетов… Готово                                                                                                                                                                             
E: Репозиторий «http://ppa.launchpad.net/nm-l2tp/network-manager-l2tp/ubuntu bionic Release» не содержит файла Release.
N: Обновление из этого репозитория нельзя выполнить безопасным способом, и поэтому по умолчанию он отключён.
N: Смотрите справочную страницу apt-secure(8) о создании репозитория и настройке пользователя

Затем попробовал

sudo apt-get -f install
Результат

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  lib32gcc1 libc6-i386
Для их удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  libnvidia-gl-390 libnvidia-gl-390:i386
НОВЫЕ пакеты, которые будут установлены:
  libnvidia-gl-390 libnvidia-gl-390:i386
Обновлено 0 пакетов, установлено 2 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Установлено или удалено не до конца 3 пакетов.
Необходимо скачать 29,1 MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 147 MB.
Хотите продолжить? [Д/н] Y
Пол:1 http://ru.archive.ubuntu.com/ubuntu bionic/restricted i386 libnvidia-gl-390 i386 390.48-0ubuntu3 [14,9 MB]
Пол:2 http://ru.archive.ubuntu.com/ubuntu bionic/restricted amd64 libnvidia-gl-390 amd64 390.48-0ubuntu3 [14,3 MB]                                                                                         
Получено 29,1 MB за 13с (2 323 kB/s)                                                                                                                                                                       
(Чтение базы данных … на данный момент установлено 168356 файлов и каталогов.)
Подготовка к распаковке …/libnvidia-gl-390_390.48-0ubuntu3_i386.deb …
отклонение /usr/lib/i386-linux-gnu/libGL.so.1 в /usr/lib/i386-linux-gnu/libGL.so.1.distrib из-за nvidia-340
dpkg-divert: ошибка: несовпадение с пакетом
  при удалении «отклонение /usr/lib/i386-linux-gnu/libGL.so.1 из-за libnvidia-gl-390»
  найдено «отклонение /usr/lib/i386-linux-gnu/libGL.so.1 в /usr/lib/i386-linux-gnu/libGL.so.1.distrib из-за nvidia-340»
dpkg: ошибка при обработке архива /var/cache/apt/archives/libnvidia-gl-390_390.48-0ubuntu3_i386.deb (--unpack):
 new libnvidia-gl-390:i386 package pre-installation script subprocess returned error exit status 2
Подготовка к распаковке …/libnvidia-gl-390_390.48-0ubuntu3_amd64.deb …
отклонение /usr/lib/x86_64-linux-gnu/libGL.so.1 в /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib из-за nvidia-340
dpkg-divert: ошибка: несовпадение с пакетом
  при удалении «отклонение /usr/lib/x86_64-linux-gnu/libGL.so.1 из-за libnvidia-gl-390»
  найдено «отклонение /usr/lib/x86_64-linux-gnu/libGL.so.1 в /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib из-за nvidia-340»
dpkg: ошибка при обработке архива /var/cache/apt/archives/libnvidia-gl-390_390.48-0ubuntu3_amd64.deb (--unpack):
 new libnvidia-gl-390:amd64 package pre-installation script subprocess returned error exit status 2
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libnvidia-gl-390_390.48-0ubuntu3_i386.deb
 /var/cache/apt/archives/libnvidia-gl-390_390.48-0ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Суд по всему, удалить старый драйвер так и не получилось.

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1936
    • Просмотр профиля
Зачем реп для дебиана добавили?
А потом -- поломанные зависимости
« Последнее редактирование: 04 Август 2018, 10:30:53 от ARTGALGANO »

Оффлайн ListOFF

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
ARTGALGANO, тут скорее не зачем, а почему. Потому что я пока в нуб в линуксе/убунте. Пока пытаюсь обеспечить  минимально необходимую среду для работы. Как от дебиан избавиться?

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3276
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Как от дебиан избавиться?
Код: Bash
  1. cd /etc/apt/
  2. grep -iIR debian
  3.  
Вывод сюда
Потому что я пока в нуб в линуксе/убунте
Если вы "нуб", то для чего делаете вещи, в которых вы не ничего не понимаете?

Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн ListOFF

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
EvangelionDeath

Вывод сюда

sources.list.d/slack.list:deb https://packagecloud.io/slacktechnologies/slack/debian/ jessie main
apt.conf.d/20dbus:APT::Update::Post-Invoke-Success { "[ ! -f /var/run/dbus/system_bus_socket ] || /usr/bin/dbus-send --system --dest=org.debian.apt --type=signal /org/debian/apt org.debian.apt.CacheChanged || true"; };

Если вы "нуб", то для чего делаете вещи, в которых вы не ничего не понимаете?

С винды пришлось на ходу пересаживаться на линукс. Обусловлено особенностями работы. Раньше мое знакомство с линуксом ограничивалось простейшими манипуляциями в консоли на сервере в уже нормально настроенной системе. Сейчас цель - минимально обеспечить себя возможностью работать, а потом уже буду основательно изучать.

 

Страница сгенерирована за 0.276 секунд. Запросов: 22.