Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: проблема с заголовочниками ядра  (Прочитано 611 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн rampagety

  • Автор темы
  • Новичок
  • *
  • Сообщений: 29
    • Просмотр профиля
Re: проблема с заголовочниками ядра
« Ответ #15 : 06 Январь 2019, 20:09:08 »
sudo apt install linux-headers-4.15.0-43-generic
Reading package lists... Done
Building dependency tree       
Reading state information... Done
linux-headers-4.15.0-43-generic is already the newest version (4.15.0-43.46).
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.
« Последнее редактирование: 07 Январь 2019, 11:53:06 от Morisson »

Оффлайн Heider

  • Старожил
  • *
  • Сообщений: 1096
    • Просмотр профиля
Re: проблема с заголовочниками ядра
« Ответ #16 : 06 Январь 2019, 20:18:37 »
Так у Вас уже стоят нужные заголовки. Покажите, с каким ядром у Вас система сейчас загружена?
uname -a

Оффлайн rampagety

  • Автор темы
  • Новичок
  • *
  • Сообщений: 29
    • Просмотр профиля
Re: проблема с заголовочниками ядра
« Ответ #17 : 06 Январь 2019, 20:22:55 »
uname -a
Linux roman-X502CA 4.13.0-45-generic #50~16.04.1-Ubuntu SMP Wed May 30 11:18:27 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Оффлайн Heider

  • Старожил
  • *
  • Сообщений: 1096
    • Просмотр профиля
Re: проблема с заголовочниками ядра
« Ответ #18 : 06 Январь 2019, 20:26:06 »
У Вас почему-то система загружена со старым ядром, для которого нет заголовков. Поэтому, вылазит ошибка. Попробуйте обновить конфиг груба:
sudo update-grubи дайте выхлоп под спойлер, будем разбираться.

Пользователь добавил сообщение 06 Январь 2019, 20:52:46:
В общем, Вам нужно загрузиться с ядром 4.15.0-43-generic, и уже с ним ставить драйвер. Ну и с загрузчиком разобраться.
« Последнее редактирование: 06 Январь 2019, 20:52:46 от Heider »

Оффлайн rampagety

  • Автор темы
  • Новичок
  • *
  • Сообщений: 29
    • Просмотр профиля
Re: проблема с заголовочниками ядра
« Ответ #19 : 06 Январь 2019, 20:55:00 »
У Вас почему-то система загружена со старым ядром, для которого нет заголовков. Поэтому, вылазит ошибка. Попробуйте обновить конфиг груба:
sudo update-grubи дайте выхлоп под спойлер, будем разбираться.

Пользователь добавил сообщение 06 Январь 2019, 20:52:46:
В общем, Вам нужно загрузиться с ядром 4.15.0-43-generic, и уже с ним ставить драйвер. Ну и с загрузчиком разобраться.
обновил граб, ничего не поменялось
хорошо, я понял, спасибо
как писать под спойлер я не знаю.

update-grub:
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 06 Январь 2019, 21:51:35 от rampagety »

Оффлайн Heider

  • Старожил
  • *
  • Сообщений: 1096
    • Просмотр профиля
Re: проблема с заголовочниками ядра
« Ответ #20 : 06 Январь 2019, 21:06:05 »
как писать под спойлер я не знаю
Выделяете текст, который хотите скрыть, потом нажимаете значок радиации (круг с черными и желтыми секторами) над окном ввода текста.

Оффлайн rampagety

  • Автор темы
  • Новичок
  • *
  • Сообщений: 29
    • Просмотр профиля
Re: проблема с заголовочниками ядра
« Ответ #21 : 06 Январь 2019, 22:12:27 »
при загрузке системы есть выбор только 4.13 ядер, если что
ну и они не работают все

Оффлайн Dzhoser

  • Активист
  • *
  • Сообщений: 833
    • Просмотр профиля
Re: проблема с заголовочниками ядра
« Ответ #22 : 07 Январь 2019, 01:07:54 »
По информации из спойлера ядра есть попробуйте для вызова сеню при загрузке нажимать ESC

Оффлайн zg_nico

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1363
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: проблема с заголовочниками ядра
« Ответ #23 : 07 Январь 2019, 09:13:04 »
при загрузке системы есть выбор только 4.13 ядер, если что ... ну и они не работают все
Found Ubuntu 16.04.3 LTS (16.04) on /dev/sda5
Description:   Ubuntu 18.04.1 LTS
Сдается мне, Вы grub не от той системы обновлять пытаетесь. Грузитесь Вы с Grub от 16.04, а обновляете конфиг груба в 18.04, судя по всему. В BIOS приоритеты загрузки проверьте. В какой системе работаете - загрузчик той на первое место и определяйте. Если у Вас там UEFI, то Вы увидите две строчки "ubuntu". Та, которая сейчас, предположительно, - от 16.04. Другая - от 18.04. Попробуйте переставить местами и загрузиться. Вполне вероятно, что сможете нормально стартовать с интересующим Вас ядром.
Либо в 16.04 загрузиться, там выполнить sudo update-grub, и заново пытаться запускать 18.04 с интересующим Вас для нее ядром через "Дополнительные параметры..." для неё.
« Последнее редактирование: 07 Январь 2019, 09:15:13 от zg_nico »
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], Ubuntu 18.04 64x [KDE, Budgie].

Оффлайн rampagety

  • Автор темы
  • Новичок
  • *
  • Сообщений: 29
    • Просмотр профиля
Re: проблема с заголовочниками ядра
« Ответ #24 : 11 Январь 2019, 13:35:31 »
По информации из спойлера ядра есть попробуйте для вызова сеню при загрузке нажимать ESC
ничего не происходит (

Пользователь добавил сообщение 11 Январь 2019, 13:38:06:
при загрузке системы есть выбор только 4.13 ядер, если что ... ну и они не работают все
Found Ubuntu 16.04.3 LTS (16.04) on /dev/sda5
Description:   Ubuntu 18.04.1 LTS
Сдается мне, Вы grub не от той системы обновлять пытаетесь. Грузитесь Вы с Grub от 16.04, а обновляете конфиг груба в 18.04, судя по всему. В BIOS приоритеты загрузки проверьте. В какой системе работаете - загрузчик той на первое место и определяйте. Если у Вас там UEFI, то Вы увидите две строчки "ubuntu". Та, которая сейчас, предположительно, - от 16.04. Другая - от 18.04. Попробуйте переставить местами и загрузиться. Вполне вероятно, что сможете нормально стартовать с интересующим Вас ядром.
Либо в 16.04 загрузиться, там выполнить sudo update-grub, и заново пытаться запускать 18.04 с интересующим Вас для нее ядром через "Дополнительные параметры..." для неё.
да кстати, при загрузке системы граб пишет что у меня 16.04, а я ее и выбираю, но загружается то все равно 18.04, в биос приоритетов граб я не нашёл  ???

UPD: все получилось, спасибо, у меня просто была вторая система Ubuntu, я их поменял местами в биосе, и теперь при выборе появились нужные версии !  :D

ВСЕМ СПАСИБО!!!
« Последнее редактирование: 12 Январь 2019, 16:45:59 от rampagety »

 

Страница сгенерирована за 0.059 секунд. Запросов: 24.