Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Драйвера nvidia не работают до сих пор  (Прочитано 4230 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Wink007

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Re: Драйвера nvidia не работают до сих пор
« Ответ #75 : 26 Январь 2019, 21:55:00 »
Даже с параметром nomodeset?

Просто у меня тоже видеокарта Nvidia, и тоже не заработала в Ubuntu 18.04, хотя на сайте nvidia заявлено что должна работать.
Откатился на Ubuntu 16.04, теперь работает.
параметр nomodeset подключает некий llvmpipe (LLVM 6.0, 256 bits) драйвер. Просто у меня пару месяцев все работало без нареканий, еще тогда вроде был 396 драйвер, а потом начали появляться артефакты на экране и все, с тех пор никак

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3511
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Драйвера nvidia не работают до сих пор
« Ответ #76 : 26 Январь 2019, 21:59:06 »
а потом начали появляться артефакты на экране и все, с тех пор никак
А не сгорела ли у Вас сама видеокарта?! Работоспособность под какой-нибудь иной операционной системой (той же windows) есть вариант проверить?
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн Wink007

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Re: Драйвера nvidia не работают до сих пор
« Ответ #77 : 26 Январь 2019, 22:00:27 »
а потом начали появляться артефакты на экране и все, с тех пор никак
А не сгорела ли у Вас сама видеокарта?! Работоспособность под какой-нибудь иной операционной системой (той же windows) есть вариант проверить?
не думаю, биос показывает наличие 2-х видеокарт

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3511
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Драйвера nvidia не работают до сих пор
« Ответ #78 : 26 Январь 2019, 22:06:20 »
Wink007, меня просто смутила фраза про артефакты на экране. На моем самом первом ПК (где нет дискректной графики как таковой) стояла N-Vidia GeForce IV. В один прекрасный день мелкие артефакты, после - вообще какой-то фаршмак вместо изображения (курсором по экрану можно было как в paint'е рисовать). Переустановка драйвера, переустановка самой системы, миграция с win98 на winXP результата не дали никакого - изображение по-прежнему было фаршмаком. Родители сдали ПК человеку, который разбирается. Человек заменил видеокарту по гарантии - работает машина до сих пор. И да, BIOS ее обнаруживать не переставал, равно как и диспетчер устройств в винде ее видел, и даже драйвер вроде как устанавливался.
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн Wink007

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Re: Драйвера nvidia не работают до сих пор
« Ответ #79 : 26 Январь 2019, 22:09:09 »
Wink007, меня просто смутила фраза про артефакты на экране. На моем самом первом ПК (где нет дискректной графики как таковой) стояла N-Vidia GeForce IV. В один прекрасный день мелкие артефакты, после - вообще какой-то фаршмак вместо изображения (курсором по экрану можно было как в paint'е рисовать). Переустановка драйвера, переустановка самой системы, миграция с win98 на winXP результата не дали никакого - изображение по-прежнему было фаршмаком. Родители сдали ПК человеку, который разбирается. Человек заменил видеокарту по гарантии - работает машина до сих пор. И да, BIOS ее обнаруживать не переставал, равно как и диспетчер устройств в винде ее видел, и даже драйвер вроде как устанавливался.
странно конечно, но все может быть, ради интереса поставлю винду, что не очень меня радует, и уже попробую проверить там

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3511
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Драйвера nvidia не работают до сих пор
« Ответ #80 : 26 Январь 2019, 22:12:41 »
за live режим не скажу, не пробовал, но до установки работал
Это, кстати, как?! :o
По дефолту в версии образа Ubuntu 18.04.1 идет ядро 4.15.0-29-generic. У Вас сейчас установлено 4.15.0-43-generic. Есть пусть и малая, но вероятность того, что Ваша аппаратная конфигурация в чем-то конфликтует с текущей версией ядра. В сущности, дабы эту вероятность отмести, надо попробовать со стоковым ядром загрузиться. Для начала уберем из списка репозиториев добавленный нами ранее PPA производителя:sudo add-apt-repository --remove ppa:graphics-drivers/ppa -yПерезагружаем машину. На этапе загрузки, когда увидите меню GRUB2 (выглядит оно примерно так как на картинке ниже):

следует выбрать "Дополнительные параметры для Ubuntu". В появившемся перечне выбирайте "Ubuntu, с Linux 4.15.0-29-generic" стрелочками на клавиатуре, далее жмите Enter:

Фактически, Вы загрузите систему с ядром стоковой версии. В этой же версии можно попробовать поставить драйвер из PPA самой системы, как мы это делали ранее: подключаем интернет, выполняем
sudo apt update && sudo ubuntu-drivers autoinstallПосле установки - перезагрузка. При загрузке снова грузимся с версией ядра 4.15.0-29-generic и проверяем работу видеодрайвера там. Если все с тем ядром работает нормально - отпишитесь, будем удалять прочие ядра.
Хотя конечно с учетом вот этого факта
даже поставив 16.04, все равно драйвер почему то не подхватывается
я не думаю, что мы что-то получим путнее с данного эксперимента...  :(
« Последнее редактирование: 26 Январь 2019, 22:15:48 от zg_nico »
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн Wink007

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Re: Драйвера nvidia не работают до сих пор
« Ответ #81 : 26 Январь 2019, 22:15:23 »
После установки - перезагрузка. При загрузке снова грузимся с версией ядра 4.15.0-29-generic и проверяем работу видеодрайвера там. Если все с тем ядром работает нормально - отпишитесь, будем удалять прочие ядра.
буду пробовать сейчас, спасибо

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3511
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Драйвера nvidia не работают до сих пор
« Ответ #82 : 26 Январь 2019, 23:08:27 »
Wink007, и еще: убедитесь в наличии двух пакетов в системе:sudo apt install intel-microcode linux-firmwareскорее всего, они уже стоят оба, но на всякий случай... Чтобы linux-firmware нормально применился надо перезагрузиться.
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн Wink007

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Re: Драйвера nvidia не работают до сих пор
« Ответ #83 : 27 Январь 2019, 14:57:19 »
вобщем, пока nvidia никак не хочет принимать, сегодня возможности поставить другую операционку нет, дабы проверить работает видюха или нет, завтра поставлю, отпишусь

Оффлайн Wink007

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Re: Драйвера nvidia не работают до сих пор
« Ответ #84 : 29 Январь 2019, 12:52:18 »
Сегодня пришло обновление, вобщем обновился,сейчас после ввода логина\пароля уже черный экран, пишу выводы
inxi -F
System:    Host: wink130390-GL553VE Kernel: 4.15.0-44-generic x86_64 bits: 64
           Desktop: Gnome 3.28.3 Distro: Ubuntu 18.04.1 LTS
Machine:   Device: laptop System: ASUSTeK product: GL553VE v: 1.0 serial: N/A
           Mobo: ASUSTeK model: GL553VE v: 1.0 serial: N/A
           UEFI: American Megatrends v: GL553VE.306 date: 01/02/2018
Battery    BAT0: charge: 41.6 Wh 98.2% condition: 42.4/48.2 Wh (88%)
CPU:       Quad core Intel Core i7-7700HQ (-MT-MCP-) cache: 6144 KB
           clock speeds: max: 3800 MHz 1: 1886 MHz 2: 1770 MHz 3: 1398 MHz
           4: 1547 MHz 5: 1661 MHz 6: 1539 MHz 7: 1667 MHz 8: 1721 MHz
Graphics:  Card-1: Intel Device 591b
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile]
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
           version: 4.5 Mesa 19.0.0-devel (git-932ed9c 2019-01-29 bionic-oibaf-ppa)
Audio:     Card Intel CM238 HD Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-44-generic
Network:   Card-1: Intel Wireless 7265 driver: iwlwifi
           IF: wlp2s0 state: up mac: 00:e1:8c:7e:7f:ac
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169
           IF: enp3s0 state: down mac: 18:31:bf:77:c8:f3
Drives:    HDD Total Size: 1000.2GB (3.4% used)
           ID-1: /dev/sda model: ST1000LM035 size: 1000.2GB
Partition: ID-1: / size: 915G used: 31G (4%) fs: ext4 dev: /dev/dm-0
           ID-2: swap-1 size: 1.02GB used: 0.00GB (0%)
           fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 44.5C mobo: N/A
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 289 Uptime: 1 min Memory: 781.9/7857.6MB
           Client: Shell (bash) inxi: 2.3.56

prime-select query
intel - тут сменил с nvidia, дабы получилось зайти в систему
modinfo nvidia | egrep "(filename|version)"
filename:       /lib/modules/4.15.0-44-generic/updates/dkms/nvidia.ko
version:        415.27
srcversion:     6095291DD12C4CC9AA0F9A0
cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.15.0-44-generic root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=1
grep -H nouveau /etc/modprobe.d/*
пусто
Пользователь добавил сообщение 29 Январь 2019, 18:53:43:
Есть какие то предложения?
« Последнее редактирование: 29 Январь 2019, 18:53:43 от Wink007 »

Оффлайн Wink007

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Re: Драйвера nvidia не работают до сих пор
« Ответ #85 : 30 Январь 2019, 20:01:22 »
Ребят, есть что то по теме?

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3511
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Драйвера nvidia не работают до сих пор
« Ответ #86 : 31 Январь 2019, 00:39:51 »
Wink007, у вас какая-то проблемная обвязка (может acpi особенный, может еще какие конфликты), - наверное имеет смысл поискать иное ядро, на котором все должным образом заработает. Ядра можно менять при помощи ukuu. Она с графическим интерфейсом - сложного в ней нет. Но обнадежить особо не чем, т.к. никакой гарантии ни что сейчас заработает, ни что в дальнейшем починится. Можно попробовать заблеклистить драйвер nouveau прямо в параметрах ядра (грузиться с параметром ядра nouveau.blacklist=1 modprobe.blacklist=nouveau при prime-select query=nvidia и установленном драйвере nvidia, естественно).
Я не могу понять, почему блеклист не отрабатывает, и почему в блеклист при установке nouveau не заносится... Это как минимум странно.
Попробуйте заново создать тот файл, после чего выполнить sudo update-initramfs -u/может ей этого не хватало?!/
Странно, но из выводов драйвер успешно активируется лишь тогда, когда чип n-vidia по сути спит.
Цитировать
drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
В настройках bios машины переключалки работы графики нет (DISCRETTE / MSHYBRID / Integer / ...)? Перевод в режим DISCRETTE позволил бы обойти проблему...
« Последнее редактирование: 17 Апрель 2019, 15:00:05 от zg_nico »
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн Wink007

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Re: Драйвера nvidia не работают до сих пор
« Ответ #87 : 31 Январь 2019, 09:49:31 »
Wink007, у вас какая-то проблемная обвязка (может acpi особенный, может еще какие конфликты), - наверное имеет смысл поискать иное ядро, на котором все должным образом заработает. Ядра можно менять при помощи ukuu. Она с графическим интерфейсом - сложного в ней нет. Но обнадежить особо не чем, т.к. никакой гарантии ни что сейчас заработает, ни что в дальнейшем починится. Можно попробовать заблеклистить драйвер nouveau прямо в параметрах ядра (грузиться с параметром ядра nouveau.blacklist=1 при prime-select query=nvidia и установленном драйвере nvidia, естественно).
Я не могу понять, почему блеклист не отрабатывает, и почему в блеклист при установке nouveau не заносится... Это как минимум странно.
Попробуйте заново создать тот файл, после чего выполнить sudo update-initramfs -u/может ей этого не хватало?!/
Странно, но из выводов драйвер успешно активируется лишь тогда, когда чип n-vidia по сути спит.
Цитировать
drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
В настройках bios машины переключалки работы графики нет (DISCRETTE / MSHYBRID / Integer / ...)? Перевод в режим DISCRETTE позволил бы обойти проблему...
Изменять версию ядра, это же как пальцем в небо, в ukuu там же много версий. Насчёт Биоса, то там такого нет, к сожалению

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3511
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Драйвера nvidia не работают до сих пор
« Ответ #88 : 31 Январь 2019, 13:45:46 »
это же как пальцем в небо
К сожалению да. Потому и предлагаю альтернативные варианты:
Попробуйте заново создать тот файл, после чего выполнить
Для этого (выполнять призываю именно в описанном ниже порядке - так мы попробуем с текущим установленным драйвером 415.27 на ядре 4.15.0-44-generic все 4 известных мне на момент варианта как можно заблеклистить этот навязчивый nouveau):
1. Открываем терминал. Исходя из того, что сейчас у Вас видеокарта n-vidia отключена на уровне prime-select, следует перво-наперво ее включить:sudo prime-select nvidiaПерезагружаться не спешим. В том же терминале вводим sudo nano /etc/modprobe.d/nvidia-graphics-drivers.confВ открывшемся (уже Вам знакомом) окне редактора nano, запущенного с правами суперпользователя вводим такой текст (можно просто на форуме выделить все это мышкой, после чего щелкнуть средней кнопкой мышки (колесиком) в окне редактора nano:
Цитировать
blacklist nouveau
blacklist lbm-nouveau
alias nouveau off
alias lbm-nouveau off
Как ввели, вводим жмем Ctrl+X, для подтверждения сохранения изменений жмем Y, далее нажатием клавиши Enter подтверждаем имя сохраняемого файла /etc/modprobe.d/nvidia-graphics-drivers.conf. Файл с этого момента существует, а окно терминала вновь готово принимать команды. Вводим cat /etc/modprobe.d/nvidia-graphics-drivers.confдабы удостовериться, что все введено правильно и файл записался. В ответ будет выведен введенный Вами ранее в окно редактора nano текст. Да, мы это уже делали. Теперь то, чего мы не делали: вводим команду sudo update-initramfs -uПо логике вещей всё. Пробуем перезагружаться. Если после загрузки видим чёрный экран, то пробуем грузиться с параметром ядра nouveau.blacklist=1
2. Для загрузки с параметром ядра nouveau.blacklist=1 включаем ноутбук, доводим загрузку до экрана Grub. Помните, как вводили параметры nomodeset и single? Принцип тот же.

Выбираем строчку "Ubuntu", нажимаем клавишу "e". Открывается текстовый редактор.

Стрелочками на клавиатуре перемещаемся к параметрам quiet splash. Стираем эти два слова и вместо них категорически впечатываем nouveau.blacklist=1:

после чего нажимаем F10. Пойдет загрузка операционной системы, кроме того будет печататься лог. Если загрузится нормально - смотрим выводы команд inxi -F
prime-select query
3. Если что-то пошло не так - грузимся с параметром single, выполняем команды
cp /etc/modprobe.d/nvidia-graphics-drivers.conf /lib/modprobe.d/
update-initramfs -u
reboot
Пробуем стартовать. Если не удалось стартовать - снова пробуем описанное в п.2 (это не то же самое еще раз - мы добавили блеклист в lib, так что условия немного изменились).
В сущности, если описанное не возымело эффекта, можно попробовать удалить драйвера из репозитория производителя и провернуть все то же самое для родного системного репозитория. Мы делали это ранее по тексту, но если не понятно как - могу расписать еще раз. Если и с тем и с другим драйвером на этом ядре не получится - то остается лишь, как Вы справедливо заметили, "пальцем в небо" брать новые ядра в надежде, что с одним из них либо драйвер из репозитория системы, либо драйвер из репозитория производителя заработает. Уверяю Вас, знал бы метод проще - непеременно бы рассказал. На мой взгляд, этот способ - единственный.
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

 

Страница сгенерирована за 0.204 секунд. Запросов: 24.