Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: [PHP 7] Создание демона для слушания заданого порта и с поддержкой SSL/TLS  (Прочитано 1769 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Rodman

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
1. Первоначальный конфиг взял тут - https://www.linode.com/docs/uptime/loadbalancing/how-to-use-haproxy-for-load-balancing/
2. Переделал с правками отсюда - https://www.haproxy.com/documentation/haproxy/deployment-guides/tls-infrastructure/#ssl-tls-offloading
3. Нашел параметр usesrc clientip в гугле и слепил



Пользователь добавил сообщение 15 Март 2019, 00:02:51:
По факту получается, что получается принять пакет, дешифровать и чистым переотправить на порт 3000
А вот не получается:
 - пробросить IP клиента
 - вернуть ответ на взодной порт, зашифровать и отправить клиенту

Клиент по таймауту рвет сокет соединение

Как правильно сделать возврат ответа?
« Последнее редактирование: 15 Март 2019, 00:02:51 от Rodman »

Оффлайн aSmile

  • Активист
  • *
  • Сообщений: 744
    • Просмотр профиля
А вот не получается:
 - пробросить IP клиента
 - вернуть ответ на взодной порт, зашифровать и отправить клиенту

Клиент по таймауту рвет сокет соединение

Как правильно сделать возврат ответа?

haproxy и приложение на одном хосте? Если на разных, то сервер с haproxy является маршрутизатором по-умолчанию?

Оффлайн Rodman

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
на одном

основное приложение находится на 3000 порту, но оно не умеет с SSL работать...
поэтому haproxy запущен на соседнем, чтобы входящее подклчение проходило SSL верификацию, и передавало чистый сигнал (без SSL) на 3000-й порт...

так вот дешифровать получилось, передать чистый сигнал с 3433 на 3000 - получилось, но вот ответ обратно отправить с 3000 на 3433, зашифровать в SSL отправить клиенту - НЕ ПОЛУЧАЕТСЯ...

3000-й порт видит что сигнал с локал хоста приходит... и наверно пытается туда же отправить...
в общем ответ теряется...
по всей видимости заголовки не правильно подменяются

может есть у кого то идеи, что нужно чтобы ответ все таки добрался до клиента?

« Последнее редактирование: 15 Март 2019, 15:42:16 от Rodman »

Оффлайн aSmile

  • Активист
  • *
  • Сообщений: 744
    • Просмотр профиля
Думаю, убрать usesrc clientip. Скорее всего на одном хосте передать адрес отправителя не получится. Наверное, единственный вариант - запустить haproxy с таким конфигом на маршрутизаторе по-умолчанию.

Оффлайн Rodman

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
делал отправку и на другой сервер... все равно - данные обратно не отправляются

Оффлайн aSmile

  • Активист
  • *
  • Сообщений: 744
    • Просмотр профиля
делал отправку и на другой сервер... все равно - данные обратно не отправляются
Лучше попросить помощи в разделе по сетям, или другом месте, где на haproxy специализируются.

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3287
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Как же все "запущено".
К сожалению, я не в курсе, каким Вы там способом реализуете работу сокетов, но
http://php.net/manual/ru/function.stream-socket-server.php
https://www.devdungeon.com/content/how-use-ssl-sockets-php
« Последнее редактирование: 18 Март 2019, 15:01:13 от EvangelionDeath »
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

 

Страница сгенерирована за 0.108 секунд. Запросов: 24.