Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Не обновляются определенные пакеты (mesa).  (Прочитано 2693 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн jack_solovey

  • Автор темы
  • Активист
  • *
  • Сообщений: 864
  • Mate, и никаких Unity
    • Просмотр профиля
Здравствуйте.
Не могу перевести xubuntu 16.04 на 18.04
При попытках получаю сообщние о том, что нужно сначала полностью обновить текущую версию.
при обновлении текущей версии осталось 3 пакета которые отказываются обновляться.
~$ sudo apt-get upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Расчёт обновлений… Готово
Следующие пакеты будут оставлены в неизменном виде:
  libegl1-mesa libgl1-mesa-dri libwayland-egl1-mesa
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 3 пакетов не обновлено.

Что нужно сделать чтобы эти пакеты обновились?
« Последнее редактирование: 30 Июнь 2019, 10:17:01 от jack_solovey »

Оффлайн ecc83

  • Старожил
  • *
  • Сообщений: 2115
  • Lubuntu 16.04 LTS
    • Просмотр профиля
Re: Не обновляются определенные пакеты.
« Ответ #1 : 30 Июнь 2019, 09:19:46 »
Что нужно сделать чтобы эти пакеты обновились?

Обновить их командой:

sudo apt-get dist-upgrade

Оффлайн jack_solovey

  • Автор темы
  • Активист
  • *
  • Сообщений: 864
  • Mate, и никаких Unity
    • Просмотр профиля
Re: Не обновляются определенные пакеты.
« Ответ #2 : 30 Июнь 2019, 09:42:43 »
Подобные советы уже перепробовал и install -f , и чистку autoremove и т.д. и т.п.

~$ sudo apt-get dist-upgrade
[sudo] пароль для xxxxxx:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Расчёт обновлений… Готово
Следующие пакеты будут оставлены в неизменном виде:
  libgl1-mesa-dri
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 1 пакетов не обновлено.
~$ sudo apt-get dist-upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Расчёт обновлений… Готово
Следующие пакеты будут оставлены в неизменном виде:
  libgl1-mesa-dri
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 1 пакетов не обновлено.
~$

Оффлайн ecc83

  • Старожил
  • *
  • Сообщений: 2115
  • Lubuntu 16.04 LTS
    • Просмотр профиля
Re: Не обновляются определенные пакеты.
« Ответ #3 : 30 Июнь 2019, 09:50:17 »
советы уже перепробовал

Ну я вижу, что теперь один пакет болтается, а было три.

sudo apt-get update && sudo apt-get dist-upgrade
А этот пакет не заблокирован вообще то?

Оффлайн jack_solovey

  • Автор темы
  • Активист
  • *
  • Сообщений: 864
  • Mate, и никаких Unity
    • Просмотр профиля
Re: Не обновляются определенные пакеты.
« Ответ #4 : 30 Июнь 2019, 10:07:14 »
Еще раз. Я все эти действия делал в различной последовательности.
Это dist-upgrade показывает сообщение про 1 пакет, просто upgrade показывает по прежнему 3 пакета.

Цитировать
А этот пакет не заблокирован вообще то?
Что значит заблокирован? Не сталкивался с таким.

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
выделить текст пакеты на apt-get install встав.
Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн ecc83

  • Старожил
  • *
  • Сообщений: 2115
  • Lubuntu 16.04 LTS
    • Просмотр профиля
Еще раз.

Вовсе нет необходимости демонстрировать мне своё раздражение. Мне намного проще не тратить на тебя своё время.
Где вывод терминала, после моей последней длинной команды? В системе индексы обновлены вообще?

Я все эти действия делал в различной последовательности.

И какие выводы сделал? Видимо никаких если сюда обращаешься.
Значит предоставь возможность сделать выводы тем, у кого просишь помощь.

Что значит заблокирован? Не сталкивался с таким.

Например через synaptic можешь посмотреть. Там находишь этот пакет, на него курсор и смотришь в меню:

Код: (txt) [Выделить]
Пакет -> Заблокировать версию
Покажи ещё вывод:

ls /etc/apt/preferences.d
И ещё, что пишет при:

sudo apt-get install libgl1-mesa-dri
« Последнее редактирование: 30 Июнь 2019, 10:50:21 от ecc83 »

Оффлайн jack_solovey

  • Автор темы
  • Активист
  • *
  • Сообщений: 864
  • Mate, и никаких Unity
    • Просмотр профиля
Где вывод терминала, после моей последней длинной команды?
Он такой же, как я приводил выше.
Цитировать
В системе индексы обновлены вообще?
Не понимаю о чем речь, о каких индексах?
Цитировать
Например через synaptic можешь посмотреть. Там находишь этот пакет, на него курсор и смотришь в меню:
В контекстном меню на пакете нет ничего о блокировке, в свойствах пакета тоже.
Цитировать
ls /etc/apt/preferences.d
Не выводит ничего.

Цитировать
sudo apt-get install libgl1-mesa-dri
По сути предлагает снести всю систему.
(Нажмите, чтобы показать/скрыть)

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
PPA? не было?
файл PPA удалить и обновить не?
Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн ecc83

  • Старожил
  • *
  • Сообщений: 2115
  • Lubuntu 16.04 LTS
    • Просмотр профиля
Он такой же, как я приводил выше.

Он не может быть таким же, потому что команда другая.

По сути предлагает снести всю систему.

Сломаны зависимости. Вероятно злоумышленники что то меняли в настройках пакетного менеджера твоей системы или подключали доп. репозитории.
В результате какие то пакеты были изменены без учёта официальных зависимостей. Это ещё бывает когда устанавливается фирменный видеодрайвер не из официального репозитория и он тянет с собой какие то изменённые пакеты с похожим именем.

Можно попробовать отключить "левые" репы и обновить систему.

Я вижу у тебя Минт, у них там есть собственные репы, которые как то переплетены с Убунтовскими.

Сразу скажу, что коментарии типа "Минт это та же Ubuntu" или "всегда всё было хорошо и тут вдруг сломалось", можно не писать.


Оффлайн jack_solovey

  • Автор темы
  • Активист
  • *
  • Сообщений: 864
  • Mate, и никаких Unity
    • Просмотр профиля
PPA? не было?
файл PPA удалить и обновить не?
Все дополнительные источники отключены.
Только основные остались
~$ sudo apt-get update
[sudo] пароль для xxxxxx:
Сущ:1 http://mirror.yandex.ru/ubuntu xenial InRelease
Сущ:2 http://mirror.yandex.ru/ubuntu xenial-updates InRelease                                               
Игн:3 http://archive.canonical.com/ubuntu trusty InRelease                                                 
Сущ:4 http://mirror.yandex.ru/ubuntu xenial-backports InRelease     
Сущ:5 http://mirror.yandex.ru/ubuntu xenial-security InRelease     
Сущ:6 http://archive.canonical.com/ubuntu trusty Release 

Пользователь добавил сообщение 30 Июнь 2019, 11:39:54:
Он не может быть таким же, потому что команда другая.
~$ sudo apt-get update && sudo apt-get dist-upgrade
Сущ:1 http://mirror.yandex.ru/ubuntu xenial InRelease
Сущ:2 http://mirror.yandex.ru/ubuntu xenial-updates InRelease                                                                     
Сущ:3 http://mirror.yandex.ru/ubuntu xenial-backports InRelease                                                                   
Сущ:4 http://mirror.yandex.ru/ubuntu xenial-security InRelease                             
Игн:5 http://archive.canonical.com/ubuntu trusty InRelease         
Сущ:6 http://archive.canonical.com/ubuntu trusty Release           
Чтение списков пакетов… Готово                                     
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Расчёт обновлений… Готово
Следующие пакеты будут оставлены в неизменном виде:
  libgl1-mesa-dri
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 1 пакетов не обновлено.

Можно попробовать отключить "левые" репы и обновить систему.
Всё отключено
Я вижу у тебя Минт, у них там есть собственные репы, которые как то переплетены с Убунтовскими.
Сразу скажу, что коментарии типа "Минт это та же Ubuntu" или "всегда всё было хорошо и тут вдруг сломалось", можно не писать.

Я сразу написал о какой системе речь идет "Не могу перевести xubuntu 16.04 на 18.04"
Это не Mint
« Последнее редактирование: 30 Июнь 2019, 11:39:54 от jack_solovey »

Оффлайн ecc83

  • Старожил
  • *
  • Сообщений: 2115
  • Lubuntu 16.04 LTS
    • Просмотр профиля
Ну вот наконец то я уговорил тебя показать полный вывод команды. С третьего раза удалось.

А теперь смотри внимательно:


Цитировать
Сущ:1 http://mirror.yandex.ru/ubuntu xenial InRelease
Сущ:2 http://mirror.yandex.ru/ubuntu xenial-updates InRelease                                                                     
Сущ:3 http://mirror.yandex.ru/ubuntu xenial-backports InRelease                                                                   
Сущ:4 http://mirror.yandex.ru/ubuntu xenial-security InRelease                             
Игн:5 http://archive.canonical.com/ubuntu trusty InRelease         
Сущ:6 http://archive.canonical.com/ubuntu trusty Release

Ты в курсе, что "xenial" это Ubuntu 16.04, а "trusty" это 14.04 ?
То есть у тебя часть репозиториев от одной системы, а часть от другой. А виноват конечно же Пушкин.
 

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
вот вижу сайт яндекс и ... проблема.
Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4444
    • Просмотр профиля
Цитировать
Сущ:4 http://mirror.yandex.ru/ubuntu xenial-security InRelease                             
Игн:5 http://archive.canonical.com/ubuntu trusty InRelease
Даже затрудняюсь сказать, что из этого более "левое".
Яндекс - это не Ubuntu. trusty - это не 16 и не 18.
В общем, ну и кашу ты заварил. Вкус получился вполне ожидаемый.

Оффлайн jack_solovey

  • Автор темы
  • Активист
  • *
  • Сообщений: 864
  • Mate, и никаких Unity
    • Просмотр профиля
Ну вот наконец то я уговорил тебя показать полный вывод команды. С третьего раза удалось.
Поумерь свой апломб пожалуйста. И относись с уважением к тем кому "хочешь помочь", или не помогай вовсе.
Меня не надо уговаривать. Я понимаю объяснения.
А уничижительное "это другая команда, мол ты тупенький не понимаешь" показывает тебя как человека высокомерного.
Ты привел две команды сразу, и в контексте мне было очевидно, что ты не поверил тому что я сказал про вывод второй команды. Что может быть интересного в первой я не подумал. А ты не соблаговолил объяснить.
(объясняю почему мне было неохота давать вывод команд. Система стоит не на моем компе, хожу туда по удлаленке, буфер обмена не работает, вывод таскаю через файл)

Человек с нормальным отношением, пояснил бы, что нужен вывод первой команды тоже т.к. есть подозрения на список источников.
И не стал бы потом уничижительное "ну вот наконец то я уговорил...".

Посмотри на себя со стороны.

Ты в курсе, что "xenial" это Ubuntu 16.04, а "trusty" это 14.04 ?Теперь буду в курсе, никогда на названия дистрибов внимания не обращал, И когда этот вывод смотрел, думал что это источники от текущего 16.04 и 18.04 на который пытался обновииться.

Цитировать
То есть у тебя часть репозиториев от одной системы, а часть от другой. А виноват конечно же Пушкин.
Я где-то искал виноватых? Свое подсознательное желание найти козла отпущения не прилепляй к другим.
А от меня с самого начала был нейтральный вопрос "Что нужно сделать чтобы эти пакеты обновились?"
И всё и я не искал вину у Пушкина, Путина, ГосДепа и инопланетян. А ты ищи, спасибо за помощь.

Пользователь добавил сообщение 30 Июнь 2019, 12:17:34:
вот вижу сайт яндекс и ... проблема.
Яндекс - это не Ubuntu.
Источник приложений сам предлагает сменить американские сервера Ubuntu на более близкие и быстрые зеркала, что я всегда и делаю.
И обычно это или Яндекс зеркала или МГУшные.
И никогда проблем не было.


Пользователь добавил сообщение 30 Июнь 2019, 12:32:36:
Даже затрудняюсь сказать, что из этого более "левое".
Яндекс - это не Ubuntu. trusty - это не 16 и не 18.
В общем, ну и кашу ты заварил. Вкус получился вполне ожидаемый.
Убрал зеркало (хотя очевидно что оно тут не причем)
Ситуация не изменилась.
~$ sudo apt-get update && sudo apt-get dist-upgrade
Сущ:1 http://archive.ubuntu.com/ubuntu xenial InRelease
Сущ:2 http://archive.ubuntu.com/ubuntu xenial-updates InRelease     
Сущ:3 http://archive.ubuntu.com/ubuntu xenial-backports InRelease   
Сущ:4 http://archive.ubuntu.com/ubuntu xenial-security InRelease   
Чтение списков пакетов… Готово                                     
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Расчёт обновлений… Готово
Следующие пакеты будут оставлены в неизменном виде:
  libgl1-mesa-dri
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 1 пакетов не обновлено.
« Последнее редактирование: 30 Июнь 2019, 12:32:36 от jack_solovey »

 

Страница сгенерирована за 0.072 секунд. Запросов: 25.