Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Установка Profanity IM (Console based XMPP client)  (Прочитано 877 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн acetone

  • Автор темы
  • Участник
  • *
  • Сообщений: 158
    • Просмотр профиля
    • Fediverse
Установка Profanity IM (Console based XMPP client)
« : 13 Февраля 2020, 13:32:24 »
 :coolsmiley: Рад, что ты читаешь это, дорогой юзернейм!

Вздумалось мне поставить консольный жаббер-клиент. Нашел Profanity. В гайде по установке вычитал, что он доступен даже из родных репозиториев Ubuntu. С радостью установил: apt-get install profanityНо, как водится, версия в репозитории оказалось в два раза старее актуальной (0.5 вместо 0.8 ). Пощупал, посмотрел - почти влюбился. Сложности возникли только с PGP.
Суть вопроса: как мне установить свежую версию? С Github скачал исходники, но ума не приложу как их собрать (я немного ламер). Привычные "setup.py" и "make clean" под случай не подходят.
(Нажмите, чтобы показать/скрыть)

Вопрос для кого-то будет смешной, но прошу помочь :)

Пользователь добавил сообщение 13 Февраля 2020, 13:57:07:
Скачивание свежего deb-пакета с packages.debian.org при sudo apt-get install ./profanity_0.8.0-1_amd64.deb Выдает:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'profanity' instead of './profanity_0.8.0-1_amd64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 profanity : Depends: libncursesw6 (>= 6) but it is not installable
             Depends: libreadline8 (>= 6.0) but it is not installable
             Depends: libsignal-protocol-c2.3.2 but it is not installable
             Depends: libtinfo6 (>= 6) but it is not installable
E: Unable to correct problems, you have held broken packages.
« Последнее редактирование: 13 Февраля 2020, 13:57:07 от .acetone »
Пошутил про демона - нажал иконку.

Оффлайн ALiEN175

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5451
  • Сделай шаг и пройдешь милю
    • Просмотр профиля
Re: Установка Profanity IM (Console based XMPP client)
« Ответ #1 : 13 Февраля 2020, 21:04:43 »
Скачивание свежего deb-пакета с packages.debian.org
Не смущает, что debian ≠ ubuntu?

версия 0.7 в 19.10
версия 0.8 в 20.04
ASUS P5K-C :: Intel Xeon E5450 @ 3.00GHz :: 8 GB DDR2 :: Radeon R7 260X :: XFCE
ACER 5750G :: Intel Core i5-2450M @ 2.50GHz :: 6 GB DDR3 :: GeForce GT 630M :: XFCE

Оффлайн acetone

  • Автор темы
  • Участник
  • *
  • Сообщений: 158
    • Просмотр профиля
    • Fediverse
Re: Установка Profanity IM (Console based XMPP client)
« Ответ #2 : 15 Февраля 2020, 16:28:19 »
ALiEN175, сейчас немного смутило. Однако руководствовался тем, что с сайта разработчиков на установку в Debian, Ubuntu и еще чём-то ссылка была одна. Оказывается, ссылочка-то одна, а кукиш :)
Спасибо за отклик.
Пошутил про демона - нажал иконку.

 

Страница сгенерирована за 0.043 секунд. Запросов: 25.