Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: KDE: Ошибка при автомонтировании компакт-дисков  (Прочитано 1207 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Михаил Минц

  • Автор темы
  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
Добрый день!

Почему-то при автомонтировании компакт-диска KDE выдаёт (в специальном окошке) следующее сообщение:

Цитировать
/media/cdrom0 - это папка, хотя ожидался файл.

Диск при этом благополучно монтируется, так что предупреждение только раздражает. Нельзя ли его как-нибудь убрать?

Использую "Kubuntu 8.04" с последними обновлениями. Автомонтирование настраивал следующим образом: в центре настройки KDE выбираем Периферия - Устройства хранения данных, создаём новую опцию "Подключить" (команда: mount /media/cdrom) и делаем её реакцией по умолчанию для нужных типов дисков. В консоли команда mount /media/cdrom выполняется без ошибок. Более того: если примонтировать диск вручную средствами KDE (т.е. правым щелчком по значку диска), никаких предупреждений тоже не появляется.

Буду признателен за любые идеи :-)

Оффлайн tazhate

  • Активист
  • *
  • Сообщений: 864
  • kunilinux
    • Просмотр профиля
странное какоето автомонтирование =)
а сам он с каких пор перестал монтироватся, без действий ручками?
lenovo thinkpad x1, gentoo ~amd64, awesome wm
asrock 330, atom 330, nvidia ion, 4gb ram, gentoo ~amd64, awesome wm
htc desire z, virtuos rom

Оффлайн Михаил Минц

  • Автор темы
  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
странное какоето автомонтирование =)
а сам он с каких пор перестал монтироватся, без действий ручками?
После установки системы автомонтирование вообще не работало. К сожалению, уже не могу вспомнить, как вёл себя "Kubuntu 7.10" (поставил его незадолго до выхода 8.04 и, видимо, просто не обращал внимания на такие вещи). До него использовал "ALT Linux 2.4 Master" - помнится, там компакт-диск монтировался автоматически при первом обращении к нему, а для флэшки автоматически создавалась точка монтирования и запись в fstab. Может быть, от него остались какие-то настройки, с которыми теперь конфликтует новая версия KDE (каталог /home перенёс из старой системы вместе со всем содержимым)?

Оффлайн tazhate

  • Активист
  • *
  • Сообщений: 864
  • kunilinux
    • Просмотр профиля
вполне вероятно =)
на самом деле лучш  снуля поставить систепму и не шалить, если хреново траблы решать получается
lenovo thinkpad x1, gentoo ~amd64, awesome wm
asrock 330, atom 330, nvidia ion, 4gb ram, gentoo ~amd64, awesome wm
htc desire z, virtuos rom

Оффлайн Михаил Минц

  • Автор темы
  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
Нет, похоже, что старые настройки всё-таки не при чём. Специально попробовал создать нового пользователя - никаких отличий от уже существующих.

Оффлайн tazhate

  • Активист
  • *
  • Сообщений: 864
  • kunilinux
    • Просмотр профиля
/etc/fstab в студию
lenovo thinkpad x1, gentoo ~amd64, awesome wm
asrock 330, atom 330, nvidia ion, 4gb ram, gentoo ~amd64, awesome wm
htc desire z, virtuos rom

Оффлайн Михаил Минц

  • Автор темы
  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
mmm@antosha:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda5
UUID=e6ae737d-d323-441c-9776-c19253389b2e /               reiserfs notail,relatime 0       1
# /dev/sda7
UUID=fe2b41ed-4625-d328-b59a-4379d2ec3206 /home           reiserfs relatime        0       2
# /dev/sda8
UUID=74308D9B308D64C8 /media/documents ntfs    defaults,umask=007,gid=46 0       1
# /dev/sda1
UUID=56BC8D88BC8D637B /media/windows  ntfs    defaults,umask=007,gid=46 0       1
# /dev/sda6
UUID=db48cb81-de26-4851-a3f2-65aba9140828 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

Оффлайн tazhate

  • Активист
  • *
  • Сообщений: 864
  • kunilinux
    • Просмотр профиля
sudo mkdir /media/dvd
sudo kate /etc/fstab
заменяешь в нем строку /media/cdrom0 на /media/dvd
пробуешь ребутнутся и вставить сидюк.
lenovo thinkpad x1, gentoo ~amd64, awesome wm
asrock 330, atom 330, nvidia ion, 4gb ram, gentoo ~amd64, awesome wm
htc desire z, virtuos rom

Оффлайн Михаил Минц

  • Автор темы
  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
Попробовал - та же самая реакция.

Оффлайн mazut

  • Забанен
  • Активист
  • *
  • Сообщений: 703
  • да, не заходи ты сюда!
    • Просмотр профиля
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0

Убрать  utf8

Привести к виду:

/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec 0 0
« Последнее редактирование: 21 Июль 2008, 22:58:35 от mazut »
Патрикеич.
Под наблюдением.

Оффлайн Михаил Минц

  • Автор темы
  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
И это не помогает - то же самое поведение :-(

Оффлайн mazut

  • Забанен
  • Активист
  • *
  • Сообщений: 703
  • да, не заходи ты сюда!
    • Просмотр профиля
Тогда

tail -f /var/log/messages

и вставить диск. Если нет ошибок, тогда KDE немного бредит. Так предпoлогаю.

У меня так вывод

Jul 22 21:19:31 alexde kernel: [ 3184.676965] UDF-fs: Partition marked readonly; forcing readonly mount
Jul 22 21:19:31 alexde kernel: [ 3184.705301] UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting volume 'BIO', timestamp 2007/09/11 10:24 (1078)
Патрикеич.
Под наблюдением.

Оффлайн Михаил Минц

  • Автор темы
  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
Нет, у меня было по-другому:

Jul 23 12:20:44 antosha kernel: [  446.100148] UDF-fs: No VRS found

Исправил в fstab тип файловой системы для /dev/scd0 на auto (было udf,iso9660) - теперь, когда я вставляю компакт-диск, в /var/log/messages не появляется вообще никаких сообщений. KDE реагирует по-прежнему.

Оффлайн mazut

  • Забанен
  • Активист
  • *
  • Сообщений: 703
  • да, не заходи ты сюда!
    • Просмотр профиля
fstab не надо править, все ошибки лежат в гуевых приблудах KDE. Поищи, где system-установки-сменные носители. Убери галочки с окошек, закрой. Запусти снова, постав галки на место. Не знаю, поможет ли  :-\
Патрикеич.
Под наблюдением.

 

Страница сгенерирована за 0.093 секунд. Запросов: 22.