Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: An upgrade from 'cosmic' to 'eoan' is not supported with this tool.  (Прочитано 1346 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ForeverSh

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Привет всем, у меня Ubuntu 18.10 и мне менеджер обновлений предлагает сразу перейти на Ubuntu 19.10 но это невозможно без обновления на ubuntu 19.04.
Когда выполнял пошагово действия на обновление с 18.10 на 19.04 с сайта:
https://www.linuxbabe.com/ubuntu/upgrade-ubuntu-18-04-18-10-to-ubuntu-19-04
Мне все равно предлагает версию 19.10 (пробовал через консоль)

Буду очень благодарен если кто-то поможет мне это сделать без полного переустановки системы.

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3817
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 22.04, 24.04
    • Просмотр профиля
Re: An upgrade from 'cosmic' to 'eoan' is not supported with this tool.
« Ответ #1 : 27 Апреля 2020, 23:31:23 »
ForeverSh, это не проблема - выполняешь в консоли:
sudo sed -i 's/cosmic/focal/g' /etc/apt/sources.list
sudo apt update
sudo apt dist-upgrade
и в результате получаешь последнюю Ubuntu 20.04. Ну сам подумай, зачем тебе 19.10?
« Последнее редактирование: 27 Апреля 2020, 23:54:06 от AlexBKost »
Я странен, а не странен кто ж? (С)

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 14037
  • Xubuntu 18.04
    • Просмотр профиля
Re: An upgrade from 'cosmic' to 'eoan' is not supported with this tool.
« Ответ #2 : 27 Апреля 2020, 23:33:08 »
AlexBKost,
Совесть есть? И с какого перепугу получишь 20.04? Это шутка такая что ли?
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3817
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 22.04, 24.04
    • Просмотр профиля
Re: An upgrade from 'cosmic' to 'eoan' is not supported with this tool.
« Ответ #3 : 27 Апреля 2020, 23:42:40 »
SergeyIT, Pilot6, вы такие резвые парни, замечаете все в полёте, да и я тоже чуть-чуть поторопился - для ТС будет так:
sudo sed -i 's/cosmic/focal/g' /etc/apt/sources.list
sudo apt update
sudo apt dist-upgrade
извиняйте друзья, бегу впереди паровоза.
Я странен, а не странен кто ж? (С)

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3817
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 22.04, 24.04
    • Просмотр профиля
Re: An upgrade from 'cosmic' to 'eoan' is not supported with this tool.
« Ответ #4 : 27 Апреля 2020, 23:55:05 »
SergeyIT, поправил, для новичков.
Я странен, а не странен кто ж? (С)

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 14037
  • Xubuntu 18.04
    • Просмотр профиля
Re: An upgrade from 'cosmic' to 'eoan' is not supported with this tool.
« Ответ #5 : 27 Апреля 2020, 23:55:50 »
Только 99%, что все равно ничего хорошего из этого не выйдет и закончится переустановкой. )))
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3817
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 22.04, 24.04
    • Просмотр профиля
Re: An upgrade from 'cosmic' to 'eoan' is not supported with this tool.
« Ответ #6 : 28 Апреля 2020, 00:15:48 »
Пусть попробует и отпишется - и мы тоже будем уверены на 99%, т.е. уже 100.
Я странен, а не странен кто ж? (С)

Оффлайн ForeverSh

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: An upgrade from 'cosmic' to 'eoan' is not supported with this tool.
« Ответ #7 : 28 Апреля 2020, 09:22:41 »
Пусть попробует и отпишется - и мы тоже будем уверены на 99%, т.е. уже 100.
все равно ничего не получилось, и дальше предлагает перейти на 19.10 после чего пишет что это невозможно.

Оффлайн andytux

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 7002
    • Просмотр профиля
Re: An upgrade from 'cosmic' to 'eoan' is not supported with this tool.
« Ответ #8 : 28 Апреля 2020, 09:54:10 »
Цитировать
дальше предлагает перейти на 19.10 после чего пишет что это невозможно.
Правильно, т.к. она уже не поддерживается. И если не хочешь каждые полгода наступать на эту граблю, то ставь LTS-версию.
« Последнее редактирование: 28 Апреля 2020, 09:57:08 от andytux »

 

Страница сгенерирована за 0.07 секунд. Запросов: 25.