Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Не устанавливается olive-editor из ppa  (Прочитано 2100 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pelirrojo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
  • ¿Qué coño mires? Que escriba!
    • Просмотр профиля
Не устанавливается olive-editor из ppa
« : 06 Февраля 2021, 13:14:50 »
Всем, привет.

Столкнулся с такой проблемой что не устанавливается ppa.
В инструкции (https://www.olivevideoeditor.org/linux.php) говориться что надо ввести:
sudo add-apt-repository ppa:olive-editor/olive-editor
sudo apt-get update
sudo apt-get install olive-editor

но на первом шаге получаю:
Cannot add PPA: 'ppa:~olive-editor/ubuntu/olive-editor'.
The team named '~olive-editor' has no PPA named 'ubuntu/olive-editor'
Please choose from the following available PPAs:

не понимаю что делать далльше?

может кто-то установит себе и даст строчки из source.list?

snap, flatpack и прочее мракобесие не предлагать!  ;D  :D ;)
« Последнее редактирование: 06 Февраля 2021, 13:17:12 от Pelirrojo »
Lenovo ideapad 330 / Nvidia 1050m / CPU core i7 8th gen / RAM DDR4 16Gb / NVME 240 Gb + SSD 1Tb / kUbuntu 20.04

Оффлайн damix

  • Забанен
  • Активист
  • *
  • Сообщений: 664
    • Просмотр профиля
Re: Не устанавливается olive-editor из ppa
« Ответ #1 : 06 Февраля 2021, 14:59:09 »
не понимаю что делать далльше?
Не прогуливать английский в школе.

Оффлайн Aleksandru

  • Администратор
  • Старожил
  • *
  • Сообщений: 3352
    • Просмотр профиля
Re: Не устанавливается olive-editor из ppa
« Ответ #2 : 06 Февраля 2021, 15:23:24 »
А если просто ввести команду?
sudo apt-get install olive-editor
В офф. репах 20.04, есть этот видеоредактор.
Вы в какую систему пытаетесь его установить?
Intel Core i5-6400, GeForce GT 1030, ASUS ROG Strix B250G Gaming, 16GB RAM, KINGSTON SV300S37A240G, Digma Mega S3 DGSM3512GS33T 512ГБ.

Оффлайн Pelirrojo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
  • ¿Qué coño mires? Que escriba!
    • Просмотр профиля
Re: Не устанавливается olive-editor из ppa
« Ответ #3 : 06 Февраля 2021, 16:20:56 »
Вы в какую систему пытаетесь его установить?
На 20.04, естественно. В подписи уже сильно устаревшие данные. Ноутбук из подписи был залит кофе года 2 назад. 😉

В обычном репозитории вроде старая версия, а тут ppa от разработчика с самой свежей версией.
Lenovo ideapad 330 / Nvidia 1050m / CPU core i7 8th gen / RAM DDR4 16Gb / NVME 240 Gb + SSD 1Tb / kUbuntu 20.04

Оффлайн KJOI

  • Активист
  • *
  • Сообщений: 286
  • ALT Linux
    • Просмотр профиля
Re: Не устанавливается olive-editor из ppa
« Ответ #4 : 06 Февраля 2021, 17:07:16 »
На 20.04, естественно. В подписи уже сильно устаревшие данные. Ноутбук из подписи был залит кофе года 2 назад.
Как показывает регулярный :coolsmiley: опыт с кофе, чаем, вареньем они все равно работают достаточно просушить и сменить клавиатуру, а еще продают специальные чехлы с формой под конкретную модель клавиатуры.
Русский Линукс: https://www.basealt.ru/products/simplylinux/
Мой проект git «Kernel Manager» linux: https://github.com/Koi-foo/kernel-manager/

Оффлайн Aleksandru

  • Администратор
  • Старожил
  • *
  • Сообщений: 3352
    • Просмотр профиля
Re: Не устанавливается olive-editor из ppa
« Ответ #5 : 06 Февраля 2021, 18:32:39 »
В обычном репозитории вроде старая версия, а тут ppa от разработчика с самой свежей версией.
И в официальных репах такая по свежести версия:

Так что смело берем клавиатуру в руки, и вперед:
sudo apt install olive-editor
Intel Core i5-6400, GeForce GT 1030, ASUS ROG Strix B250G Gaming, 16GB RAM, KINGSTON SV300S37A240G, Digma Mega S3 DGSM3512GS33T 512ГБ.

Оффлайн Pelirrojo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 49
  • ¿Qué coño mires? Que escriba!
    • Просмотр профиля
Re: Не устанавливается olive-editor из ppa
« Ответ #6 : 07 Февраля 2021, 11:08:21 »
Так что смело берем клавиатуру в руки, и вперед:
Установил я эту версию, но это какая-то дико старая альфа. Вобщем нужно как-то установить из ppa
Lenovo ideapad 330 / Nvidia 1050m / CPU core i7 8th gen / RAM DDR4 16Gb / NVME 240 Gb + SSD 1Tb / kUbuntu 20.04

Онлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5611
  • Все по палатам!
    • Просмотр профиля
Re: Не устанавливается olive-editor из ppa
« Ответ #7 : 07 Февраля 2021, 13:36:48 »
Pelirrojo,
Может собрать?
https://www.olivevideoeditor.org/compile.php#ubuntu
Извините, я все еще учусь

Оффлайн Aleksandru

  • Администратор
  • Старожил
  • *
  • Сообщений: 3352
    • Просмотр профиля
Re: Не устанавливается olive-editor из ppa
« Ответ #8 : 07 Февраля 2021, 14:04:02 »
SergeyIT, а может лучше в AppImage программу скачать, чем систему захламлять?
Но ТС у нас принципиальный.
С непонятно кем сделанного репозитория он хочет программу установить, а собранную в AppImage самими разработчиками нет.
Snap и Flatpak я тоже не перевариваю, но чем AppImage не угодил?
Сейчас скачал Olive-19eabf28-Linux-x86_64.AppImage, запустил.
Версия Olive 0.2.0-19eabf28, язык русский есть.
Intel Core i5-6400, GeForce GT 1030, ASUS ROG Strix B250G Gaming, 16GB RAM, KINGSTON SV300S37A240G, Digma Mega S3 DGSM3512GS33T 512ГБ.

Оффлайн Ser_W

  • Активист
  • *
  • Сообщений: 386
    • Просмотр профиля
Re: Не устанавливается olive-editor из ppa
« Ответ #9 : 07 Февраля 2021, 14:33:48 »

Оффлайн Igor_ubuntu

  • Участник
  • *
  • Сообщений: 101
    • Просмотр профиля
Re: Не устанавливается olive-editor из ppa
« Ответ #10 : 07 Февраля 2021, 19:05:45 »
Цитировать
Cannot add PPA: 'ppa:~olive-editor/ubuntu/olive-editor'.
The team named '~olive-editor' has no PPA named 'ubuntu/olive-editor'
Please choose from the following available PPAs:

Это означает:
That PPA was not made by Matthew (olive-team), which is why you're getting that error. It was made by some person who we have never had contact with and who is not affiliated with the project in any way ..

Цитировать
В обычном репозитории вроде старая версия, а тут ppa от разработчика с самой свежей версией.

Не от разработчика и не с самой свежей версией, а старьем годичной давности.

Цитировать
не понимаю что делать дальше?

1. Забыть об этом ppa и пакете из репов. Потому что 0.2-релиза как такового еще не было. То, что валяется в штатных и сторонних репах под вывеской 0.2 - это текущие срезы репозитория на гитхаб. В ppa - срез по состоянию на 2020-02-21, то-бишь преданье старины глубокой. Оно тебе надо ?!

2. Ставить unstable 0.2 nightly builds appimage отсюда https://olivevideoeditor.org/nightly.php
При этом не забывать, что программа в активной разработке и значит что-то добавляется, исправляется, а что-то вероятно ломается, а значит возможны проблемы со стабильностью и т.п. То есть не требуй от нее много и будь готов к неожиданностям.


Если appimage ставить мировоззрение не позволяет, ну тогда ставь старье из ppa, не добавляя ppa в систему

Качаешь вручную пакет для 20.04 со страницы ppa.
В зависимостях у него:
Depends:
libavcodec58 (>= 7:4.2), libavfilter7 (>= 7:4.0), libavformat58 (>= 7:4.2), libavutil56 (>= 7:4.0), libc6 (>= 2.29), libgcc-s1 (>= 3.0), libopencolorio1v5 (>= 1.1.1~dfsg0), libopenimageio2.1 (>= 2.1.10.1~dfsg0), libqt5core5a (>= 5.12.2), libqt5gui5 (>= 5.11.0~rc1) | libqt5gui5-gles (>= 5.11.0~rc1), libqt5multimedia5 (>= 5.9.0~rc), libqt5widgets5 (>= 5.12.2), libstdc++6 (>= 5.2), libswresample3 (>= 7:4.0), libswscale5 (>= 7:4.0), ffmpeg, frei0r-plugins, libqt5multimedia5-plugins

Устанавливаешь их, затем
sudo dpkg -i пакет

--------
Или сначала sudo dpkg -i пакет
После этого у тебя будут поломаны зависимости в системе и заблокирована работа синаптика.
sudo apt-get install -f всё автоматически поправит и установит требуемые зависимости.
Если в ходе установки зависимостей пакет оливе будет удален (читай сообщение в терминале), тогда ещё раз сделай sudo dpkg -i пакет

Или устанавливай пакет при помощи Gdebi - это фронтенд к dpkg, но он умеет разруливать зависимости самостоятельно.


Мораль сей басни такова: ставь appimage и не морочь себе голову.
« Последнее редактирование: 07 Февраля 2021, 19:11:57 от Igor_ubuntu »

 

Страница сгенерирована за 0.05 секунд. Запросов: 25.