Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: [Решено] Пропал пользователь из окна входа в систему  (Прочитано 1375 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Amavite

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
  • Кривыми должны быть извилины, а не руки.
    • Просмотр профиля
Пропал пользователь с окна приветствия и с вкладки "пользователи" в настройках. При включении ПК предлагает создать нового пользователя. Создаю. Завершаю сеанс и логинюсь в свой профиль через "нет в списке", потому что в списке мой аккаунт не отображается. Если удалить новоиспеченного пользователя то, при перезагрузке, приходится опять оного создавать, ибо никак не дает залогиниться к себе. Как вернуть себя, так сказать? Хелп плиз.
P.S. Когда захожу к себе, то всё в порядке. Всё на месте и всё работает.
« Последнее редактирование: 06 Марта 2021, 18:29:23 от Amavite »
Motherboard: GIGABYTE GA-H61M-S1 rev.2.2, CPU: Intel Core i5-3570k,
GPU: NVIDIA GTX-760 2Gb, RAM: 2x4Gb 1333MHz, HDD: Western Digital WD10EZEX 1Tb,
Power Supply: Xilence Red Wings XN052 500W

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 5277
    • Просмотр профиля
Re: Пропал пользователь из окна gdm3.
« Ответ #1 : 05 Марта 2021, 05:00:17 »
Загляни в /var/lib/AcountsService/users. Может что подскажет.

Оффлайн Amavite

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
  • Кривыми должны быть извилины, а не руки.
    • Просмотр профиля
Re: Пропал пользователь из окна gdm3.
« Ответ #2 : 05 Марта 2021, 14:05:55 »
Загляни в /var/lib/AcountsService/users. Может что подскажет.
Там пользователь есть.
Перед этим приключением я ковырялся с кастомизацией консоли, по статье с хабра. Не понравилось. Сделал sudo apt remove zsh и руками в домашней папке скрытые файлы от него удалил. Есть подозрение, что что-то лишнее удалил, скорее всего
Motherboard: GIGABYTE GA-H61M-S1 rev.2.2, CPU: Intel Core i5-3570k,
GPU: NVIDIA GTX-760 2Gb, RAM: 2x4Gb 1333MHz, HDD: Western Digital WD10EZEX 1Tb,
Power Supply: Xilence Red Wings XN052 500W

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 5277
    • Просмотр профиля
Цитировать
Там пользователь есть
Так и смотри глубже. Сравни файлы разных пользователей, может там настройка, показывать или нет пользователя.
Цитировать
Есть подозрение, что что-то лишнее удалил
Есть подозрения - надо проверить. Восстанови из бэкапа и.... У тебя конечно-же есть бэкап?
« Последнее редактирование: 05 Марта 2021, 14:18:42 от andytux »

Оффлайн Amavite

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
  • Кривыми должны быть извилины, а не руки.
    • Просмотр профиля
andytux, Там только один файл, моего пользователя) Ибо нового я таки удалил. Но когда он не был удален, я сравнивал два файла эти. Идентичны были. И бэкапа у меня нет, согрешил... Простите новичка)

P.S. Суть в том, что пользователь не отображается даже в настройках, на вкладке "пользователи". А он есть.
« Последнее редактирование: 05 Марта 2021, 14:28:06 от Amavite »
Motherboard: GIGABYTE GA-H61M-S1 rev.2.2, CPU: Intel Core i5-3570k,
GPU: NVIDIA GTX-760 2Gb, RAM: 2x4Gb 1333MHz, HDD: Western Digital WD10EZEX 1Tb,
Power Supply: Xilence Red Wings XN052 500W

Оффлайн ALiEN175

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5374
  • Сделай шаг и пройдешь милю
    • Просмотр профиля
cat /etc/passwd | grep ama
ASUS P5K-C :: Intel Xeon E5450 @ 3.00GHz :: 8 GB DDR2 :: Radeon R7 260X :: XFCE
ACER 5750G :: Intel Core i5-2450M @ 2.50GHz :: 6 GB DDR3 :: GeForce GT 630M :: XFCE

Оффлайн Amavite

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
  • Кривыми должны быть извилины, а не руки.
    • Просмотр профиля
cat /etc/passwd | grep ama

amavite:x:1000:1000:Amavite,,,:/home/amavite:/usr/bin/zsh
amavit:x:1001:1001:amavit,,,:/home/amavit:/bin/bash


Вот такой вывод. Странно. И ещё, при каждом включении ПК выдает окно приветствия, как при установке и приходится нового пользователя создавать(

P.S. Вот этого (/home/amavite:/usr/bin/zsh) у себя не вижу. Имею ввиду, zsh.
« Последнее редактирование: 05 Марта 2021, 19:50:18 от Amavite »
Motherboard: GIGABYTE GA-H61M-S1 rev.2.2, CPU: Intel Core i5-3570k,
GPU: NVIDIA GTX-760 2Gb, RAM: 2x4Gb 1333MHz, HDD: Western Digital WD10EZEX 1Tb,
Power Supply: Xilence Red Wings XN052 500W

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27977
    • Просмотр профиля
sudo chsh --shell=/bin/bash amavite
userdel --remove --force amavit
getent passwd | grep ama
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Amavite

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
  • Кривыми должны быть извилины, а не руки.
    • Просмотр профиля
sudo chsh --shell=/bin/bash amavite
userdel --remove --force amavit
getent passwd | grep ama
Благодарю. Частично проблема решилась. При перезагрузке теперь не просит нового пользователя создать. Но на экране входа так и не появился. И в -"настройки" -> "пользователи" так и висит: "Пользователи не найдены". 

В /var/lib/AccountsService/users/amavite вот это. Может быть, здесь что-то не так? Извините. На askubuntu видел нечто похожее. Только там наоборот хотели скрыть пользователя. И отправляют этот файл ковырять. А я понятия не имею, как он должен выглядеть.

Session=
XSession=
Icon=/home/amavite/.face
SystemAccount=true

[InputSource0]
xkb=us

[InputSource1]
xkb=ru
« Последнее редактирование: 05 Марта 2021, 20:33:41 от Amavite »
Motherboard: GIGABYTE GA-H61M-S1 rev.2.2, CPU: Intel Core i5-3570k,
GPU: NVIDIA GTX-760 2Gb, RAM: 2x4Gb 1333MHz, HDD: Western Digital WD10EZEX 1Tb,
Power Supply: Xilence Red Wings XN052 500W

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27977
    • Просмотр профиля
SystemAccount=true
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн ALiEN175

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5374
  • Сделай шаг и пройдешь милю
    • Просмотр профиля
SystemAccount=true
Замените на
SystemAccount=false
ASUS P5K-C :: Intel Xeon E5450 @ 3.00GHz :: 8 GB DDR2 :: Radeon R7 260X :: XFCE
ACER 5750G :: Intel Core i5-2450M @ 2.50GHz :: 6 GB DDR3 :: GeForce GT 630M :: XFCE

Оффлайн Amavite

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
  • Кривыми должны быть извилины, а не руки.
    • Просмотр профиля
SystemAccount=true
Замените на
SystemAccount=false
Эммм... А можно узнать, при всём уважении к Вам, чем это чревато? Мне бы искренне не хотелось заново всё ставить. Я ни в коем разе не сомневаюсь в Вашем профессионализме. Просто хочу знать, на что повлияет изменение этого параметра. Профиль станет не системным. А как понять это? Я просто недавно в Linux. То есть, грубо говоря, кастрированный профиль? Или я ошибаюсь.

P.S. Изменение True на False не помогло. Помогло только полное удаление данной строчки. Что это было, я не понял... А начиналось то всё с кастомизации терминала...
Точнее, частично помогло. В окне логина "Я" появился. Но в "настройки -> пользователи" - нет.
Может быть, посоветуете какую то литературу для чайников, по Linux? Более менее современную. Я тут прохожу пару лайт курсов по пингвину, но там так все.... Такое себе крч.
« Последнее редактирование: 06 Марта 2021, 00:29:11 от Amavite »
Motherboard: GIGABYTE GA-H61M-S1 rev.2.2, CPU: Intel Core i5-3570k,
GPU: NVIDIA GTX-760 2Gb, RAM: 2x4Gb 1333MHz, HDD: Western Digital WD10EZEX 1Tb,
Power Supply: Xilence Red Wings XN052 500W

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27977
    • Просмотр профиля
В окне логина "Я" появился. Но в "настройки -> пользователи" - нет.
SystemAccount как раз маркирует пользователя как системный (== невидимый для окна логина) аккаунт.
А вот настройки-пользователи - это совсем другая песня. Не помогу, я с десктопом очень мало знаком.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Amavite

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
  • Кривыми должны быть извилины, а не руки.
    • Просмотр профиля
Спасибо большое всем, кто помогал решить проблему. Вопрос решен. Помогло изменение /var/lib/AccountsService/users/amavite -> "SystemAccount = true" на "false". Везде я появился) Правда, в настройках после второй перезагрузки появился пользователь. Ещё раз всем спасибо, тему можно закрыть
Motherboard: GIGABYTE GA-H61M-S1 rev.2.2, CPU: Intel Core i5-3570k,
GPU: NVIDIA GTX-760 2Gb, RAM: 2x4Gb 1333MHz, HDD: Western Digital WD10EZEX 1Tb,
Power Supply: Xilence Red Wings XN052 500W

 

Страница сгенерирована за 0.046 секунд. Запросов: 25.