Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Проблема с пакетами.  (Прочитано 809 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Diablero

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Проблема с пакетами.
« : 07 Октября 2021, 15:14:31 »
Моя система: Ubuntu 20.04.3 LTS 64-бит
В общем суть в том что после sudo apt upgrade пишет
Следующие пакеты будут оставлены в неизменном виде:
  libodbc1 wine-staging wine-staging-amd64 wine-staging-i386:i386
  winehq-staging

Пробую принудительно установить
sudo apt install libodbc1
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Предлагаемые пакеты:
  msodbcsql17 unixodbc-bin
Следующие пакеты будут УДАЛЕНЫ:
  libodbc1:i386
Следующие пакеты будут обновлены:
  libodbc1

Так же с вайном
sudo apt install wine-staging wine-staging-amd64 wine-staging-i386:i386
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Будут установлены следующие дополнительные пакеты:
  libvkd3d-shader1:i386 libvkd3d1:i386 vkd3d-compiler:i386 winehq-staging
Следующие пакеты будут УДАЛЕНЫ:
  vkd3d-compiler
Следующие НОВЫЕ пакеты будут установлены:
  libvkd3d-shader1:i386 libvkd3d1:i386 vkd3d-compiler:i386
Следующие пакеты будут обновлены:
  wine-staging wine-staging-amd64 wine-staging-i386:i386 winehq-staging
Проверил на фиксацию пакетов, aptitude search "~ahold" и dpkg --get-selections | grep hold всё пусто.

Что делать? Если принудительно установлю, будет ли всё хорошо потом? Почему такое произошло, ведь всё всегда обновлялось без проблем? Подскажите плиз где и что можно почитать на эту тему, чтобы в будущем знать что делать?

i386 это же для 32 битных систем, а у меня то 64.
Помогите пожалуйста.
« Последнее редактирование: 07 Октября 2021, 15:16:41 от ALiEN175 »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13987
  • Xubuntu 18.04
    • Просмотр профиля
Re: Проблема с пакетами.
« Ответ #1 : 07 Октября 2021, 15:41:10 »
Не совсем понятно в чем проблема. У вас подключен сторонний репозиторий wine. Поэтому возможны любые приключения. Но последняя команда же обновляет?
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Diablero

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Re: Проблема с пакетами.
« Ответ #2 : 07 Октября 2021, 16:06:34 »
Не совсем понятно в чем проблема. У вас подключен сторонний репозиторий wine. Поэтому возможны любые приключения.
А как вы определили сторонний репозиторий wine? У меня с официального сайта репозиторий системный, скрин прилагаю. Да, у меня ещё есть Lutris и Playonlinux, и там установлены wine, но они же отдельно лежат и не мешают системному wine или я что то путаю?
Скрин: https://ibb.co/0qkq3T3

Ещё не понятно про libodbc1, зачем он хочет удалить i386 версию и предлагает установить 2 пакета msodbcsql17 unixodbc-bin? Так же про vkd3d-compiler, почему хочет удалить этот пакет, он же 64 битный получается?
Просто боюсь всё сломать...

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13987
  • Xubuntu 18.04
    • Просмотр профиля
Re: Проблема с пакетами.
« Ответ #3 : 07 Октября 2021, 16:08:55 »
А как вы определили сторонний репозиторий wine?
Очень просто. Никакого wine-staging в официальных репах нет.

Пользователь добавил сообщение 07 Октября 2021, 16:11:18:
Дайте вывод

apt list wine-staging

Пользователь добавил сообщение 07 Октября 2021, 16:12:36:
зачем он хочет удалить i386 версию и предлагает установить 2 пакета msodbcsql17 unixodbc-bin? Так же про vkd3d-compiler, почему хочет удалить этот пакет, он же 64 битный получается?
Так зависимости в сторонней репе прописаны видимо.
« Последнее редактирование: 07 Октября 2021, 16:12:36 от Pilot6 »
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Diablero

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Re: Проблема с пакетами.
« Ответ #4 : 07 Октября 2021, 16:14:36 »
Дайте вывод

apt list wine-staging

apt list wine-staging
Вывод списка… Готово
wine-staging/focal 6.18~focal-1 amd64 [может быть обновлён с: 6.16~focal-1]
wine-staging/focal 6.18~focal-1 i386

Пользователь добавил сообщение 07 Октября 2021, 16:17:16:
Так зависимости в сторонней репе прописаны видимо.
А как узнать откуда эта либа взялась? Из какого репозитория?
« Последнее редактирование: 07 Октября 2021, 16:17:16 от Diablero »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13987
  • Xubuntu 18.04
    • Просмотр профиля
Re: Проблема с пакетами.
« Ответ #5 : 07 Октября 2021, 16:18:06 »
Ну и

apt show wine-staging
Пользователь добавил сообщение 07 Октября 2021, 16:19:25:
Ну и еще одну

apt-cache policy wine-staging
Всё будет видно.
« Последнее редактирование: 07 Октября 2021, 16:19:53 от Pilot6 »
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Diablero

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Re: Проблема с пакетами.
« Ответ #6 : 07 Октября 2021, 16:19:53 »
apt show wine-staging
Package: wine-staging
Version: 6.18~focal-1
Priority: optional
Section: otherosfs
Maintainer: Rosanne DiMesio <dimesio@earthlink.net>, Marcus Meissner <meissner@suse.com>
Original-Maintainer: WineHQ Builds <webmaster@fds-team.de>
Installed-Size: 18,2 MB
Pre-Depends: dpkg (>= 1.14.12ubuntu3)
Depends: debconf (>= 0.5) | debconf-2.0, libc6 (>= 2.17), wine-staging-i386 (= 6.18~focal-1), wine-staging-amd64 (= 6.18~focal-1)
Recommends: libcap2-bin
Download-Size: 3 616 kB
APT-Sources: https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
Description: WINE Is Not An Emulator - runs MS Windows programs
 Wine is a program which allows running Microsoft Windows programs
 (including DOS, Windows 3.x and Win32 executables) on Unix. It
 consists of a program loader which loads and executes a Microsoft
 Windows binary, and a library (called Winelib) that implements Windows
 API calls using their Unix or X11 equivalents.  The library may also
 be used for porting Win32 code into native Unix executables.

N: Есть 40 дополнительных записей. Используйте «-a» для их просмотра.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13987
  • Xubuntu 18.04
    • Просмотр профиля
Re: Проблема с пакетами.
« Ответ #7 : 07 Октября 2021, 16:20:27 »
Diablero,

Ну вот жеж сторонняя репа.

https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages

Это скорее надо у них спрашивать что они там прописали.

Пользователь добавил сообщение 07 Октября 2021, 16:22:12:
А то что какие-то пакеты будут удалены - это нестрашно.
« Последнее редактирование: 07 Октября 2021, 16:22:12 от Pilot6 »
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Diablero

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Re: Проблема с пакетами.
« Ответ #8 : 07 Октября 2021, 16:25:04 »
Ну так мне устанавливать вручную, не поломаю систему, ведь всегда wine можно снести и установить заново? Просто всегда пользовался staging версией из за игр.
А что с libodbc1, обновляться вручную?

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13987
  • Xubuntu 18.04
    • Просмотр профиля
Re: Проблема с пакетами.
« Ответ #9 : 07 Октября 2021, 16:27:40 »
А что с libodbc1, обновляться вручную?
Ну он и так предлагает обновиться. Я проблемы не вижу. i386 удаляется, так как видимо не нужен.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Diablero

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Re: Проблема с пакетами.
« Ответ #10 : 07 Октября 2021, 16:42:58 »
Отлично, я всё понял! :coolsmiley: Спасибо большое! ;)
« Последнее редактирование: 07 Октября 2021, 18:46:11 от Diablero »

 

Страница сгенерирована за 0.071 секунд. Запросов: 25.