Форум русскоязычного сообщества Ubuntu


Автор Тема: Настройка abills  (Прочитано 7581 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tramX

  • Автор темы
  • Новичок
  • *
  • Сообщений: 40
    • Просмотр профиля
Настройка abills
« : 20 Сентябрь 2008, 02:35:47 »
Пытаюсь настроить abills по этому руководству.
http://www.tux.in.ua/articles/749#more-749 Не получается apache2 настроить. Если как в статье добавить
Alias /abills “/usr/abills/cgi-bin/”
<Directory “/usr/abills/cgi-bin”>
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{HTTP:Authorization} ^(.*)
RewriteRule ^(.*) - [E=HTTP_CGI_AUTHORIZATION:%1]
Options Indexes ExecCGI SymLinksIfOwnerMatch
</IfModule>


# Интерфейс администратора
<Directory “/usr/abills/cgi-bin/admin”>
AddHandler cgi-script .cgi
Options Indexes ExecCGI FollowSymLinks
AllowOverride none
DirectoryIndex index.cgi
order deny,allow
allow from all
</Directory>

Ругается что не хватает </Directory> в первом случае
У меня после того как распакован архив в /usr/abills получается
Abills backup cgi-bin COPYING docs libexec misc soft
abills.sql bin CHANGES db language miniserv README var

http://localhost/admin не получается. Каталог admin есть в cgi-bin . Пытаюсь попасть http://localhost/cgi-bin/admin
получаю
The requested URL /cgi-bin/admin was not found on this server.

Оффлайн ultrapravyj

  • Новичок
  • *
  • Сообщений: 36
  • UBUNTU rulez!!! =)
    • Просмотр профиля
Re: Настройка abills
« Ответ #1 : 30 Октябрь 2008, 16:38:24 »
Ты всётаки восспользуйся и этим описанием  http://iglooom.livejournal.com/3739.html#cutid1
А возьми из первого описания про mysql и всё проканает!

Оффлайн Vetal_krot

  • Новичок
  • *
  • Сообщений: 37
    • Просмотр профиля
Re: Настройка abills
« Ответ #2 : 31 Октябрь 2008, 22:33:42 »
Пробовал настраивать по обеих ссылках (с использованием рррое и ррtр) всеравно не работает, вернее не проходит авторизация.
freeradius вообще как то странно работает, при выполнении

radiusd –X пишет
bash: /usr/sbin/radiusd: No such file or directory
радтест вообще не работает, помогите кто чем может, 4-й день бъюсь в истереке немагу настроить((((((((((
kubuntu desctop 8.04, ubuntu server 8.04

Оффлайн Vetal_krot

  • Новичок
  • *
  • Сообщений: 37
    • Просмотр профиля
Re: Настройка abills
« Ответ #3 : 31 Октябрь 2008, 22:49:49 »
и еще как войти в интерфейс пользователя?
kubuntu desctop 8.04, ubuntu server 8.04

Оффлайн ultrapravyj

  • Новичок
  • *
  • Сообщений: 36
  • UBUNTU rulez!!! =)
    • Просмотр профиля
Re: Настройка abills
« Ответ #4 : 13 Ноябрь 2008, 18:03:51 »
http://silverghost.org.ua/2008/10/13/ustanovka-billinga-abills-na-ubuntu-804-lts-server-mikrotik-router-os-v-kachestve-servera-dostupa/#comment-1177 А вот ещё одно описание!!!! Говорят, что оно точно рабочееjavascript:void(0);!!!!

Оффлайн Silver Ghost

  • Участник
  • *
  • Сообщений: 107
    • Просмотр профиля
Re: Настройка abills
« Ответ #5 : 14 Декабрь 2008, 11:07:46 »
100% рабочее, т.к. у меня самого оно и работает. :)

Оффлайн Nesmit

  • Старожил
  • *
  • Сообщений: 1296
    • Просмотр профиля
Re: Настройка abills
« Ответ #6 : 06 Январь 2009, 18:00:05 »
Угу, за 30 минут поднимается со всеми ковыряниями + mppe-128 и без Микротика.
Последнее требует подключение словарей к freradiusclient для pptpd смог понять ms-chap v2.

Однако, я так и не смог понять почему в базе вместо русских букв вопросики, все указывает на MySQL, но что править никак не пойму. :(((( Кодировка по умолчанию cp1251.
« Последнее редактирование: 06 Январь 2009, 18:23:43 от Nesmit »

Оффлайн ultrapravyj

  • Новичок
  • *
  • Сообщений: 36
  • UBUNTU rulez!!! =)
    • Просмотр профиля
Re: Настройка abills
« Ответ #7 : 06 Февраль 2009, 17:16:36 »
И у меня вопросики. Долго пытался устранить, не удалось....  :-[ Но меня наставляли на правельный путь, но дорогу я забыл....

Оффлайн Nesmit

  • Старожил
  • *
  • Сообщений: 1296
    • Просмотр профиля
Re: Настройка abills
« Ответ #8 : 08 Февраль 2009, 15:39:41 »
я не смог побороть вопросики, пришел к выводу, что сделано специально
Причины, если пользователь пишет админу сообщение, приходят вопросики, а если ответ то все ок! Правда забавно? :)))

Оффлайн salyery

  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Настройка abills
« Ответ #9 : 14 Февраль 2009, 09:29:09 »
Может кто сталкивался с такой проблемой. При запросе http://your.host/abills/admin/  в браузере отображается текст perl скрипта, выполнятся он не хочет. Настраивал как http://silverghost.org.ua/2008/10/13/ustanovka-billinga-abills-na-ubuntu-804-lts-server-mikrotik-router-os-v-kachestve-servera-dostupa/#comment-1177
на ubuntuserver 8.10. Все вроде как ровно усьтановилось, но вот в админку не пускает. Вообще кто нибудь ставил на Ubuntu-server 8.10 ? Хотелось бы совместными усилиями сделать подробное описание с указанием всех подводных камней.
Ubuntu 8.10, Ubuntu-server 8.10

Оффлайн Nesmit

  • Старожил
  • *
  • Сообщений: 1296
    • Просмотр профиля
Re: Настройка abills
« Ответ #10 : 14 Февраль 2009, 23:01:26 »
скорее всего, у тебя cgi не прописан в конфах апача, причем я там ненашел описания как это сделать.
http://gloomm.blogspot.com/2008/03/vpn-abills-ubuntu-710.html
я делал по этому описанию

Оффлайн salyery

  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Настройка abills
« Ответ #11 : 16 Февраль 2009, 09:30:23 »
Проблема решилась установкой прав для /usr/abills/cgi-bin.
"chown -Rf www-data:www-data /usr/abills/cgi-bin" почему-то криво отработал (или я что-то не понимаю), поправил права для всех cgi скриптов по отдельности и сразу все завелось.
Ubuntu 8.10, Ubuntu-server 8.10

Оффлайн Nesmit

  • Старожил
  • *
  • Сообщений: 1296
    • Просмотр профиля
Re: Настройка abills
« Ответ #12 : 16 Февраль 2009, 09:43:14 »
Если кто решит проблему с вопросиками в базе данных, кричите сразу!

Оффлайн kim007

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Настройка abills
« Ответ #13 : 17 Февраль 2009, 22:25:09 »
что касается базы данных
- один из косяков описания юзверей по установке абилса это неправильный путь переноса базы данных, забывают указывать путь mysql - u root -p abills < \usr\abills\......
-далее использование пользователя аbills в config.pl  , намного проще использовать пользователя root  - $conf{dbuser}='root'
- а вот если в логах ошибки апача вы увидите что то там со строкой 70 не пугайтесь лезте в этот файл, на самом деле в админку вы не попадаете из за неконекта базы данных, после того как залезли ищите строку 70 и прописывайте там истину, т.е. убирите скрипты и поставте четкие значения! не забудте что дбхост -localhost, а пользователь root

Оффлайн hackerochek

  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: Настройка abills
« Ответ #14 : 18 Февраль 2009, 00:25:31 »
Проблема решилась установкой прав для /usr/abills/cgi-bin.
"chown -Rf www-data:www-data /usr/abills/cgi-bin" почему-то криво отработал (или я что-то не понимаю), поправил права для всех cgi скриптов по отдельности и сразу все завелось.

напиши плиз как поправил права для всех cgi скриптов.
я пробывал:
chown -Rf www-data:www-data /usr/abills/cgi-bin/index.cgi и так все остальные но результат не изменился, я вижу исходный  текст файлов в браузере >:(

и кстати, ln -s /usr/abills/misc/abills_httpd.conf /etc/apache2/sites-enabled/abills_httpd.conf не помогло
я сделал так: ln -s /usr/abills/cgi-bin/ /var/www/abills - правильно ли я сделал?
 :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D
ПРОБЛЕМУ РЕШИЛ!!!
удалил ссылки!!!
я сделал как сказано тут http://gloomm.blogspot.com/2008/03/vpn-abills-ubuntu-710.html :

Редактируем /etc/apache2/sites-enabled/000-default
<VirtualHost *> 
   DocumentRoot /usr/abills/cgi-bin/
    Alias /abills "/usr/abills/cgi-bin/"
    <Directory "/usr/abills/cgi-bin"> 
  <IfModule mod_rewrite.c> 
      RewriteEngine on   
        RewriteCond %{HTTP:Authorization} ^(.*)
       RewriteRule ^(.*) - [E=HTTP_CGI_AUTHORIZATION:%1] 
      Options Indexes ExecCGI SymLinksIfOwnerMatch   
     </IfModule>   
    AddHandler cgi-script .cgi   
    Options Indexes ExecCGI FollowSymLinks   
    AllowOverride none   
    DirectoryIndex index.cgi   
    #Options ExecCGI       
   <Files ~ "\.(db|log)$">     
     Order allow,deny       
    Deny from all     
  </Files> 
 </Directory>     
#Admin interface   
 <Directory "/usr/abills/cgi-bin/admin"> 
  AddHandler cgi-script .cgi   
   Options Indexes ExecCGI FollowSymLinks   
    AllowOverride none 
  DirectoryIndex index.cgi 
  order deny,allow 
  allow from all   
 </Directory>   
</VirtualHost>   
« Последнее редактирование: 18 Февраль 2009, 00:53:03 от hackerochek »

 

Страница сгенерирована за 0.074 секунд. Запросов: 22.