Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: CDMA модем Huawey ec226 есть проблема  (Прочитано 3918 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн YoS

  • Автор темы
  • Участник
  • *
  • Сообщений: 243
  • неординарен
    • Просмотр профиля
    • allUBUNTU
CDMA модем Huawey ec226 есть проблема
« : 03 Октябрь 2008, 13:39:46 »
если кто-то уже сталкивался с этим чудом пожалуйста помогите...
с первых дней владения этим творением китайской мысли, он не совсем корректно работает под линуксом.
проблемма первая:
после подключения модема, в  gnome-ppp пытаюсь опросить его... не всегда это получается, хотя в юсб устройствах он видится,
yos@yos-notebook:~$ lsusb
Bus 004 Device 002: ID 067b:2528 Prolific Technology, Inc.
Bus 004 Device 001: ID 0000:0000 
Bus 003 Device 004: ID 0bda:0116 Realtek Semiconductor Corp.
Bus 003 Device 001: ID 0000:0000 
Bus 002 Device 001: ID 0000:0000 
Bus 001 Device 005: ID 12d1:1001 Huawei Technologies Co., Ltd. E620 USB Modem
Bus 001 Device 004: ID 09da:8090 A4 Tech Co., Ltd
Bus 001 Device 001: ID 0000:0000 
Обычно пишет "модем не найден", но даже если и опросит модем то в dev/modem/ его не видно...
wvdialconf пишет следующее:
yos@yos-notebook:~$ wvdialconf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: S0   S1   S2   S3   
WvModem<*1>: Cannot get information for serial port.
ttyUSB0<*1>: ATQ0 V1 E1 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 Z -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyUSB0<*1>: Modem Identifier: ATI -- Manufacturer: +GMI: HUAWEI TECHNOLOGIES CO., LTD
ttyUSB0<*1>: Speed 9600: AT -- OK
ttyUSB0<*1>: Max speed is 9600; that should be safe.
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
WvModem<*1>: Cannot get information for serial port.
ttyUSB1<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyUSB1<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 9600 baud
ttyUSB1<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
WvModem<*1>: Cannot get information for serial port.
ttyUSB2<*1>: ATQ0 V1 E1 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 Z -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyUSB2<*1>: Modem Identifier: ATI -- Manufacturer: +GMI: HUAWEI TECHNOLOGIES CO., LTD
ttyUSB2<*1>: Speed 9600: AT -- OK
ttyUSB2<*1>: Max speed is 9600; that should be safe.
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found a modem on /dev/ttyUSB0.
Modem configuration written to /etc/wvdial.conf.
/etc/wvdial.conf<Warn>: Can't write '/etc/wvdial.conf.tmp6552': Permission denied
/etc/wvdial.conf<Warn>: Can't write '/etc/wvdial.conf' ('/etc/wvdial.conf'): Bad file descriptor
ttyUSB0<Info>: Speed 9600; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
ttyUSB2<Info>: Speed 9600; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
а wvdial пишет:
yos@yos-notebook:~$ wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot open /dev/modem: No such file or directory
--> Cannot open /dev/modem: No such file or directory
--> Cannot open /dev/modem: No such file or directory
как достичь нормальной работы модема?
И то что его не видно в dev/modem/ это нормально???

Оффлайн vadim-nsk

  • LoCo команда
  • Старожил
  • *
  • Сообщений: 1318
  • Жить надо так, как горит пламя!
    • Просмотр профиля
    • Linux в Новосибирске
Re: CDMA модем Huawey ec226 есть проблема
« Ответ #1 : 03 Октябрь 2008, 15:46:32 »
ну а почему бы wvdialconf через судо запустить? аналогично и c wvdial

Оффлайн Stalker

  • Участник
  • *
  • Сообщений: 118
    • Просмотр профиля
Re: CDMA модем Huawey ec226 есть проблема
« Ответ #2 : 03 Октябрь 2008, 17:04:00 »
Выполнить команду:
sudo ln -s /dev/ttyUSB0 /dev/modem

Оффлайн YoS

  • Автор темы
  • Участник
  • *
  • Сообщений: 243
  • неординарен
    • Просмотр профиля
    • allUBUNTU
Re: CDMA модем Huawey ec226 есть проблема
« Ответ #3 : 06 Октябрь 2008, 22:21:26 »
ну а почему бы wvdialconf через судо запустить? аналогично и c wvdial
не вижу смысла
 ??? тоже самое происходит, насколько я знаю эти команды и с обычными правами работают

Оффлайн YoS

  • Автор темы
  • Участник
  • *
  • Сообщений: 243
  • неординарен
    • Просмотр профиля
    • allUBUNTU
Re: CDMA модем Huawey ec226 есть проблема
« Ответ #4 : 06 Октябрь 2008, 22:45:35 »
Выполнить команду:
sudo ln -s /dev/ttyUSB0 /dev/modem
а вот эта команда кажется помогла... спасибо ;)

Оффлайн Meo

  • Любитель
  • *
  • Сообщений: 90
    • Просмотр профиля
Re: CDMA модем Huawey ec226 есть проблема
« Ответ #5 : 07 Октябрь 2008, 11:04:10 »
У меня никогда /dev/modem  по умолчанию в модем не попадало... Такое впечатление, что это устройство по умолчанию смотрит исключительно в COM1
Только либо по симлинку, либо по /dev/ttyXXX

Оффлайн YoS

  • Автор темы
  • Участник
  • *
  • Сообщений: 243
  • неординарен
    • Просмотр профиля
    • allUBUNTU
Re: CDMA модем Huawey ec226 есть проблема
« Ответ #6 : 16 Февраль 2009, 14:52:20 »
ситуация!!!
устаовил 8.10, модем ачал определятс как модем, все хорошо но после подключения к нэту рово через 3 сек дисконект... привожу журнал ниже.
--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L3DT#777
--> Waiting for carrier.
ATM1L3DT#777
CONNECT
--> Carrier detected.  Waiting for prompt.
~[7f]}#@!}!}!} }4}"}&} }*} } }#}$@#}%}&")}3Cyg~
--> PPP negotiation detected.
--> Starting pppd at Mon Feb 16 15:44:03 2009
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 6497
--> Using interface ppp0
--> Disconnecting at Mon Feb 16 15:44:04 2009
--> The PPP daemon has died: Authentication error.
--> We failed to authenticate ourselves to the peer.
--> Maybe bad account or password? (exit code = 19)
--> man pppd explains pppd error codes in more detail.
--> I guess that's it for now, exiting
--> The PPP daemon has died. (exit code = 19)
парольввожу правильно!

Оффлайн YoS

  • Автор темы
  • Участник
  • *
  • Сообщений: 243
  • неординарен
    • Просмотр профиля
    • allUBUNTU
Re: CDMA модем Huawey ec226 есть проблема
« Ответ #7 : 20 Февраль 2009, 10:32:54 »
проблема решена! просто установил соединение через wvdial, а через gnom ppp выкидывало почемуто...

Оффлайн vedavrata

  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
CDMA-модем Huawei EC226 (EVDO)
« Ответ #8 : 04 Март 2009, 22:55:18 »
если кто-то уже сталкивался с этим чудом пожалуйста помогите...
с первых дней владения этим творением китайской мысли, он не совсем корректно работает под линуксом.

wvdial пишет:
yos@yos-notebook:~$ wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot open /dev/modem: No such file or directory
--> Cannot open /dev/modem: No such file or directory
--> Cannot open /dev/modem: No such file or directory

как достичь нормальной работы модема?
И то что его не видно в dev/modem/ это нормально???

  Я поставил ubuntu час назад, :-) и первое что я попытался сделать - это выйти в интернет через такой же модем (EVDO "Интертелеком").

   После просмотра этого прекрасного форума и разных попыток мне таки удалось выйти в интернет, выполнив много команд, но, полагаю, решающими были эти:
lsusb
sudo  wvdialconf
sudo  ln -s /dev/ttyUSB0 /dev/modem
sudo  gedit  /etc/wvdial.conf                /* внёс номер, имя и пароль */
sudo  wvdial

    Я всё правильно сделал? :-)
    Я совсем не знаю ubuntu, :-) хотя работал в Solaris на уровне команд ls / pwd / cp / и так далее. Поэтому не до конца понимаю, что я сделал.
    Кстати, я их выполнят в терминале. Теперь, как я полагаю, мне достаточно запускать одну последнюю команду "sudo  wvdial", да? Стоит её повесить на кнопку (типа shortcut) в Panel ?
   
 
    Думаю, что этот набор команд подойдёт для любого USB-модема "Интертелекома" ?..
    Да?

   Теперь буду учиться выходать в интернет через модем PCMCIA (PC-card) и через КПК (CDMA-смартфон HTC 6800 Mogul)... :-)
« Последнее редактирование: 04 Март 2009, 22:56:54 от vedavrata »

Оффлайн YoS

  • Автор темы
  • Участник
  • *
  • Сообщений: 243
  • неординарен
    • Просмотр профиля
    • allUBUNTU
Re: CDMA модем Huawey ec226 есть проблема
« Ответ #9 : 05 Март 2009, 12:50:17 »
Цитировать
lsusb
sudo  wvdialconf
sudo  ln -s /dev/ttyUSB0 /dev/modem
sudo  gedit  /etc/wvdial.conf                /* внёс номер, имя и пароль */
sudo  wvdial
lsusb - с помощью этой команды ты увидел подключённые к машине ЮСБ устройства
wvdialconf - сконфигурировал настройки под твой модем
ln -s /dev/ttyUSB0 /dev/modem - в твоем случае срочка лишняя...
gedit  /etc/wvdial.conf - с этим ты сам разобрался  ;)
wvdial - собственно дозвон.

мне интересно пробовал ли ты подключится через gnome-ppp если да, то без ошибок ли...
и еще есть статейка по поводу модема этого... http://leolik.blogspot.com/2008/09/cdma.html там написано как подключать интерне при загрузке убунты

P.S. очень рад что тема не умела... если есть какието соображения по поводу этого модема, прошу отписыватся.
Очень рад что тема не умерла, а по прежнему актуальна

Оффлайн vedavrata

  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: CDMA модем Huawey ec226 есть проблема
« Ответ #10 : 10 Март 2009, 13:45:12 »
мне интересно пробовал ли ты подключится через gnome-ppp если да, то без ошибок ли...

Пробовал. Получилось. Только нужно заходить в "Настройки" и выбирать нужный /dev/ttyUSB , потому что gnome-ppp (если я правильно понял) всё время пытается на ttyUSB0, а модем может быть на USB1 или USB3...
Кроме того, он показывает Analog modem - надо менять на USB modem?
И обязательно ли менять скорость 9600 на 432000 ?

Даже не знаю, что лучше wvdial или gnome-ppp ...

Оффлайн koltin

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: CDMA модем Huawey ec226 есть проблема
« Ответ #11 : 11 Март 2009, 22:21:37 »
По моему лучше использовать gnomeppp. Это потому, что при загрузке система определяет этот модем на каком то определенном порту (у меня /dev/ttyUSB0), но в продолжении работы возможны проблеммы, при которых система теряет модем (например подключенный через длинный USB удлинитель) на несколько секунд, а потом находит его опять, но регистрирует под другим устройсвом (например у меня /dev/ttyUSB1). Файл wvdial.conf записан статически и птому в таком случае придется заново его редактировать и кроме того wvdial может вообще отказаться работать с другим портом. А gnomeppp как раз и выручает. Потерялся модем - отключился от сети , залез в настройки, указал обнаружение модема, утилита нашла новый порт, опять подключился и все - проблем нет.

Оффлайн vedavrata

  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: CDMA-модем Huawei EC226
« Ответ #12 : 22 Март 2009, 18:57:07 »
мне интересно пробовал ли ты подключится через gnome-ppp если да, то без ошибок ли...
P.S. Если есть какието соображения по поводу этого модема, прошу отписыватся.
Очень рад что тема не умерла, а по прежнему актуальна

Итак, добился, что через USB-модем (Huawei)  могу выйти в интернет ("Интертелеком") и через vwdial, и через gnome-ppp .
Ошибок нет.

Причём, что каждый раз не запускать через sudo нужно сделать (по советам форумов):

System -> Администрирование -> Пользователи и группы -> Unlock -> учётнаязапись ->
разрешаем  устанавливать соединения

Оффлайн volosatyjbabuin

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: CDMA модем Huawey ec226 есть проблема
« Ответ #13 : 17 Июль 2009, 12:43:59 »
Цитировать
lsusb
sudo  wvdialconf
sudo  ln -s /dev/ttyUSB0 /dev/modem
sudo  gedit  /etc/wvdial.conf                /* внёс номер, имя и пароль */
sudo  wvdial

проделал это.
Запускаю wvdial и вот что получается

--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT80922861139
--> Waiting for carrier.
ATDT80922861139
ERROR
--> Invalid dial command.
--> Disconnecting at Fri Jul 17 11:30:14 2009

Посоветуйте что нибудь пожалуйста

Пользователь решил продолжить мысль 17 Июль 2009, 09:34:30:
Проблему с набором номера решил. Надо было указать в wvdial.comf правильный телефон ( для peolenet #777)
модем приконнектился

вот вывод в терминал
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
CONNECT
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Fri Jul 17 12:01:46 2009
--> Pid of pppd: 17672
--> Using interface ppp0
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> local  IP address 94.248.16.36
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> remote IP address 77.109.0.225
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> primary   DNS address 77.109.1.8
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> secondary DNS address 77.109.1.9
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]

Но пинги на внешние сервера не идут
Сайты не открываются



Пользователь решил продолжить мысль 17 Июль 2009, 11:36:07:
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
CONNECT
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Fri Jul 17 12:01:46 2009
--> Pid of pppd: 17672
--> Using interface ppp0
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> local  IP address 94.248.16.36
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> remote IP address 77.109.0.225
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> primary   DNS address 77.109.1.8
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> secondary DNS address 77.109.1.9
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]

Пользователь решил продолжить мысль 17 Июль 2009, 13:37:04:
Форум режет сообщение

конец лога

d: пїЅпїЅпїЅпїЅ[10]i[01]
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> local  IP address 94.248.16.36
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> remote IP address 77.109.0.225
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> primary   DNS address 77.109.1.8
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
--> secondary DNS address 77.109.1.9
--> pppd: пїЅпїЅпїЅпїЅ[10]i[01]
« Последнее редактирование: 17 Июль 2009, 13:37:04 от volosatyjbabuin »

Оффлайн YoS

  • Автор темы
  • Участник
  • *
  • Сообщений: 243
  • неординарен
    • Просмотр профиля
    • allUBUNTU
Re: CDMA модем Huawey ec226 есть проблема
« Ответ #14 : 20 Июль 2009, 11:14:42 »
так я не понял, проблема решена? или гдето здесь нужно искать вопрос?

 

Страница сгенерирована за 0.073 секунд. Запросов: 22.