Форум русскоязычного сообщества Ubuntu


Автор Тема: Не изменяются настройки GlyphCache (кэш символов) на NVIDIA  (Прочитано 1127 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн levne

  • Автор темы
  • Любитель
  • *
  • Сообщений: 60
    • Просмотр профиля
Ужасно долго мучился с дровами к NVIDIA 8400M , все равно работает из рук вон, но сейчас дело немного не в этом. Волнует такой вопрос:
на многих сайтах (в частности, тут: http://www.nvnews.net/vbulletin/showthread.php?t=72490 )

Для улучшения производительности 2D (которое тормозит нещадно при прокрутке везде, где только можно) советуют ввести команду

 
Цитировать
nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1

'InitialPixmapPlacement' устанавливается нормально, а вот  GlyphCache выдает вот такую ошибку:
Цитировать
ERROR: Error parsing assignment 'GlyphCache=1' (Unrecognized attribute name).

Гуглировал даже по-английски ничего не нашел.
Я так понимаю, эта комманда напрямую отосится к отображению шрифтов (а у меня как раз в ООо косяки при прокрутке страшные).

Кто-нибудь знает, что это за GlyphCache и как его заставить работать?

Спасибо.


« Последнее редактирование: 13 Октябрь 2008, 18:18:24 от levne »

Оффлайн levne

  • Автор темы
  • Любитель
  • *
  • Сообщений: 60
    • Просмотр профиля
Re: Не работает GlyphCache (кэш символов) на NVIDIA
« Ответ #1 : 12 Октябрь 2008, 20:42:02 »
Еще прочел тут сегодня что для работы GlyphCache ЯКОБЫ нужен драйвер 171.06
or 173.08 (кажется бета), а у меня 177.80 - как вы думаете, это правда? Не хочется просто опять эксперименты ставить и дрова менять в 10 раз, да еще и на бету... а Глифкэш бы хотелось.......

Оффлайн nextlife

  • Активист
  • *
  • Сообщений: 444
    • Просмотр профиля
Re: Не работает GlyphCache (кэш символов) на NVIDIA
« Ответ #2 : 22 Октябрь 2008, 14:22:31 »
Еще прочел тут сегодня что для работы GlyphCache ЯКОБЫ нужен драйвер 171.06
or 173.08 (кажется бета), а у меня 177.80 - как вы думаете, это правда? Не хочется просто опять эксперименты ставить и дрова менять в 10 раз, да еще и на бету... а Глифкэш бы хотелось.......
У тебя и так самое свежее.

"производительности 2D (которое тормозит нещадно при прокрутке везде, где только можно)" - есть такое при прокрутке
Kool Desktop Environment (KDE)

Оффлайн levne

  • Автор темы
  • Любитель
  • *
  • Сообщений: 60
    • Просмотр профиля
Я понимаю, что у меня самое свежее. Я не понимаю, почему не меняется ГлифКэш, который советуют поменять на сайте НВИДИА, чтобы решить проблему с 2Д

Оффлайн nextlife

  • Активист
  • *
  • Сообщений: 444
    • Просмотр профиля
Я понимаю, что у меня самое свежее. Я не понимаю, почему не меняется ГлифКэш, который советуют поменять на сайте НВИДИА, чтобы решить проблему с 2Д

ERROR: Error parsing assignment 'GlyphCache=1' (Unrecognized attribute name).
получается что нет такого параметра GlyphCache v 177.80
Kool Desktop Environment (KDE)

Оффлайн levne

  • Автор темы
  • Любитель
  • *
  • Сообщений: 60
    • Просмотр профиля
мне кажется, что там вообще нет ГлифКэша - или он у меня отключен  - потому что то же самое выдает и при простом запросе о значении ГлифКэш

Оффлайн nextlife

  • Активист
  • *
  • Сообщений: 444
    • Просмотр профиля
мне кажется, что там вообще нет ГлифКэша - или он у меня отключен  - потому что то же самое выдает и при простом запросе о значении ГлифКэш
Klevo sidet voobshe bez draiverov. Siju poka pod vesa. voobshe ni4ego ne tormozit! :o
Kool Desktop Environment (KDE)

Оффлайн nextlife

  • Активист
  • *
  • Сообщений: 444
    • Просмотр профиля
http://techbase.kde.org/User:Lemma/KDE4-NVIDIA

Актуально и для ubuntu.
GlyphCache использование
Kool Desktop Environment (KDE)

Оффлайн levne

  • Автор темы
  • Любитель
  • *
  • Сообщений: 60
    • Просмотр профиля
Глифкэш неожиданно заработал (сам не знаю почему - ничего не менял)  - но  проблем с графикой это не решает(

Оффлайн nextlife

  • Активист
  • *
  • Сообщений: 444
    • Просмотр профиля
Глифкэш неожиданно заработал (сам не знаю почему - ничего не менял)  - но  проблем с графикой это не решает(
Странно, у меня с 2D проблеммы решились, правда раздражает что батарея на ноутбуке быстро садится...
Kool Desktop Environment (KDE)

Оффлайн levne

  • Автор темы
  • Любитель
  • *
  • Сообщений: 60
    • Просмотр профиля
У меня по-прежнему "подмаргивает" изображение при прокрутке и в видео. Косяки в ООо еще не проверял.

Оффлайн ntrl

  • Любитель
  • *
  • Сообщений: 59
  • Ubuntu 8.10
    • Просмотр профиля
У меня 8400М G и драйвера 177.80. GlyphCache выставился сразу.
На том же форуме (http://www.nvnews.net/vbulletin/showthread.php?t=118088) ещё советуют добавить в xorg.conf в секцию screen
два параметра:
Option "PixmapCacheSize" "1000000"
Option "AllowSHMPixmaps" "0"
Пробовали? Причем значение первого можно увеличить, у меня сейчас не 1000000, а 2500000.
При прокрутке ни в FF, ни в OOo морганий не наблюдаю.
Хотя не скажу что всё летает, но вполне приемлемо...

PS: да, и надо не забыть куда-нибудь в автозагрузку запихать строку
# nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1чтобы каждый раз не набирать.
я в .gnomerc добавил
« Последнее редактирование: 03 Ноябрь 2008, 18:02:00 от ntrl »

 

Страница сгенерирована за 0.06 секунд. Запросов: 22.