Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Компиляция - просит дополнительные библиотеки  (Прочитано 1710 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн APACHE

  • Автор темы
  • Участник
  • *
  • Сообщений: 169
  • Windows 7
    • Просмотр профиля
apache@apache-desktop:~$ cd Программы
apache@apache-desktop:~/Программы$ cd gtk+-2.14.0
apache@apache-desktop:~/Программы/gtk+-2.14.0$ aclocal
configure.in:154: warning: macro `AM_DISABLE_STATIC' not found in library
configure.in:186: warning: macro `AM_PROG_LIBTOOL' not found in library
configure.in:492: warning: macro `AM_GLIB_GNU_GETTEXT' not found in library
configure.in:498: warning: macro `AM_GLIB_DEFINE_LOCALEDIR' not found in library
configure.in:567: warning: macro `AM_PATH_GLIB_2_0' not found in library
apache@apache-desktop:~/Программы/gtk+-2.14.0$

Как добавлять эти библиотеки?

Оффлайн MooSE

  • Активист
  • *
  • Сообщений: 911
    • Просмотр профиля
1. Может не надо их исходников ставить то, что есть в репоизтории?

2. Если уж совсем прижало - постарайся понять что именно оно хочет. Так например AM_PROG_LIBTOOL скорее всего есть в libtool или в libltdl7-dev

Оффлайн APACHE

  • Автор темы
  • Участник
  • *
  • Сообщений: 169
  • Windows 7
    • Просмотр профиля
1. Ну просто проблема возникла не в первый раз. Да и из исходников, как я понимаю, я получаю новейшее ПО нежели из репов.
2. Понятно, вроде удалось найти нужные пакеты через гугл.

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
-dev пакеты ставь, будет достаточно. И читай иногда прикреплённые темы.

Если хочется экстрима, новейшее ПО уже собрано в Jaunty (9.04).

Оффлайн Yurror

  • Старожил
  • *
  • Сообщений: 1966
    • Просмотр профиля
APACHE, открой для себя Gentoo =)

Оффлайн APACHE

  • Автор темы
  • Участник
  • *
  • Сообщений: 169
  • Windows 7
    • Просмотр профиля
Ну я экстрима не до такой степени хочу, чтобы беты ставить. Просто, скажем, тот же Pidgin в репах версии 2,5,2, а в исходниках на сайте 2,5,4. Netbeans 6.1,а на сайте можно скачать sh пакет версии 6,5.

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
APACHE
gedit 2.5.4 есть на getdeb.net
Netbeans - качаешь какой надо и ставишь, и никаких гвоздей.

То же самое можно провернуть ещё с кучей софта, начиная от всяких фаерфоксов и заканчивая ОО.о со товарищи ;)

 

Страница сгенерирована за 0.06 секунд. Запросов: 24.