Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: камера Logitech QuickCam Express под Ubuntu 8.10  (Прочитано 813 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tricky

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
камера Logitech QuickCam Express под Ubuntu 8.10
« : 23 Февраль 2009, 13:01:20 »
Всем доброго времени суток!
У меня возникла следующая проблема, надеюсь, что что-нибудь мне подскажете )

Не получается заставить работать камеру Logitech QuickCam Express под Ubuntu 8.10

Камера определятся и определялась с самого начала, lsusb показывал следующее:

Bus 002 Device 002: ID 046d:0840 Logitech, Inc. QuickCam Express

После этого установил из репозитория gspca-source (sudo aptitude install gspca-source), затем распаковал и вышло следующее:

trciky@tricky-desktop:/usr/src/modules/gspca

Conexant   decoder       gspca.h       Mars-Semi         Sunplus       Vimicro
cutlog.py  Etoms         license       Pixart            Sunplus-jpeg
changelog  gspca_build   Makefile      READ_AND_INSTALL  Transvision
debian     gspca_core.c  Makefile.kld  Sonix             utils

затем делаю sudo make, но оканчивается ошибкой

make[2]: *** [/usr/src/modules/gspca/gspca_core.o] Error 2
make[1]: *** [_module_/usr/src/modules/gspca] Error 2
make[1]: se sale del directorio `/usr/src/linux-headers-2.6.27-7-generic'
make: *** [default] Error 2

(хедеры ядра 2.6.27-7 (моего действующего - из uname -a) установил заранее - установились из репозитория без проблем)

Затем взял версию с sourge forge (тоже сорсы), скомпилил, подгрузил модуль в ядро, а камера все-равно не работает

Вот вывод некоторых пунтов из lsmod
Module                  Size  Used by

videodev               41344  1 quickcam
v4l1_compat            22404  1 videodev

usbcore               148848  5 quickcam,usbhid,ohci_hcd,ehci_hcd

В чем может быть проблема? Жду вашего совета, заранее спасибо!

P.S.:
есть работающий драйвер только под виндус, существует ли что-нибудь для виндусовых драйверов камер под линукс  как  ndiswrapper для wifi?
« Последнее редактирование: 23 Февраль 2009, 13:48:36 от tricky »

Оффлайн t2a

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: камера Logitech QuickCam Express под Ubuntu 8.10
« Ответ #1 : 23 Февраль 2009, 15:30:26 »
"Не получается заставить работать камеру Logitech QuickCam Express под Ubuntu 8.10"

Здесь http://jeffrasmussen.wordpress.com/2009/02...ickcam-express/ смотрели ?

Оффлайн tricky

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: камера Logitech QuickCam Express под Ubuntu 8.10
« Ответ #2 : 28 Февраль 2009, 19:06:55 »
t2a, огромное Вам спасибо, Вы, наверное, имели в виду следующую ссылку, да? http://jeffrasmussen.wordpress.com/2009/02/04/ubuntu-quickcam-express/
действительно все скомпилилось, ошибки при make больше не вызвало, другое дело, что до сих пор не могу проверить, работает ли камера, друг утащил к себе под винду и не возвращает...

СПАСИБО!

Оффлайн ubuntar

  • Участник
  • *
  • Сообщений: 129
  • Qui quaerit, reperit
    • Просмотр профиля
Re: камера Logitech QuickCam Express под Ubuntu 8.10
« Ответ #3 : 07 Март 2009, 22:39:20 »
Ещё вот тут погляди,это официальный сайт Logitech,посвящённый opensource. http://www.quickcamteam.net/

 

Страница сгенерирована за 0.08 секунд. Запросов: 23.