Форум русскоязычного сообщества Ubuntu


Автор Тема: Emacs + python-mode : не работают отступы  (Прочитано 887 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн chainreaction

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Здравствуйте!

Проблемма в том, что python-mode не делает автоматических отступов на следующей строчке после определения функций. Более того, при нажатии кнопки отступа в минибуфере появляется сообщение
sole identation и ничего не происходит.

Такое впечатление, что я что-то основное упускаю из виду. Хотя про эту проблемму я читал в сообщениях в сети, но решения или способа как делать отступ правильно не нашел.
« Последнее редактирование: 27 Март 2009, 16:51:48 от chainreaction »

Оффлайн K_E_S_T

  • Участник
  • *
  • Сообщений: 198
  • пси][опат
    • Просмотр профиля
Re: Emacs + python-mode : не работают отступы
« Ответ #1 : 31 Март 2009, 20:09:40 »
хм.... раз такое дело то могу лишь предложить попробовать скопипастить таб.... хотя это тоже может не сработать.... да и извращенство это :)

Оффлайн chainreaction

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Emacs + python-mode : не работают отступы
« Ответ #2 : 01 Апрель 2009, 21:03:27 »
А вы тоже с этим режимом работаете?

Оффлайн K_E_S_T

  • Участник
  • *
  • Сообщений: 198
  • пси][опат
    • Просмотр профиля
Re: Emacs + python-mode : не работают отступы
« Ответ #3 : 02 Апрель 2009, 14:07:30 »
не, я щас C++ учу вместе с Qt

Оффлайн kermit

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Emacs + python-mode : не работают отступы
« Ответ #4 : 03 Апрель 2009, 21:48:55 »
во время установки python-mode было сообщение примерно такого содержания: "emacs22 includes it's own python-mode, skipping installation"??

 

Страница сгенерирована за 0.083 секунд. Запросов: 24.