Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Проблемы с базовым компилстором GCC [РЕШЕНО]  (Прочитано 2757 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alonan

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Народ с недавно решил зансться програмированием под линукс но даже самую простую програму на Си не смог скомпилировать после команды маке мне выдаёться ошибка компиляции обьссните мне что не так а может надо чегонибудь доустонавливать если да то как и откуда
вот код програмы которую с пытался скомпилить:
main()
{
printf("Hello World");
}

пробовали так:
#include <stdio.h>
main()
{
printf("Hello World");
}

Даже так попробовал:
#include <stdio.h>
int main(void)
{
printf("Hello world!\n");
return(0);
}
но увы ни какого результата с так и не наблюдал кроме ошибок конечно(
Действис происходст в Ubuntu 6.10
« Последнее редактирование: 26 Ноябрь 2006, 17:06:16 от doctor »

Оффлайн h8

  • Активист
  • *
  • Сообщений: 395
    • Просмотр профиля
Re: Проблемы с базовым компилстором GCC
« Ответ #1 : 25 Ноябрь 2006, 16:23:03 »
Телепаты как обычно в отпуске ))) Вывод компилстора надо прилагать, а то так непонятно ведь на что он ругается. И какой командой собираешь прогу?
Ubuntu 11.04 / MacOS X 10.6

Оффлайн alonan

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Проблемы с базовым компилстором GCC
« Ответ #2 : 26 Ноябрь 2006, 12:24:14 »
Вот окно терминала:
alonan@nightcon-laptop:~$ make prog
cc     prog.c   -o prog
prog.c:1:19: error: stdio.h: No such file or directory
prog.c: In function ‘main’:
prog.c:4: warning: incompatible implicit declaration of built-in function ‘printf’
make: *** [prog] Ошибка 1
alonan@nightcon-laptop:~$ gcc prog.c
prog.c:1:19: error: stdio.h: No such file or directory
prog.c: In function ‘main’:
prog.c:4: warning: incompatible implicit declaration of built-in function ‘printf’
alonan@nightcon-laptop:~$



Оффлайн Bonta-Kun

  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Re: Проблемы с базовым компилстором GCC
« Ответ #3 : 26 Ноябрь 2006, 14:01:00 »
apt-get install libc6-dev
/*GNU C Library: Development Libraries and Header Files*/
Windows 2000 SP4 + all updates ^____^

Оффлайн alonan

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Проблемы с базовым компилстором GCC
« Ответ #4 : 26 Ноябрь 2006, 15:33:14 »
попробовал твой вариант но он мне выдал что не может установить данный покет
Вот вывоод из терминала
alonan@nightcon-laptop:~$ sudo apt-get install libc6-dev
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Reading state information... Готово                       
Некоторые пакеты невозможно установить. Возможно, Вы просите невозможного,
или же используете нестабильного дистрибутив, и запрошенные Вами пакеты
ещё не созданы или были удалены из Incoming.

Так как Вы просили выполнить только одну операцию, то веростнее всего, что
пакет просто не может быть установлен из-за ошибок в самом пакете.
Необходимо послать отчёт об  этой ошибке.
Следующас информация возможно поможет Вам:

Пакеты, имеющие неудовлетворённые зависимости:
  libc6-dev: Зависит: libc6 (= 2.3.6-0ubuntu20) но 2.4-1ubuntu12 будет установлен
E: Сломанные пакеты


Оффлайн Bonta-Kun

  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Re: Проблемы с базовым компилстором GCC
« Ответ #5 : 26 Ноябрь 2006, 15:55:42 »
дело в зависимостсх, для удобства запусти synaptic и установи этот пакет, у мс та же ОС и с его установил
Windows 2000 SP4 + all updates ^____^

Оффлайн alonan

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Проблемы с базовым компилстором GCC
« Ответ #6 : 26 Ноябрь 2006, 15:56:45 »
Щас попробую но не уверен что получеться

Оффлайн alonan

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Проблемы с базовым компилстором GCC
« Ответ #7 : 26 Ноябрь 2006, 16:05:16 »
вот что мне выдал Synaptic :
Не возможно отметить все пакеты для или обновленис
Следующие пакеты имеют неразрешимые зависимости
Убедитесь в том что все необходимые репозитории добавлены и включены в настройках

libc6-dev:
  Зависит: libc6 (=2.3.6-0ubuntu20) но 2.4-1ubuntu12 установлен



Оффлайн alonan

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Проблемы с базовым компилстором GCC
« Ответ #8 : 26 Ноябрь 2006, 16:57:36 »
проблема решена проблема заключалась в том что с изменял сорс лист теперь с востановил обратно базовый сорс лист и все библиотеки скачались как надо и установилсь без проблем.
GCC  компилирует и всё работает замечательно :D

Оффлайн alonan

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Проблемы с базовым компилстором GCC [РЕШЕНО]
« Ответ #9 : 26 Ноябрь 2006, 17:00:54 »
Всем огромное спасибо особенно Bonta-Kun потомучто именно он навёл меня на мысль востановить старый сорс лист))))

Оффлайн doctor

  • Активист
  • *
  • Сообщений: 736
  • не навреди...
    • Просмотр профиля
Re: Проблемы с базовым компилстором GCC
« Ответ #10 : 26 Ноябрь 2006, 17:05:48 »
ну и написал бы в названии топика "РЕШЕНО".... соответственно закрываю топик, раз так все удачно

 

Страница сгенерирована за 0.056 секунд. Запросов: 24.