Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Монтирование USB-HDD  (Прочитано 6975 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kush

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Монтирование USB-HDD
« : 14 Сентября 2009, 00:03:41 »
Всех приветствую, помогите разобраться в следующей проблеме, имеется USB-HDD 160Gb с двумя разделами - Mdisk1 , Mdisk2.
fdisk -l показывает следующее:

Диск /dev/sda: 320.0 ГБ, 320072933376 байт
255 heads, 63 sectors/track, 38913 cylinders
Units = цилиндры of 16065 * 512 = 8225280 bytes
Disk identifier: 0xabfaaa4e

Устр-во Загр     Начало       Конец       Блоки   Id  Система
/dev/sda1   *           1        2611    20972826    7  HPFS/NTFS
/dev/sda2            2612       36550   272615016    7  HPFS/NTFS
/dev/sda3           36551       38913    18980797+   5  Расширенный
/dev/sda5           36551       36824     2200873+  82  Linux своп / Solaris
/dev/sda6           36825       38913    16779861   83  Linux

Диск /dev/sdb: 160.0 ГБ, 160041885696 байт
255 heads, 63 sectors/track, 19457 cylinders
Units = цилиндры of 16065 * 512 = 8225280 bytes
Disk identifier: 0x5aa14298

Устр-во Загр     Начало       Конец       Блоки   Id  Система
/dev/sdb1   *           1        2611    20972826    7  HPFS/NTFS
/dev/sdb2            2612       19457   135315492+   7  HPFS/NTFS


Так вот, при подключении диска автоматически происходит монтирование первого раздела sdb1 (Mdisk1) без каких либо проблем, а на второй раздел (Mdisk2) выдает ошибку


и меня смущает то, что там упоминается про раздел sda2 (MEDIA), хотя должен быть sdb2 (Mdisk2). Что же это значит и как можно исправить??? С нетерпение жду советов. PS: MEDIA - это раздел основного жесткого диска. O/S UBUNTU 9.04 Проблема случилась неожиданно, ранее все подключалось нормально.

Пользователь решил продолжить мысль 14 Сентября 2009, 01:17:18:
Упс, извиняюсь, видимо глюк какой-то был, сейчас выскакивает эта же ошибка, но раздел определяет правильно sdb2, тогда просто подскажите как сделать чтобы нормально монтировался раздел?
« Последнее редактирование: 14 Сентября 2009, 01:17:18 от Kush »

Оффлайн zilog82

  • Активист
  • *
  • Сообщений: 420
  • Hello, World!!!
    • Просмотр профиля
Re: Монтирование USB-HDD
« Ответ #1 : 14 Сентября 2009, 07:46:33 »
blkid покажите.
насколько я понял, у Вас на sda находится система, а усбшный винт - sdb.  у Вас не монтируется sdb2. Попробуйте его из консоли
#mount -t ntfs-3g -o force /dev/sdb2 /media/MountPoint

Оффлайн Kush

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Re: Монтирование USB-HDD
« Ответ #2 : 14 Сентября 2009, 10:41:36 »
Из консоли монтируется, но происходит какой-то глюх с разделом sda2, он пропадает и его тоже приходится монтировать вручную. Что же все-таки мешает присоединяться тому sdb2 в автоматическом режиме после подкл usb-hdd?

Оффлайн zilog82

  • Активист
  • *
  • Сообщений: 420
  • Hello, World!!!
    • Просмотр профиля
Re: Монтирование USB-HDD
« Ответ #3 : 14 Сентября 2009, 13:09:29 »
вот так вот сам и пропадает?! осветите все, что делаете в консоли. и как пропадает раздел. заодно прикрепите dmesg. что-то уж совсем странно. кстати, вывод blkid все же хотелось бы увидеть.

Оффлайн Kush

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Re: Монтирование USB-HDD
« Ответ #4 : 14 Сентября 2009, 13:31:36 »
dmesg выдает следующее:

[11571.230591] Initializing USB Mass Storage driver...
[11571.232287] scsi5 : SCSI emulation for USB Mass Storage devices
[11571.232647] usbcore: registered new interface driver usb-storage
[11571.232653] USB Mass Storage support registered.
[11571.233660] usb-storage: device found at 5
[11571.233666] usb-storage: waiting for device to settle before scanning
[11576.232851] usb-storage: device scan complete
[11576.239516] scsi 5:0:0:0: Direct-Access     SAMSUNG  HM160HI               PQ: 0 ANSI: 2
[11576.243405] sd 5:0:0:0: [sdb] 312581808 512-byte hardware sectors: (160 GB/149 GiB)
[11576.253799] sd 5:0:0:0: [sdb] Write Protect is off
[11576.253807] sd 5:0:0:0: [sdb] Mode Sense: 38 00 00 00
[11576.253812] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[11576.255672] sd 5:0:0:0: [sdb] 312581808 512-byte hardware sectors: (160 GB/149 GiB)
[11576.263204] sd 5:0:0:0: [sdb] Write Protect is off
[11576.263211] sd 5:0:0:0: [sdb] Mode Sense: 38 00 00 00
[11576.263216] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[11576.263226]  sdb: sdb1 sdb2
[11576.871921] sd 5:0:0:0: [sdb] Attached SCSI disk
[11576.872049] sd 5:0:0:0: Attached scsi generic sg2 type 0


blkid:

/dev/sda1: UUID="A09C21929C21644E" LABEL="SYSTEM" TYPE="ntfs"
/dev/sda2: UUID="26E845EAE845B8B7" LABEL="MEDIA" TYPE="ntfs"
/dev/sda5: TYPE="swap" UUID="1a8ce3c3-8902-4dc4-8093-07a102425f27"
/dev/sda6: UUID="b0feff44-d777-43ce-8ab8-839d37e7f375" TYPE="ext3"


Сейчас попробовал еще раз из консоли подключить, удалось без казусов, все работает... Если все таки можно как-то настроить чтобы он при подключении автоматически монтировался, как и первый раздел, то был бы очень вам благодарен за помощь ;-)


Пользователь решил продолжить мысль 14 Сентября 2009, 09:49:14:
Вот как пропадает том sda2 (MEDIA) , когда я пытаюсь отсоединить раздел sdb2, а исчезает sda2. Отсоединяю через контекстное меню - отсоединить том. sdb2 по прежнему остается доступным.

Пользователь решил продолжить мысль 14 Сентября 2009, 12:10:24:
если отсоединять через консоль, то такого глюка не происходит, все отсоединяется четко...

Пользователь решил продолжить мысль 14 Сентября 2009, 14:10:53:
если отсоединять через консоль, то такого глюка не происходит, все отсоединяется четко...
« Последнее редактирование: 14 Сентября 2009, 14:10:53 от Kush »

 

Страница сгенерирована за 0.045 секунд. Запросов: 23.