Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Приглашаются программисты в проект EiskaltDC++  (Прочитано 6966 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля


Оффлайн L0z4

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Eiskalt уже обогнал, по моему скромному мнению, все остальные дц клиенты под линух в плане удобств использования и функционала. Единственно НО - unstable версия уж очень любит падать от обновления к обновлению.

Оффлайн Tehnick_

  • Любитель
  • *
  • Сообщений: 65
    • Просмотр профиля
    • tehnick-8.narod.ru
Сегодня официально состоялся первый стабильный релиз EiskaltDC++ 2.0. Теперь можно на форуме начать новую ветку или обновить информацию в этой.
« Последнее редактирование: 22 Март 2010, 20:53:24 от Tehnick_ »

Оффлайн Viglim

  • Любитель
  • *
  • Сообщений: 57
    • Просмотр профиля
Большое спасибо, только с зваисимостями какая-то беда. У меня вот не запускается : ругается

eiskaltdcpp: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by eiskaltdcpp)

файл этот имеется.

Оффлайн Yurror

  • Старожил
  • *
  • Сообщений: 1966
    • Просмотр профиля
ага, имеется только у тебя он собран гораздо более свежим компилятором. eiskaltdcpp собран чем-то допотопным. например g++ 3.4

Оффлайн Tehnick_

  • Любитель
  • *
  • Сообщений: 65
    • Просмотр профиля
    • tehnick-8.narod.ru
eiskaltdcpp собран чем-то допотопным. например g++ 3.4
Ошибаешься: http://packages.ubuntu.com/karmic/gcc => gcc версии 4.4.1
Программа из пакета работает во всех заявленных версиях убунты и дебиана.
Проверено лично.

Оффлайн Yurror

  • Старожил
  • *
  • Сообщений: 1966
    • Просмотр профиля
Tehnick_, не пробовал вообще его запускать но вот строчка
eiskaltdcpp: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by eiskaltdcpp)
наводит на мысль... и пакеты из бубунты здесь ни при чем. речь о том каким компилятором был собран бинарник eiskaltdcpp и с какой библиотекой
а в репозитарии я знаю что лежит в этом то видимо и проблема, что оно сильно новее чем надо бинарю
Viglim, пересобирайте на своей системе и будет работать

Оффлайн Tehnick_

  • Любитель
  • *
  • Сообщений: 65
    • Просмотр профиля
    • tehnick-8.narod.ru
Tehnick_, не пробовал вообще его запускать но вот строчка
eiskaltdcpp: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by eiskaltdcpp)
наводит на мысль... и пакеты из бубунты здесь ни при чем. речь о том каким компилятором был собран бинарник eiskaltdcpp и с какой библиотекой
а в репозитарии я знаю что лежит в этом то видимо и проблема, что оно сильно новее чем надо бинарю
Viglim, пересобирайте на своей системе и будет работать
Пакеты были собраны на ланчпаде, в стандартном окружении yбyнтy кармик. Я выше указал, каким компилятором был собран бинарник... В остальном ты прав.

Viglim, указать версию вашей системы было бы нелишним.

Пользователь решил продолжить мысль 24 Март 2010, 00:18:07:
Большое спасибо, только с зваисимостями какая-то беда. У меня вот не запускается : ругается
eiskaltdcpp: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by eiskaltdcpp)
файл этот имеется.

Выполни:
strings /usr/lib/libstdc .so.6 | grep GLIBУ меня:
$ strings /usr/lib/libstdc++.so.6 | grep GLIB
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBC_2.0
GLIBC_2.3
GLIBC_2.1
GLIBC_2.1.3
GLIBC_2.3.2
GLIBC_2.2
GLIBCXX_FORCE_NEW
GLIBCXX_DEBUG_MESSAGE_LENGTH

У тебя же очевидно GLIBCXX_3.4.11 не хватает. И пакет libstdc++6 придется обновить, если не хочешь пересобрать пакет самостоятельно. Что на самом деле несложно...
« Последнее редактирование: 24 Март 2010, 00:18:07 от Tehnick_ »

Оффлайн Viglim

  • Любитель
  • *
  • Сообщений: 57
    • Просмотр профиля
У меня ubuntu 9.04. libstdc++ самый свежий из реп. ну ладно, не велика беда -- сам соберу.

Оффлайн Tehnick_

  • Любитель
  • *
  • Сообщений: 65
    • Просмотр профиля
    • tehnick-8.narod.ru
Начиная с сегодняшнего дня в моем PPA на ланчпаде будут собираться пакеты в родных окружениях Lucid, Karmic и Jaunty. Таких проблем больше не возникнет. Рекомендую исправить адрес и обновиться тем у кого стоит не Ubuntu Karmic.

Оффлайн Tehnick_

  • Любитель
  • *
  • Сообщений: 65
    • Просмотр профиля
    • tehnick-8.narod.ru
Re: Приглашаются программисты в проект EiskaltDC++
« Ответ #26 : 02 Апрель 2010, 01:44:07 »
Для Jaunty у кого-нибудь собралось? А то у меня на лачнпаде был сломанный пакет, но мне никто об этом не догадался сразу написать...

UPD: проблема была в правилах для cmake, в ревизии 631 она решена.

PS: если кому здесь интересно, в ревизии 624 сделал панель быстрого поиска
« Последнее редактирование: 06 Апрель 2010, 15:35:35 от Tehnick_ »

Оффлайн Tehnick_

  • Любитель
  • *
  • Сообщений: 65
    • Просмотр профиля
    • tehnick-8.narod.ru
Re: Приглашаются программисты в проект EiskaltDC++
« Ответ #27 : 19 Апрель 2010, 22:26:55 »
EiskaltDC++ 2.0.1 релизнулся. Обновляйтесь. ChangeLog_ru.txt

Оффлайн Viglim

  • Любитель
  • *
  • Сообщений: 57
    • Просмотр профиля
Re: Приглашаются программисты в проект EiskaltDC++
« Ответ #28 : 22 Апрель 2010, 13:08:22 »
>Начиная с сегодняшнего дня в моем PPA на ланчпаде будут собираться пакеты в родных окружениях Lucid, Karmic и Jaunty. Таких проблем больше не возникнет. >Рекомендую исправить адрес и обновиться тем у кого стоит не Ubuntu Karmic.

Отлично. Теперь не ругается.

Оффлайн Tehnick_

  • Любитель
  • *
  • Сообщений: 65
    • Просмотр профиля
    • tehnick-8.narod.ru
Re: Приглашаются программисты в проект EiskaltDC++
« Ответ #29 : 24 Апрель 2010, 00:51:19 »
Появилась сборка eiskaltdcpp-unstable для intrepid. Эти пакеты так же подходят для debian lenny.

 

Страница сгенерирована за 0.124 секунд. Запросов: 24.