Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: ZTE MF626 и Ubuntu 9.10  (Прочитано 6935 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sht0rm

  • Старожил
  • *
  • Сообщений: 3397
    • Просмотр профиля
Re: ZTE MF626 и Ubuntu 9.10
« Ответ #15 : 18 Март 2010, 16:52:02 »
Всем привет ))
....
NetworkManager прекрасно умеет работать с 3G модемами

nigametianov

  • Гость
Re: ZTE MF626 и Ubuntu 9.10
« Ответ #16 : 18 Март 2010, 18:20:43 »
Ни фига подобного....
На 9.04 все подключалось через NM автоматом
В 9.10 даже не видит этот модем, хотя Nokia подключается нормально
тока ч-з vwdial, но как часы, вот мой конфиг
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 18 Март 2010, 18:23:05 от nigametianov »

Оффлайн jad81

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: ZTE MF626 и Ubuntu 9.10
« Ответ #17 : 19 Март 2010, 10:42:36 »
Да на 9.10 NM в упор не видит модем ZTE 626  :(
Спасибо за конфиг, сегодня попробую к Билайну применить :)

vwdial запускать от юзера или от root ?

У меня сейчас модем коннектится и сразу дисконект и процесс останавливается, а под root после дисконекта идет переподключение через 5 10 15 20 сек и т.д.

nigametianov

  • Гость
Re: ZTE MF626 и Ubuntu 9.10
« Ответ #18 : 19 Март 2010, 12:59:55 »
Да на 9.10 NM в упор не видит модем ZTE 626  :(
Спасибо за конфиг, сегодня попробую к Билайну применить :)

vwdial запускать от юзера или от root ?

У меня сейчас модем коннектится и сразу дисконект и процесс останавливается, а под root после дисконекта идет переподключение через 5 10 15 20 сек и т.д.

я пользуюсь gnome-ppp - это GUI к wvdial и в конфиге логин и пароль на beeline надо заменить
можно запускать и от рута и от пользователя, но надо пользователю добавить права на использование модема

Оффлайн Mityai-78

  • Новичок
  • *
  • Сообщений: 33
    • Просмотр профиля
Re: ZTE MF626 и Ubuntu 9.10
« Ответ #19 : 06 Апрель 2010, 09:18:11 »
камрады. у меня такой же модем (ZTE MF626 от МТС) перечитал кучу инфы, но нефига не понял (Ubuntu пользуюсь недавно). можно пошагово объяснить, что сделать надо, что бы эта хрень заработала. если сделать можно через графический интерфейс, то будет ваще здорово.

Оффлайн Andersen

  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: ZTE MF626 и Ubuntu 9.10
« Ответ #20 : 30 Май 2010, 15:32:13 »
Всем привет! Юзаю Ubuntu 9.10 интернет через ZTE MF626 причем это единственный выход.Перечитал очень много по форуму в поисках решения по mf626,и (о,вот счастье!) все заработало.Поэтому хочу поделиться  дабы предупредить мытарства других.Все по порядку:
Проблемы: CD_STARTUP_FLAG  из файловой системы модема удаляем безжалостно
                      NetworkManager что-то он мне не понравился,поэтому его туда же.( wvdial рулит!)
После настройки wvdial.conf (у меня билайн) все коннектится все проги (Mozilla и т.п) работают,но всего несколько минут
 потом пишет что модем повесил трубку и все .Передергивать модем каждые 5 минут - тот еще интернет!После нескольких дней копания в интернете я нашел файлик mf626-b09-1.1(автору огромный респект).Далее разложил содержимое по папкам ,
reboot,запускаем sudo mf626-b09 ждем немного потом открываю другую консоль,там sudo wvdial  и все, я в сети.Никаких разрывов не наблюдал.
Если кто знает другой путь то пожалуйста,поправляйте

Оффлайн volkchara

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: ZTE MF626 и Ubuntu 9.10
« Ответ #21 : 18 Февраль 2011, 22:55:40 »
для разлочки непрошиваемого MF626, только кабелем с кнопкой, и прошивкой от тестла. если надо стучи 491925478

Оффлайн dj--alex

  • Старожил
  • *
  • Сообщений: 3209
  • Понимаешь, я какбы беру в руки лопату и говорю...
    • Просмотр профиля
    • все мои творения и занятия
Re: ZTE MF626 и Ubuntu 9.10
« Ответ #22 : 21 Март 2011, 22:41:51 »
делал по этому ману установку и настройку

http://startubuntu.ru/?p=5641

мтс-коннект   zte mf626

Выбираем пункт настроек: «Настройка последовательного порта», далее жмем клавишу «a», вводим:
/dev/ttyUSB1
(такого устройства вместо tty8 вообще нет)

проверить можно набрав  ati0

ничего не происходит - команда не найдена.
minicom: невозможно открыть /dev/ttyUSB1: Нет такого файла или каталога
user@user-desktop:/media/D/Games/Unreal Tournament/System$ ati0
ati0: command not found

разумеется выполнение последующих шагов тоже ведет к ошибке.
user@user-desktop:/media/D/Games/Unreal Tournament/System$ echo -e "AT+ZCDRUN=Ern" > /dev/ttyUSB1
bash: /dev/ttyUSB1: Отказано в доступе
user@user-desktop:/media/D/Games/Unreal Tournament/System$ sudo echo -e "AT+ZCDRUN=Ern" > /dev/ttyUSB1
bash: /dev/ttyUSB1: Отказано в доступе

мигает красная лампочка инета нет. только по выделенке можно что то делать.

ну почему производители мопедов так ненавидят линукс????


а вот это - установка mobile partner
user@user-desktop:/media/D/Games/UnrealTournament/System$ cd /home/user/Загрузки/MobilePartner
user@user-desktop:~/Загрузки/MobilePartner$ ./install
bash: ./install: Отказано в доступе
user@user-desktop:~/Загрузки/MobilePartner$ sh ./install
./install: 31: LANGUAGESTRING[0]=zh: not found
./install: 32: LANGUAGESTRING[1]=en_US: not found
./install: 33: LANGUAGECODE[0]=0: not found
./install: 34: LANGUAGECODE[1]=1: not found
./install: 37: Bad substitution
user@user-desktop:~/Загрузки/MobilePartner$ sudo  ./install
sudo: ./install: command not found
user@user-desktop:~/Загрузки/MobilePartner$ sudo install
install: пропущен операнд, задающий файл
Попробуйте `install --help' для получения более подробного описания.
user@user-desktop:~/Загрузки/MobilePartner$ sudo install install
install: после «install» пропущен операнд, задающий целевой файл
Попробуйте `install --help' для получения более подробного описания.
user@user-desktop:~/Загрузки/MobilePartner$

кое как установил - переместив на другой раздел с ntfs .
видимо noexec где то был , а на ntfs всё всегда работает

попробовал и gnome-ppp
тот же отстой что и другие программы
ни одной нормально рабочей нету
ещё одна пастебин:
http://pastebin.ubuntu.com/583498/
вопрос - конечно этот метод рабоатет - но скорость просто пипец (или это я отстал от времени? )
1кб\с (!!!)   так и должно работать?   или это назад в 1998 год к 56к модемам в режиме эмуляции?
после полуночи я думаю немного народа сидит в инете.  
яндекс 5 минут открывается. ужас тихий после выделенки :(

получилось... н блин   у меня 56к модем на телефоне быстрее работал !!!!!!
яндекс открывал меньше чем за минуту !!!!!!!!!!!!1
http://wow.chg.su/inside/filemgr.php?c=e5e5
ну как можно не открыть яндекс за такое количество времени?
даже ноликов понадописывал в скорость модема - не помогло.

интересно почему же мтс и билайн не сделали нормальную программу типа mobile partner какую сделал мегафон
денег не хватило ? :)))


« Последнее редактирование: 21 Март 2011, 23:42:47 от dj--alex »
Ubuntu 16.04.1 MATE x64, 18.1 x64 Mate, MX-Linux 16 Mate Mate Mate Mate. PC:?\FX4100@4ghz\8Gb\2TB HDD\1060gtx\90GB Ocz
https://forum.ubuntu.ru/index.php?topic=199897.0

Оффлайн Упс

  • Старожил
  • *
  • Сообщений: 3231
    • Просмотр профиля
Re: ZTE MF626 и Ubuntu 9.10
« Ответ #23 : 21 Март 2011, 23:58:01 »
Цитировать
интересно почему же мтс и билайн не сделали нормальную программу типа mobile partner какую сделал мегафон
Потому что NM проще и быстрее, без лишних вопросов, ничего лишнего.

Цитировать
Выбираем пункт настроек: «Настройка последовательного порта», далее жмем клавишу «a», вводим:
/dev/ttyUSB1
А почему не /dev/ttyUSB0 или /dev/ttyUSB3?
« Последнее редактирование: 22 Март 2011, 00:00:43 от Упс »
xUbuntu 12.04

Оффлайн dj--alex

  • Старожил
  • *
  • Сообщений: 3209
  • Понимаешь, я какбы беру в руки лопату и говорю...
    • Просмотр профиля
    • все мои творения и занятия
Re: ZTE MF626 и Ubuntu 9.10
« Ответ #24 : 22 Март 2011, 00:31:38 »
как написано в руководстве так и вводил . в инструкции должно быть всё вернее.
у меня модем оказался на ttyACM1 и причем он не всегда определяется. это я узнал из автодетекта гнома который настраивал позже.

nm - вообще отстой умеет только показывать что gprs\gsm сеть не найдена или что то вроде этого.
ни разу через него ни один мобильный "брелок" не запустился.

и что самое плохое на синем огоньке скорость вообще не держится (50кб\с),  часто на зеленый сваливается
а это - 1кб\с  ,  а что такое интернет на такой скорости это думаю обэяснять не надо.
обратно увы не возвращается.

у модема короче 3 режима работы - медленно, отвратительно и совсем нерабочий.
разнобразие так себе скажем.

или у меня в квартире мтс не берет. надеюсь в конечном пункте назначения лучше будет.
Ubuntu 16.04.1 MATE x64, 18.1 x64 Mate, MX-Linux 16 Mate Mate Mate Mate. PC:?\FX4100@4ghz\8Gb\2TB HDD\1060gtx\90GB Ocz
https://forum.ubuntu.ru/index.php?topic=199897.0

Оффлайн Упс

  • Старожил
  • *
  • Сообщений: 3231
    • Просмотр профиля
Re: ZTE MF626 и Ubuntu 9.10
« Ответ #25 : 22 Март 2011, 00:43:17 »
Цитировать
как написано в руководстве так и вводил . в инструкции должно быть всё вернее.
у меня модем оказался на ttyACM1 и причем он не всегда определяется. это я узнал из автодетекта гнома который настраивал позже.
На заборе тоже написано .....
Цитировать
nm - вообще отстой умеет только показывать что gprs\gsm сеть не найдена или что то вроде этого.
ни разу через него ни один мобильный "брелок" не запустился.
Несколько лет пользуюсь и никаких проблем, что телефон, что модем всё работает как часы.
Модем в режиме "только модем".
Цитировать
и что самое плохое на синем огоньке скорость вообще не держится (50кб\с),  часто на зеленый сваливается
а это - 1кб\с  ,  а что такое интернет на такой скорости это думаю обэяснять не надо.
обратно увы не возвращается.
Даже на телефоне(gprs) такого никогда не было.
Цитировать
или у меня в квартире мтс не берет. надеюсь в конечном пункте назначения лучше будет.
Подключение с помощью NM, если подвести курсор на значок NM показывает уровень сигнала в процентах.
xUbuntu 12.04

Оффлайн Root-Boot

  • Старожил
  • *
  • Сообщений: 1814
    • Просмотр профиля
Re: ZTE MF626 и Ubuntu 9.10
« Ответ #26 : 22 Март 2011, 02:05:57 »
Мне помогла завести 3g модем вот эта инструкция.
https://forum.ubuntu.ru/index.php?topic=110317.0
Тут описывается модем Beeline ZTE MF100, но сути это не меняет. У меня МТС МF112.
проверить можно набрав  ati0
ничего не происходит - команда не найдена.
minicom: невозможно открыть /dev/ttyUSB1: Нет такого файла или каталога
user@user-desktop:/media/D/Games/Unreal Tournament/System$ ati0
ati0: command not found
Команду ati0 надо вводить в самом minicom и.......
echo -e "AT+ZCDRUN=E\r\n" > /dev/ttyUSB1
echo -e "AT+ZCDRUN=8\r\n" > /dev/ttyUSB1
echo -e "AT+ZSNT=0,0,2" > /dev/ttyUSB1
...это тоже надо вводить в minicom, но после этого модем больше не заведется под Windows, мы же определяющие файлы снесли.
У меня получилось только так завести этот дивайс под Ubuntu 9.10.

 

Страница сгенерирована за 0.071 секунд. Запросов: 24.