Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: zlib  (Прочитано 10019 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Doonay

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
zlib
« : 06 Январь 2010, 22:41:39 »
Атэншн, я нуб.
решил поставить приложение интересное (celestia), оно требует сабж.
нашел, поставил. в кучу понаставил всего сопутствующего для сабжа, даже связку php+apache2+mysql.
запускаю ./configure  всё как положено, процесс идёт, но заканчивается таким предложением:
configure: error: zlib not found.

Внимание вопрос: Как этот зэдлиб включить?

Я 2 дня его искал и ставил, а теперь включить не могу. Что ему, заразе, еще надо?

Оффлайн stmc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1713
  • Arch Linux
    • Просмотр профиля
    • Моя страница на Launchpad
Re: zlib
« Ответ #1 : 06 Январь 2010, 23:10:04 »
есть такая крутая штука как менеджер пакетов Synaptic в Система > Администрирование

p/s обычно при компиляции нужны еще пакеты c пометкой -dev (для разработчиков)


да и вообще нафига вам компилить когда оно есть в репах
в терминале:
sudo apt-get install celestia
« Последнее редактирование: 06 Январь 2010, 23:16:54 от stmc »

Оффлайн Doonay

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: zlib
« Ответ #2 : 06 Январь 2010, 23:19:53 »
елы палы, вручную всё переконопатил, а синаптиком воспользоваться в голову не пришло. но это от того, что исходник Celestia я качал с их родного сайта, и в голову не пришло, что она может быть в стандартных репозиториях. попробую сейчас. спасибо

Пользователь решил продолжить мысль 06 Январь 2010, 23:30:22:
всё работает. в следующий раз буду проверять сначала стандартные репозитории. сэнкью мистер =)
« Последнее редактирование: 06 Январь 2010, 23:30:22 от Doonay »

Оффлайн Gadd

  • Участник
  • *
  • Сообщений: 209
    • Просмотр профиля
Re: zlib
« Ответ #3 : 04 Март 2010, 20:25:40 »
А у меня вопрос стоит этот. Решил поставить последнюю версию Celestia 1.6.0 (только в виде исходников есть на оф.сайте). В синаптике видел только 1.5.1. Заодно решил потренироваться в сборке deb-пакета. Для начала попробовал юзать GiftWrap, но не нашёл как указать ему, что надо собирать не с
./configure
, а
./configure --with-gnome
Он доходил до этого пункта и ругался (вернее configure ругалось), что надо параметр указать. Затем решил сделать сам с помощью мануала. Но при выполнении
./configure --with-gnome
вконце выдавало вот это:
checking for X... no
checking for deflate in -lz... no
configure: error: zlib not found.


поиски zlib в репах привели только к похожим пакетам (ставил zlib1g-dbg,  zlibc, zlib1g-dev, zlib1g уже стояло). Пробовал что-то ещё. Короче - не помогло. Ситуация не изменилась.
Дошел до http://www.zlib.net/, но там только исходники. Гуглизм ни к чему не привел, только к таким же ищущим, например тут (не хочу заново качать), тут и тут. Дело видимо не только в бубунте.
Итого: что делать? ставить zlib из исходников? А поможет ли?
требовало в качестве зависимости autotools-dev - поставил через синаптик.
Конфигурация:
Юзер - новичек
ОС - Ubuntu 9.10 amd64
Ubuntu 16.04 x86_64
AMD FX X8 8350, Gigabyte 990FXA-UD3 (rev 3.0), GeForce GTX760 2ГБ
Установлены все обновления

Оффлайн Упс

  • Старожил
  • *
  • Сообщений: 3231
    • Просмотр профиля
Re: zlib
« Ответ #4 : 04 Март 2010, 21:41:31 »
xUbuntu 12.04

Оффлайн Gadd

  • Участник
  • *
  • Сообщений: 209
    • Просмотр профиля
Re: zlib
« Ответ #5 : 04 Март 2010, 23:27:35 »
Намек понял, хотя я о таком уже имел хоть какое-то представление.

Попробовал сначала собрать zlib c помощью GiftWrap , и опять неудача - захотел GiftWrap использовать опцию --build-что-то-там-про-x86-64,  а конфигуре её не оценил. Ну да ладно.
Короче собрал я zlib:
./configure --prefix=/opt/zlib   (может зря? может надо было без префикса?)
make
make install
Все встало без ошибок.
Перешел к Celestia:
./configure
и в конце выдало уже родное:
checking for X... no
checking for deflate in -lz... no
configure: error: zlib not found.


Итого: не помогло!
может Celestia глючная?
Ubuntu 16.04 x86_64
AMD FX X8 8350, Gigabyte 990FXA-UD3 (rev 3.0), GeForce GTX760 2ГБ
Установлены все обновления

Oni-chan

  • Гость
Re: zlib
« Ответ #6 : 04 Март 2010, 23:51:51 »
ну поставь то, что ему нужно
zlib1g-dev
xorg-dev

Оффлайн Gadd

  • Участник
  • *
  • Сообщений: 209
    • Просмотр профиля
Re: zlib
« Ответ #7 : 05 Март 2010, 00:33:49 »
Поставил xorg-dev (zlib1g-dev уже стоял). Проблема ушла, но пришла другая:
checking GL/glu.h usability... no
checking GL/glu.h presence... no
checking for GL/glu.h... no
configure: error: No glu.h found. See INSTALL file for help.

Посмотрел INSTALL и поставил libglu1-mesa-dev. Проблема ушла.  Ща требует установить зависимости (вроде как):
checking for GTK... configure: error: Package requirements (libgnomeui-2.0 gtk+-2.0 >= 2.6 gtkglext-1.0) were not met:

No package 'libgnomeui-2.0' found
No package 'gtk+-2.0' found
No package 'gtkglext-1.0' found


Ну тут вроде почти понятно, хотя в синаптике нет пакетов с точно такими названиями (стоит уже, например, libgnomeui-0).
Возникают риторические вопросы: Надо ставить какой-либо мета-пакет? Версия может быть 2.0 или больше?
Короче, буду разбираться завтра. По результатам отпишусь. Но если кто что знает - не откажусь от помощи.

Кстати, Shtsh, откуда взял инфу, что требовался xorg-dev?
Ubuntu 16.04 x86_64
AMD FX X8 8350, Gigabyte 990FXA-UD3 (rev 3.0), GeForce GTX760 2ГБ
Установлены все обновления

Оффлайн arrecck

  • Старожил
  • *
  • Сообщений: 1726
    • Просмотр профиля
Re: zlib
« Ответ #8 : 05 Март 2010, 00:42:51 »
sudo apt-get build-dep celestiaбери сырцы из svn, те что на сайте пришлось править инклуды, все ставится на ура, играюсь

Оффлайн hhex

  • Участник
  • *
  • Сообщений: 108
  • я знаю что ничего не знаю
    • Просмотр профиля
Re: zlib
« Ответ #9 : 05 Март 2010, 04:31:22 »

No package 'libgnomeui-2.0' found
No package 'gtk+-2.0' found
No package 'gtkglext-1.0' found
поставь libgnomeui-dev, libgtk2.0-dev, libgtkglext1-dev и снова попробуй

Пользователь решил продолжить мысль 05 Март 2010, 04:42:26:
Кстати, Shtsh, откуда взял инфу, что требовался xorg-dev?
графический сервер Xorg часто называют иксами, X и есть Xorg,
ну а постольку поскольку ты собираешь из исходников, то xorg-dev необходим для сборки,
пакеты с пометкой -dev почти всегда нужны при сборке из исходников, но это не значит что нужно
ставить все подряд пакеты с пометкой -dev, только те что просят  ;)
« Последнее редактирование: 05 Март 2010, 04:42:26 от hhex »

Оффлайн Gadd

  • Участник
  • *
  • Сообщений: 209
    • Просмотр профиля
Re: zlib
« Ответ #10 : 05 Март 2010, 19:36:45 »
поставь libgnomeui-dev, libgtk2.0-dev, libgtkglext1-dev и снова попробуй

Поставил. Все пошло. Разбираюсь дальше. Спасибо!

Пользователь решил продолжить мысль 05 Март 2010, 18:06:24:
бери сырцы из svn, те что на сайте пришлось править инклуды, все ставится на ура, играюсь

и точно... после make ругается на celx.h и celx_internal.h
Причем создалось впечатление, что ошибка не в самих *.h, а в переменных окпужения (или как они там зовутся - переменные препроцессора, передающиеся из make-файлов и др., короче при сборке, в частности LUA_VER и им подобные. Сам я в программировании не очень). Ибо ругается исключительно на все, связанное с этим самым lua.
попробовал посмотреть сами файлы, но мало что понял. Мож кто в курсе?

arrecck, а ты сам правил? или качал заново? Ибо у меня инет по трафику, перекачивать заново напряжно.


З.Ы. пора тему переименовать в "Сборка Celestia в deb-пакет своими руками" или что-то подобное.
З.З.Ы. вложение - ругань компилятора. Толку от него мало, но вдруг поможет?
« Последнее редактирование: 05 Март 2010, 20:09:35 от Gadd »
Ubuntu 16.04 x86_64
AMD FX X8 8350, Gigabyte 990FXA-UD3 (rev 3.0), GeForce GTX760 2ГБ
Установлены все обновления

Оффлайн arrecck

  • Старожил
  • *
  • Сообщений: 1726
    • Просмотр профиля
Re: zlib
« Ответ #11 : 05 Март 2010, 20:28:57 »
Цитировать
../celestia/celx.h:26:17: error: lua.h: No such file or directory
ты луа не поставил, locate lua.h должен быть в /usr/include, сделай apt-get build-dep celestia, он должен все зависимости подтянуть (если нет то ставь liblua5.1-0-dev или для поиска dev пакетов apt-file search lua.h | grep dev)
какие файлы правил не помню, там компилятор ругался на sprintf и EOF, добавлял #include <stdio.h>, потом была ошибка с правами доступа, в итоге скачал из svn более новую версию, плюс с опцией --with-gnome не работало, делал --with-gtk

 

Оффлайн Gadd

  • Участник
  • *
  • Сообщений: 209
    • Просмотр профиля
Re: zlib
« Ответ #12 : 05 Март 2010, 20:58:40 »
Хм... а ведь отсутствие *.h файла я заметил...  :o Только когда пошёл копать глубже - начисто все забыл...  :idiot2: Ща буду пробовать.

Пришлось доставлять liblua5.1-0-dev. А apt-get build-dep celestia не помогло.

Пользователь решил продолжить мысль 05 Март 2010, 18:03:49:
Итого:
В файлах
celestia-1.6.0/src/celengine/overlay.h
celestia-1.6.0/src/celengine/star.cpp
celestia-1.6.0/src/celengine/star.h
(на него не ругался, но на всякий тоже сделал)
записал строчку #include <stdio.h>
make заработал.

Далее после дебианизации по мануалу не заработало нормально dpkg-buildpackage -rfakeroot. Снова требовало --with-gnome, что вылечилось добавлением данного параметра в файле celestia-1.6.0/debian/rules в строку
   ./configure $(CROSS) --prefix=/usr --with-gnome --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
далее все пошло. Пакет собрался. Единственно - были замечания в конце сборки deb-пакета:
dpkg-shlibdeps: предупреждение: зависимости от libSM.so.6 можно избежать, если "debian/celestia/usr/bin/celestia" не будет бесполезно скомпонована с ней (не используется ни одного её символа).
dpkg-shlibdeps: предупреждение: зависимости от libgthread-2.0.so.0 можно избежать, если "debian/celestia/usr/bin/celestia" не будет бесполезно скомпонована с ней (не используется ни одного её символа).
dpkg-shlibdeps: предупреждение: зависимости от libart_lgpl_2.so.2 можно избежать, если "debian/celestia/usr/bin/celestia" не будет бесполезно скомпонована с ней (не используется ни одного её символа).
dpkg-shlibdeps: предупреждение: зависимости от libpangoft2-1.0.so.0 можно избежать, если "debian/celestia/usr/bin/celestia" не будет бесполезно скомпонована с ней (не используется ни одного её символа).

И это только часть сообщений. Я так понял эти файлы закачались вместе с мета-пакетом и не учавствовали в процессе. Вопрос - где их убрать?
Сразу после установки пакета в трее выскочил красный кружок с крестиком, который вещал что-то про ошибки в зависимостях, но сейчас он пропал, а повторная переустановка пакета его не вызвало. Видимо что-то не так.
А программа запустилась.
В дополнение скажу, что ключем не подписывал, поэтому: gpg: [stdin]: clearsign failed: секретный ключ не найден, но меня этот вопрос не взволновал особенно - выкладывать пакет никуда не собираюсь, а позже может ключ и сделаю.
Ещё один вопрос: есть ли правила, описывающие общие принципы именования пакетов с учетом их сборки (номер версии, особые отметки и т.д.). Видимо есть здесь, но может есть где кратенько? Не горит, если честно, просто интересно, надо будет - сам найду.

« Последнее редактирование: 05 Март 2010, 22:07:29 от Gadd »
Ubuntu 16.04 x86_64
AMD FX X8 8350, Gigabyte 990FXA-UD3 (rev 3.0), GeForce GTX760 2ГБ
Установлены все обновления

 

Страница сгенерирована за 0.068 секунд. Запросов: 22.