Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Отвалился Eth0 не могу решить проблему.[РЕШЕНО]  (Прочитано 10807 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн shude

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Всем привет. Вобщем проблема такая. На стареньком ноуте поднял сервак 9.10 Ubuntu.
Все работало как часы. На днях клинанул вентилятор на проце - в следствие чего аварийное выключение из-за перегрева проца.
Я впервый раз не понял из-за чего вырубился сервак и включил его, все заработало. Но через несколько часов он опять вырубился и тут я почувствал причину. пергрев.  Земинл кулер включил. вроде все норм.

Пропал интерфейс eth0.

/etc/network/interfaces
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp


ifconfig выдает только интерфейс lo

---------------------------------------------------------
В сети нашел, что можно попробовать удалить из /etc/udev/rules.d/70-persistent-net.rules  все старые сетевухи.
Пробовал не помогло.
на команду /etc/init.d/networking restart

SIOCSIFADDR: No such device
eth0: ERROR While getting interface flags: No such device
eth0: ERROR While getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up eth0

---------------------------------------------------------

Хотел поиграться с modprobe , но как оказалось папки /etc/modules у меня вовсе нет.

lshw -C net выдает следующее
(Нажмите, чтобы показать/скрыть)

И тоже самое для Wi-fi карточки ниже. (ну она мне не нужна вовсе).

Если кто знает как подрубить буду признателен, ибо два дня в гугле проблему не решили.

 
« Последнее редактирование: 08 Февраль 2010, 19:48:32 от shude »

Оффлайн athost

  • Старожил
  • *
  • Сообщений: 1897
    • Просмотр профиля
Re: Отвалился Eth0 не могу решить проблему.
« Ответ #1 : 08 Февраль 2010, 15:08:01 »
lspci -k | grep -iA2 ether   

Оффлайн shude

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: Отвалился Eth0 не могу решить проблему.
« Ответ #2 : 08 Февраль 2010, 15:14:36 »
lspci -k | grep -iA2 ether   

06:01.0 Ethernet controller: Broadcom corporation BCM4401-B0 100Base-TX (rev 02)
                 Kernel modules: b44
06:02.0 Network controller: Broadcom corporation BCM4318 [AirForce One 54g] 802.11g Wireless Lan Controller (rev 02)

Оффлайн athost

  • Старожил
  • *
  • Сообщений: 1897
    • Просмотр профиля
Re: Отвалился Eth0 не могу решить проблему.
« Ответ #3 : 08 Февраль 2010, 15:17:25 »
sudo modprobe -i b44   

Оффлайн shude

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: Отвалился Eth0 не могу решить проблему.
« Ответ #4 : 08 Февраль 2010, 15:21:40 »
sudo modprobe -i b44   

Fatal: Error inserting b44 (/lib/modules/2.6.31.19-generic-pae/kernel/drivers/net/b44.ko): Unknown symbol in module, or unknown parameter (see dmesg)

Оффлайн athost

  • Старожил
  • *
  • Сообщений: 1897
    • Просмотр профиля
Re: Отвалился Eth0 не могу решить проблему.
« Ответ #5 : 08 Февраль 2010, 15:24:28 »
Цитировать
(see dmesg) 

А что dmesg то пишет после этого? И дай ка uname -a


Оффлайн shude

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: Отвалился Eth0 не могу решить проблему.
« Ответ #6 : 08 Февраль 2010, 15:27:46 »
Цитировать
(see dmesg) 

А что dmesg то пишет после этого? И дай ка uname -a



dmesg выводит вот что:
(Нажмите, чтобы показать/скрыть)

uname -a
Linux QWERTY1 2.6.31-19-generic-pae #56-Ubuntu SMP Thu Jan 28 02:29:51 UTC 2010 i686 GNU/Linux

Оффлайн athost

  • Старожил
  • *
  • Сообщений: 1897
    • Просмотр профиля
Re: Отвалился Eth0 не могу решить проблему.
« Ответ #7 : 08 Февраль 2010, 15:43:19 »
А покажи lsmod

Пользователь решил продолжить мысль 08 Февраль 2010, 15:48:52:
И не надо фотографировать экран. Выведи результат в файл и выложи его.
« Последнее редактирование: 08 Февраль 2010, 15:48:52 от athost »

Оффлайн shude

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: Отвалился Eth0 не могу решить проблему.
« Ответ #8 : 08 Февраль 2010, 15:50:03 »
А покажи lsmod

Пользователь решил продолжить мысль [time]Mon Feb  8 13:48:52 2010[/time]:
И не надо фотографировать экран. Выведи результат в файл и выложи его.

(Нажмите, чтобы показать/скрыть)

Выложить файл не могу. Нет сети ведь
Если только подмонтировать фотик как флешку. Подскажи команду монтирования накопителя. Я выложу в файлах все тогда
« Последнее редактирование: 08 Февраль 2010, 15:52:00 от shude »

Оффлайн athost

  • Старожил
  • *
  • Сообщений: 1897
    • Просмотр профиля
Re: Отвалился Eth0 не могу решить проблему.
« Ответ #9 : 08 Февраль 2010, 15:53:28 »
Хрен его знает, почему модуль не грузится. Я бы переставил ядро и пересобрал модули (если ядро самосборное)
« Последнее редактирование: 08 Февраль 2010, 15:58:45 от athost »

Оффлайн shude

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: Отвалился Eth0 не могу решить проблему.
« Ответ #10 : 08 Февраль 2010, 15:59:10 »
Хрен его знает, почему модуль не грузится. Я бы переставил ядро и пересобрал модули (если ядро сомосборное)

Нет, ядро не самосборное. Ставил с дистриба все как есть.
А как можно пересобрать ядро и модули ?  может есть ссылочка ?

Оффлайн athost

  • Старожил
  • *
  • Сообщений: 1897
    • Просмотр профиля
Re: Отвалился Eth0 не могу решить проблему.
« Ответ #11 : 08 Февраль 2010, 16:07:56 »
Ну попробуй просто пакет с ядром переставить

Оффлайн shude

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: Отвалился Eth0 не могу решить проблему.
« Ответ #12 : 08 Февраль 2010, 16:12:40 »
Ну попробуй просто пакет с ядром переставить

В том то и дело, что я не знаю как переставить пакет с ядром.

т.е. Где его взять например (при неработающей сети)
и как установить.

Оффлайн athost

  • Старожил
  • *
  • Сообщений: 1897
    • Просмотр профиля
Re: Отвалился Eth0 не могу решить проблему.
« Ответ #13 : 08 Февраль 2010, 16:46:04 »
Скачай на компе с инетом пакет linux-image-server и установи на серваке.
« Последнее редактирование: 08 Февраль 2010, 16:47:58 от athost »

Оффлайн shude

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: Отвалился Eth0 не могу решить проблему.
« Ответ #14 : 08 Февраль 2010, 19:47:57 »
Скачай на компе с инетом пакет linux-image-server и установи на серваке.

Спасибо! Все реально заработало.

Для тех кто столкнется с подобным пишу как я сделал.

В моем случае полетели не только сетевые интерфейсы, но и большинство модулей. Я не мог подрубить ни флешку ни прочитать диск.

Зарезал на болвану образ установочника Ubuntu Desktop , загрузился с него. И сеть и все остальное заработало.
Далее вот от сюда http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.31.5/ вытягиваем

linux-headers-2.6.31-02063105_2.6.31-02063105_all.deb
linux-headers-2.6.31-02063105-generic_2.6.31-02063105_i386.deb
linux-image-2.6.31-02063105-generic_2.6.31-02063105_i386.deb

Сохраняю на жесткий, перегружаюсь.
Далее идем в папку куда сохранили вышеперечисленные 3 пакета и пишем
sudo dpkg -i linux-headers-2.6.31-02063105_2.6.31-02063105_all.deb linux-headers-2.6.31-02063105-generic_2.6.31-02063105_i386.deb linux-image-2.6.31-02063105-generic_2.6.31-02063105_i386.deb

После этого перегружаемся е все работает ! :)

 

Страница сгенерирована за 0.064 секунд. Запросов: 23.